Touchpad settings ignored/missing after update

Changing the /org/gnome/desktop/peripherals/touchpad settings in dconf have no effect. “gsettings get” agree with dconf but no effect.
In the new GNOME settings section mouse & touchpad there are no settings for touchpad input anymore only Mouse and General. The computer is a Macbook air (mid 2013).

Other dconf periferals settings work like: keyboard, displays. The touchpad works well in otherwise. (although it is hard to write on a laptop with large touchpad when tap-to-click is enabled causing constant accidental clicks)

I suspect the problem appeared when updating to GNOME 3.26 the other week at witch point I belive the settings where changed back to default.

I have run out of things to test… What can I have done wrong? Or is this a known issue / where should I report it?

So there are no setting options under System Settings -> Devices -> Mouse & Touchpad?

Are you running Wayland or X?

Only mouse and general settings, no touchpad settings

Are you running Wayland or X?

Wayland as it is the default in TW

OK, I have an older MacBook (2007) and in both Xwayland and X I see Touchpad settings, if plug a mouse in those settings appear as well.

As root user, what is the output for;

hwinfo --mouse


  sudo hwinfo --mouse 
40: USB 00.2: 10503 USB Mouse                                   
  [Created at usb.122]
  Unique ID: q5Ea.l0o61Jx+a04
  Parent ID: k4bc.2DFUsyrieMD
  SysFS ID: /devices/pci0000:00/0000:00:14.0/usb1/1-5/1-5:1.2
  SysFS BusID: 1-5:1.2
**   Hardware Class: mouse**
**   Model: "Apple Internal Keyboard / Trackpad"**
  Hotplug: USB
  Vendor: usb 0x05ac "Apple, Inc."
  Device: usb 0x0290 "Apple Internal Keyboard / Trackpad"
  Revision: "1.71"
  Serial ID: "DQ632743KM6F94QAW1A"
  Compatible to: int 0x0210 0x0001
  Driver: "bcm5974"
  Driver Modules: "bcm5974"
  Device File: /dev/input/mice (/dev/input/mouse0)
  Device Files: /dev/input/mice, /dev/input/mouse0, /dev/input/event13, /dev/input/by-id/usb-Apple_Inc._Apple_Internal_Keyboard___Trackpad_DQ632743KM6F94QAW1A-if02-event-mouse, /dev/input/by-path/pci-0000:00:14.0-usb-0:5:1.2-event-mouse, /dev/input/by-id/usb-Apple_Inc._Apple_Internal_Keyboard___Trackpad_DQ632743KM6F94QAW1A-if02-mouse, /dev/input/by-path/pci-0000:00:14.0-usb-0:5:1.2-mouse
  Device Number: char 13:63 (char 13:32)
  Speed: 12 Mbps
  Module Alias: "usb:v05ACp0290d0171dc00dsc00dp00ic03isc01ip02in02"
  Driver Info #0:
    Buttons: 1
    Wheels: 0
    XFree86 Protocol: explorerps/2
    GPM Protocol: exps2
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #39 (Hub)

I guess that explains why I cant change the touchpad settings as the system thinks my touchpad is a mouse…

I guess that explains why I cant change the touchpad settings as the system thinks my touchpad is a mouse…

Yes that does appear to be the case. FWIW, the exact capabilities of the device can be examined using

sudo libinput-list-devices

As libinput is work in progress, a bug report may be needed to get this device handled properly.

Bug reporting…

The relevant (I hope) part of the output of libinput-list-devices:

Device:           Apple Inc. Apple Internal Keyboard / Trackpad
Kernel:           /dev/input/event5
Group:            7
Seat:             seat0, default
Capabilities:     keyboard 
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      n/a
Nat.scrolling:    n/a
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   none
Click methods:    none
Disable-w-typing: n/a
Accel profiles:   n/a
Rotation:         n/a

Device:           bcm5974
Kernel:           /dev/input/event13
Group:            8
Seat:             seat0, default
Size:             105x75mm
Capabilities:     pointer 
Tap-to-click:     disabled
Tap-and-drag:     enabled
Tap drag lock:    disabled
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: disabled
Calibration:      n/a
Scroll methods:   *two-finger edge 
Click methods:    button-areas *clickfinger 
Disable-w-typing: enabled
Accel profiles:   none
Rotation:         n/a

Ok, I will try and put together a bug report

Actually, the output for the touchpad looks ok to me, and ‘Tap-to-ckick’ is disabled.

Yes, but still it is not actually disabled… This is all very weird.

Created a bug report. "]](

You have inadvertently added a bracket character to the URL. It should be

Yes, sorry, tried to make the link pretty but only made it pretty useless.

The latest bet is that the bug is not in libinput and my bug report there is now resolved as “not our bug”.

I wouldn’t be surprised. The output you posted here doesn’t suggest any issues with the touchpad device.

So the “solution” to this problem eventually consisted of me reinstalling Tumbleweed. After re-installation the settings worked again.

Still have no idea what caused it but at least it is working now.

Thank you all for your help.