touchpad & netbook

On my 32-bit Intel Atom Netbook the Touchpad was working well when I had pre-installed Ubuntu-8.04.
After installing opensuse-11.3 with an installation-ubs created with terminal-command

dd if=opensuse-11.5-Gnome-Live-CD1.iso of=/dev/sdb bs=4M

the touchpad is not responding and I am taking help of an usb-mouse.
I have searched /etc/sysconfig but has found no line for touchpad.
I may mention that I have installed opensuse-11.3 on another laptop with the helo of the
same usb-stick and that laptop has no problem.
Thanks for help.

Try enabling Touchpad into KDE Control Center (Mouse & Keyboard).

If it doesn’t work, check if the synaptiks package is installed.

Do you mean Yast and Add/Remove packages? I am now logged in my other laptop and will try tpmorrow mornig.

Nope. I mean KDE Control Center… It’s different from YaST control center. You can easily find typing “settings” inside kickoff menu and hitting the first occurance.

About synaptiks package, yes, i meant Add/Remove Packages, found in YaST.

Let me add what further I found. In yast —>hardware there is no touchpad but yes mouse is there. Clicking it gave me a long list which contains among others
PS/2 mouse (Aux-Port)
Microsoft compatible serial mouse - (tty SO-COM1)
Sun Mouse - (/dev/sunmouse) but in my /dev there is no such entry
IntelliMouse Explorer (ps2).

In /etc/syslog again there is no touchpad but there is a file “mouse” which shows
MOUSEDEVICE = “/dev/input/mice”
MOUSETYPE = “exps2”
FULLNAME = “22_exps2”
XMOUSETYPE = "/dev/input/mice’
WHEELS = “1”
XMOUSETYPE = “Explorer PS/2”

In the laptop (Gnome, kernel on which touchpad is responding has nothing after
and the only difference is
MOUSETYPE = “imps2”

The Netbook where the touchpad is not responding has Gnome, kernel 2.6.34-12-default

In the list of Add/Remove Software I could not distinguish packages for touchpad/mouse.

And I could not find KDE control center in Main Menu on the Panel.

And I am waiting for further advice.

Firstly, all the advice about KDE is irrelevant if you are using Gnome. Secondly, assuming you do not have a separate mouse, it appears that you can only configure your touchpad as a mouse - this will limit what you can do. Try using the mouse configuration options to see if they have any effect on the way your touchpad responds.

Since the touchpad is not responding I am using an external usb-mouse (actually a Microsoft Mouse). I generally carry the Netbook
with me when I am away from HomeBase and I prefer not to carry the external mouse. So kindly advise me how I shall configure my touchpad as a my. I am an end-user.

However, i was wondering if the problem is of more mundane origin like the touchpad having somehow been jammed.

I’ll be waiting and Thanks.

I am trying varying options to solve this problem. I downloaded synaptics-latest.tar.gz and after creating the synaptics-0.1.1/ directory ran ./configure The result gave among others
checking for working aclocal… missing
checking for working autoconf… missing
checking for working automake… missing
checking for working autoheader… missing
checking for working makeinfo… missing

Everything else gave ‘yes’ as the answer.
Of course the touchpad is still unresponsive.
What next? Thanks.

If it has any relevance, after installing evdev from oss the /etc/X11/xorg.conf.d/10-evdev.conf has the following lines

Section “InputClass”
Identifier “evdev touchpad catchall”
MatchIsTouchpad “on”
MatchDevicePath “/dev/input/event*”
Driver “evdev”

This is the first time that I have found any mention of touchpad.

Interesting suggestion considering that the user stated the following and I quote:

dd if=opensuse-11.5-Gnome-Live-CD1.iso of=/dev/sdb bs=4M

which clearly points that the user is using GNOME. So, I would assume within the boudaries of my limited knowledge that the user can’t load KDE control center because he isn’t just using KDE :slight_smile:

My advice would be to check out the output of


and check if the pointing device is actually picked up there. If it’s the case and confirmed by /var/log/messages that there are no issues, then we could take another approch and check Xorg logs for anything that might be useful.

Anyway you can post on SUSE Paste the log contents of:

dmesg (you can save the output into a file by running: dmesg > dmesg-log.txt which will create a dmesg-log.txt file)

Share it with us, so we can take a more helpful approach.

I wanted to send /var/log/messages, /var/log/dmesg-log.txt, /boot/grub/menu.lst, /etc/sysconfig/mouse, /etc/X11/xorg.conf.d/10-evdev.conf and /etc/X11/xorg.conf.d/11-mouse.conf; but could not find an option for uploading of fies. Kindly show a way. I could not manage SusePaste.

Copy the contents of the files to, select like 1 week so the contents will be available for 1 week and it will return you a link. Just publish the link here.

In practice something like this will happen:

SUSE Paste


I had a little play with GNOME on my netbook recently and configured the touchpad.

You should have a utility called gsynaptics installed. You need to execute that utility to configure your touchpad but you also need to ensure it is executed at your GNOME session startup as gsynaptics --init to load your settings from its configuration file.

Please check the gsynaptics manpage as I am making this post entirely from memory.

Neil Darlow

I found gsynaptics and gsyaptics-lang in add/remove softwware and installed them; but there was no gsynaptics-init. Even after reboting the tuchpad is unresponsive. Even Even pressing Fn+F6 is not making any difference.

I am sorry that I could not make my predicament clear when I wrote that I could not manage SusePaste. What I meant is that
when I tried to copy dmesg-log.txt for pasting only the first frame on the terminal window got captured and not the whole file.
If you give me an e-mail address I can send the files as attachments

No, you should run gsynaptics with the argument –init during your GNOME session startup.

Neil Darlow

Let me confess that I am an end-user.
I ran #gsynaptic --init and was told that I have to se ‘SHMConfig’ ‘true’ in xorg.conf or XF86Config. But my machine has no xorg.conf or XF86Config. However, there is a directory /etc/X11/xorg.conf.d/ which has got a file 50-synaptics.conf with entries

Section “InputClass”
Identifier “touchpad catchall”
Driver “synaptics”
MatchIsTouchpad “on”
MatchDevicePath “/dev/input/event*”
Option “HorizScrollDelta” “0”

Shall I put in this file the line

Option “SHMConfig” “true”

and then reboot the system?

And what shall I understand by 'during Gnoe session startup? Sorry for bothering all of you.

Setting SHMConfig should not be required on a modern GNOME installation and, as a KDE user, I can’t offer assistance with that.

There should be settings in GNOME Control Center for Startup/Shutdown and you would create an entry for gsynaptics --init there.

At this point I really need a competent GNOME user to step in and provide you with assistance as my knowledge is limited in this area.

Neil Darlow

I just found out that the netbook has alps touchpad. Where shall I find its driver for opensuse-11.4?