Touch pad Problems

I have a toshiba laptop with a synoptics touch pad. It was working perfectly until just recently. Whenever I login under my default user, it stops responding as soon as gnome pops up. When I login under root, it works perfectly again.

I’m running opensuse 11.0 and I’m fairly new to linux, could you guys guide me in the right direction to getting my mouse to work again correctly?

Also, I do not have access to an external mouse as the only one I have is ps/2 and there are no tech shops in my area.

go to control panel>sessions, uncheck ‘touchpad’ and reboot.
you can navigate with tab and arrows.

Thanks to modulep!

Your answer helped me, too.

I had until yesterday the same problem with Suse 11.0 on my notebook (Samsung X20 1730 V with intel 915 on board graphic) and it’s touchpad (synaptics). I tried a lot without much success (see: =; I also switched mouse and tochpad in the control bord. But I had a USB-mouse ad hand, so I mad a new normal (not-root) user and in this second profile/user the touchpad worked again normal.

Thanks to modulep’s advice now the fist normal user can also use the touchpad again (including the virtual mouse wheel).

I think the problem has something to do with the 3D Effects (and maybe the mouse control with sax2). It appeared after I switched the desktop-effects (Compitz) on in the first normal profile and wasn’t there in the second profil (in which I will always work without wabbeling windows ect. out of caution).

After going to control panel>sessions, and unchecking ‘touchpad’ I can now use 3D and touchpad in first profile. But I wonder
why there was before that something aktivated (checked) that deactivated my touchpad (“gsynaptics-init --sm-disable”). Is this a general bug or had just roccomonte and I done the same things wrong?


you’re most welcome :slight_smile:
i noticed that after fresh install touchpad keeps working until you run yast>touchpad setings.
it even affects kde if gsynaptics is installed (removing ‘touchpad’ from kde-startup-programs solves problem).
quick bugzilla search returned this:
#16 mentions similar workaround.

Yes, your right modulep:
You don’t have to turn on the (3D) desktop effects to produce the malfunction/not-at-all-function of the touchpad. All that is needed for the malfunktion is to adjust something in the mouse configuration under yast/sax2.

But I presume still that bug has something to do with two or more possible ways of configure the mouse/touchpad in the normal 2D and the 3D settings and possible conflicting settings:
I had today an quite similar problem with the keyboard (but it kept working) - you can also configure that under (sax2 3D = run:/usr/sbin/sax2 > keyboard) AND under control panel>hardware>keyboard (2D-Gnome = run:gnome-keyboard-properties).

I think the programs should communicate with another or bloc one another or the installer yast2 should set something like negative dependencies: a warning and a suggestion to uninstall one program (for example if you are installing both programs; and gsynaptics or whatever is there conflicting/possible conflicting).