Toshiba Satellite P200 overheating

Firstly, I apologise in advance as I know this is a common problem but alot of the information on the web relating to it is outdated or too technical for my newbie mind to comprehend :stuck_out_tongue: any help would be much appreciated! :slight_smile:

I recently installed Ubuntu 11.04 on my Toshiba Satellite P200-1K8 laptop; with Ubuntu the fans were always running at full blast and the laptop would overheat and shut down even though I wasn’t using the computer for anything intensive, e.g.just browsing YouTube. I installed openSuse thinking the problem might have been with Ubuntu but in Suse as well the fans seem to be running full blast right from start up and the laptop getting quite hot. I’ve now learnt this is a generic problem with toshiba satellite laptops and linux, something to do with acpi and possibly the ATI graphics cards? My gpu is an ATI Mobility Radeon 2600 if thats any help. In Windows (which I was last using two days ago) the fans and heat from the laptop were nowhere near this noticeable and I didn’t experience this overheating problem just browsing the web.

Could anyone recommend any fixes to better the heat management of my laptop on Linux (apart from cleaning the fan which I’ve already tried :P)?

Thanks for any help :slight_smile:

If you think it may be acpi have you considered running it without acpi as a test?

As root in a terminal type: service acpid stop

I don’t have my Satellite in front of me so I can’t check but the answer, I think, is a boot option (add to your grub menu) like “acpi=linux”. That’s from memory, but googling for this and similar options might be your quickest route to a solution.

If your fans are running full speed and a laptop is still getting too hot one must consider that your heat sinks inside could be full of dust, which is possible once a laptop is over one year old and in lots of usage. Get you a couple of cans of Duster (cans of compressed air) and blow out the dust from ALL open vents on this Laptop. I suggest two cans because they get cold in use and can freeze up the nozzle. Just switch to the second can and continue blowing out the dust. Once the cans thaw out, they will work just fine again on your next dirty computer.

Thank You,

Thanks for all the replies. The problem with the P200 laptop is that its very hard to open up (numerous small screws), in the past I have removed almost every screw I could find and still couldn’t open up the chassis to clean the fan. I figured I wasn’t experienced enough to be messing around with computer innards that had obviously been designed to be a bit hard to get at and tried to clean the fan through the vents, but I think I may have ended up blowing a good deal of the dust deeper into the laptop >< … lol. :slight_smile: I am guessing the overheating is not purely hardware based as in Windows these problems never occurred, except maybe if I had been playing a 3D game for a long while.

The most frustrating thing is, I had Ubuntu 10.04 on my laptop in the past (about a year ago) and had the exact same problem, but I remember somehow overcoming it but not exactly how! The old forum threads I find on google relating to this problem don’t seem very helpful and I can’t find a/the solution anywhere.

Ecky, I executed the “service acpid stop,” there is no noticeable effect afaik. Gminnerup, have you had a similar problem? Can you remember the exact acpi argument? I googled acpi=linux but to no avail unfortunately :frowning: the only arguments I can seem to find are acpi=off or acpi=force, both of which I’m somewhat unsure to use. For the moment I will keep the laptop on a dinner plate as a makeshift heat sink and I will try cleaning out the laptop fans once more. Thanks!

On 06/10/2011 06:06 PM, xenon18 wrote:
>
> I am guessing the overheating is not purely
> hardware based as in Windows these problems never occurred

you are correct! what you might do is write an email to Toshiba and ATI
and ask them to pretty please send you the power/heat management.
graphics and other drivers which are equal in function and capability to
the drivers they provide to the buyers of their hardware who use MS
Windows…

and, wait and see how quickly they send you those…

in your second note you could just ask them to work closely with the
Linux driver writers (like they do with the Windows developers) to
insure Linux users get the same battery life, low noise level, low heat
output and etc etc etc…


dd CAVEAT: http://is.gd/bpoMD
via NNTP openSUSE 11.4 [2.6.37.6-0.5] + KDE 4.6.0 + Thunderbird 3.1.10
Acer Aspire One D255, 1.66 GHz Atom, 1 GB RAM, Intel Pineview graphics

  • When your gecko is broken you have a reptile dysfunction! *

First off, you do not need to take the computer case off to blow out the dust, just blow into all of the vents. Second, consider changing the CPU power setup in YaST:

CPU Speed control exists now in YaST. Why not do the following, open:

YaST / Software / Software Management, search on Power and install yast2-power-management. Once done, restart YaST.

Next:

YaST / System / System Services (Runlevel), select Expert Mode Bullet at the top left:

Now:

Find and highlight pm-profiler and then select the button on the bottom right and Enable the pm-profile Service and answer yes to the added services requested.

Next:

Select the button on the bottom left and Start the pm-profiler Servrce. You should get a good start with a 0 error return code.

Now select the finish button on the bottom right and allow your selections to be saved.

Now:

YaST / System / Power Management. You can select from three choices with Power Saving doing what I think you are looking for. I would select Powersaving to reduce CPU power usage and perhaps energy creation.

Thank You,

I just cleaned out my fans using pressurised air, I was surprised at how much dust came out! My laptop does not seem to be overheating as much anymore and is definitely functional in this state, thanks! I installed the yast2 power manager and tried doing the pm-profiler service thing, it said haldaemon was missing? And (subsequently) there is no Power Management option under YaST/System :frowning:

In other news, the window title bars for my programs have suddenly disappeared, meaning I can’t drag the windows or close/minimise/maximise them, but I guess that is another topic :slight_smile:

I just cleaned out my fans using pressurised air, I was surprised at how much dust came out! My laptop does not seem to be overheating as much anymore and is definitely functional in this state, thanks! I installed the yast2 power manager and tried doing the pm-profiler service thing, it said haldaemon was missing? And (subsequently) there is no Power Management option under YaST/System :frowning:

In other news, the window title bars for my programs have suddenly disappeared, meaning I can’t drag the windows or close/minimise/maximise them, but I guess that is another topic :slight_smile:
As for the YaST Power Management, you need to follow my steps exactly as this really does work. As for the windows border, make sure you are using the KDE Plasmoid Desktop. When you log into KDE, select the sessions icon on the Bottom Left and select the right KDE desktop to run. If you have activated Compiz, this can also be a symptom of that operation. I would reboot, disable Compiz (only if you enabled it) and make sure you had the right desktop and then go back into YaST and try again for the Power Management.

Thank You,

Sorry, I should’ve mentioned I am using the Gnome desktop. Either way, a reboot cured that problem but I’ve bookmarked this thread if it were to occur in future. Unfortunately my laptop did overheat again, funnily enough while watching another youtube video :slight_smile: perhaps I’ll have to stay away from there lol. When I get to the point where I click to enable pm-profile an alert comes up saying:

To enable service pm-profiler in runlevels 2, 3, 5,
these services must be additionally enabled,
because it depends on them:
haldaemon.

I click “continue” and then another alert comes up:

These required services are missing:
haldaemon.

I click “continue” and then nothing. Although when I click Start now… in the bottom left the same sequence of alerts comes up but then a return 0 (success) alert comes up immediately after.

/etc/init.d/pm-profiler start returned 0 (success):

I exit and save results. Would the power management option be different in Gnome to KDE? There are power management options in the “Control Centre” but no power saving option or anything, more deciding how long the computer idles before sleeping etc

Thanks for your continued replies, I am following your instructions to the T. I am considering contacting Toshiba for their opinion on the matter as I cannot use my laptop for much more than an hour at a time at the moment unless I switch back to Windows. Any other ideas? :slight_smile:

I exit and save results. Would the power management option be different in Gnome to KDE? There are power management options in the “Control Centre” but no power saving option or anything, more deciding how long the computer idles before sleeping etc

Thanks for your continued replies, I am following your instructions to the T. I am considering contacting Toshiba for their opinion on the matter as I cannot use my laptop for much more than an hour at a time at the moment unless I switch back to Windows. Any other ideas? :slight_smile:
So we are talking about running YaST. While some of YaST functions can be run outside of YaST, if you run YaST, after my instructions, the Power Savings Program should be there (YaST / System / Power Management). I show to run YaST as a GUI, the command is:

/usr/bin/xdg-su -c /sbin/yast2

It is true I don’t use GNOME, but YaST is YaST in any Desktop as far as I know.

Thank You,

Just tried again and I found the Power Management by typing it in the YaST search box, it was under YaST/Miscellaneous/Power Management. I have switched to the “Power Saving” profile and will let you know how it runs! Thanks for all your help so far :slight_smile:

Just tried again and I found the Power Management by typing it in the YaST search box, it was under YaST/Miscellaneous/Power Management. I have switched to the “Power Saving” profile and will let you know how it runs! Thanks for all your help so far :slight_smile:
Well happy to hear you did find the program. It is odd that it was placed in a different location when done under GNOME. I must remember that in the future. So now you have been able to blow dust out of your internal heat sinks and it is amazing how much dust can build up there. AND you have installed the CPU speed control which when set to power savings should reduce the heat generated by the CPU.

Please let us know if these steps where of benefit to you and good luck!

Thank You,

Just checked my Satellite and there’s nothing in the boot options anymore, yet it works! But definitely, when I first bought my Satellite 300 and installed openSUSE (then probably 11.2), the fan would come on after a short while and never stop again. The boot option I then installed in my Grub menu, and which worked instantly, was “acpi_osi=linux”. How did I find that out? By remembering that I had posted about this in an earlier thread here:

Fan goes crazy and keeps spinning - Page 2

Indeed, the issue comes up repeatedly in the Laptop subforum, you might check out the above and similar threads there, even repost there. But try out the boot option first, it might work for you as it did for me. Why I no longer need it, I have no idea! No need to edit your grub/menu.lst permanently to try it out, just enter the above at the menu screen and hit Enter. Good luck!

EDIT: You don’t say which version of openSUSE you’ve installed. If <11.4, the fact that I don’t need the boot option anymore might just mean that an upgrade to 11.4 solves it for you…

The fans used in many of the Toshiba Laptops are of an interesting design that may, in part, explain your problem. I note that you report that your fans are running at full speed at startup, so this may not apply, but check just in case. Note: most Toshibas have two fans. We’ve had a couple of ours crash when we could hear the fans, only to realize that one was running and the other is not.

I’ve even noticed that a couple of our Toshibas start up fine, but, when the power management allows the fans to shut down briefly, they don’t restart when needed. There’s a simple reason, and it’s mechanical. The peculiar design of the fan itself is at fault. The fan assembly consists of a housing, a motor secured to the inside of the housing and a plastic blade assembly. Unlike most fans which have the blades secured to a central motor shaft, these blades are part of a single plastic part that consists of the blades, a central shaft that inserts into the motor assembly and a shroud/skirt that covers the motor but spins with the blades. The problem comes when a little dirt begins to find its way into the assembly. Some of the dirt gets into the interior of the fan and coats the shaft, the outside of the motor and the inside of the shroud. As the fan spins that crud gets transformed into a sticky mess that causes the fan blades to need a great deal more force from the motor to make them spin. The problem is sometimes worse when the machine is hot than when cold, making the negative effect on cooling all the worse.

The ONLY way to solve this is to disassemble the PC and remove and clean the fan blade assembly. No amount of canned air or compressed air will do anything more than clean the heat exchanger (and maybe even force some of that crud further into the fan assembly.)

Taking apart a Toshiba Laptop is a daunting task (see my post here, look for post #23). There are good tutorials on line that’ll give you guidance. Try this one. A couple of tips though.

  1. If you follow a tutorial and the PC still won’t come apart remember to look for the little numbers embossed in the Toshiba’s plastic housings right next to the screw heads. Each of the screws with a number next to it has to come out at some point in the whole tedious process of dis-assembly, even thought the tutorial might have forgotten to mention it. If a screw has no number next to it it probably stays, but not always.

  2. Take the steps in the tutorial in order. Don’t skip ahead and take them out of order!

  3. Don’t rush, take your time, especially when handling the little fine wires and cables.

Once you get the fans out just lift the fan blades out and clean the shaft, shroud and motor housing with a cotton swab soaked in rubbing alcohol. Apply one drop (not more) of good quality oil to the shaft and put it all back together.

Good luck. I’ve solved my problems with two PCs this way so far, and the fellow who taught me (Ry) has cured dozens of Toshibas this way.

Note: nothing said above means I dislike Toshiba. Every brand has its flaws, and this one is minor compared to some other brands.

All very interesting but as the OP’s Satellite doesn’t exhibit these symptoms under Windows but only Linux (Ubuntu and openSUSE) it’s hardly caused by the mechanics of the fan…

Thanks, unfortunately my laptop overheated again within two hours of turning on even with “Power Saving” enabled, it may have helped a little bit though. For clarification I’m using openSuse 11.4

Just checked my Satellite and there’s nothing in the boot options anymore, yet it works! But definitely, when I first bought my Satellite 300 and installed openSUSE (then probably 11.2), the fan would come on after a short while and never stop again. The boot option I then installed in my Grub menu, and which worked instantly, was “acpi_osi=linux”. How did I find that out? By remembering that I had posted about this in an earlier thread here:

Fan goes crazy and keeps spinning - Page 2

Indeed, the issue comes up repeatedly in the Laptop subforum, you might check out the above and similar threads there, even repost there. But try out the boot option first, it might work for you as it did for me. Why I no longer need it, I have no idea! No need to edit your grub/menu.lst permanently to try it out, just enter the above at the menu screen and hit Enter. Good luck!

EDIT: You don’t say which version of openSUSE you’ve installed. If <11.4, the fact that I don’t need the boot option anymore might just mean that an upgrade to 11.4 solves it for you…

Thanks, I’m trying it now. I’m using acpi_osi=linux as a temporary boot argument at the moment as I can’t seem to open the menu.lst file even as a superuser.

sudo gedit /boot/grub/menu.lst
(gedit:6354): Gtk-WARNING **: cannot open display:

I think I remember the previous time I had this problem it may have been a boot option that solved the problem as well, but I’ll report back how this goes :slight_smile:

The fans used in many of the Toshiba Laptops are of an interesting design that may, in part, explain your problem. I note that you report that your fans are running at full speed at startup, so this may not apply, but check just in case. Note: most Toshibas have two fans. We’ve had a couple of ours crash when we could hear the fans, only to realize that one was running and the other is not.

I’ve even noticed that a couple of our Toshibas start up fine, but, when the power management allows the fans to shut down briefly, they don’t restart when needed. There’s a simple reason, and it’s mechanical. The peculiar design of the fan itself is at fault. The fan assembly consists of a housing, a motor secured to the inside of the housing and a plastic blade assembly. Unlike most fans which have the blades secured to a central motor shaft, these blades are part of a single plastic part that consists of the blades, a central shaft that inserts into the motor assembly and a shroud/skirt that covers the motor but spins with the blades. The problem comes when a little dirt begins to find its way into the assembly. Some of the dirt gets into the interior of the fan and coats the shaft, the outside of the motor and the inside of the shroud. As the fan spins that crud gets transformed into a sticky mess that causes the fan blades to need a great deal more force from the motor to make them spin. The problem is sometimes worse when the machine is hot than when cold, making the negative effect on cooling all the worse.

The ONLY way to solve this is to disassemble the PC and remove and clean the fan blade assembly. No amount of canned air or compressed air will do anything more than clean the heat exchanger (and maybe even force some of that crud further into the fan assembly.)

Taking apart a Toshiba Laptop is a daunting task (see my post here, look for post #23). There are good tutorials on line that’ll give you guidance. Try this one. A couple of tips though.

  1. If you follow a tutorial and the PC still won’t come apart remember to look for the little numbers embossed in the Toshiba’s plastic housings right next to the screw heads. Each of the screws with a number next to it has to come out at some point in the whole tedious process of dis-assembly, even thought the tutorial might have forgotten to mention it. If a screw has no number next to it it probably stays, but not always.

  2. Take the steps in the tutorial in order. Don’t skip ahead and take them out of order!

  3. Don’t rush, take your time, especially when handling the little fine wires and cables.

Once you get the fans out just lift the fan blades out and clean the shaft, shroud and motor housing with a cotton swab soaked in rubbing alcohol. Apply one drop (not more) of good quality oil to the shaft and put it all back together.

Good luck. I’ve solved my problems with two PCs this way so far, and the fellow who taught me (Ry) has cured dozens of Toshibas this way.

Note: nothing said above means I dislike Toshiba. Every brand has its flaws, and this one is minor compared to some other brands.

I have rechecked and my fans are almost silent on start-up, but slowly increase as time goes on until the laptop chassis is hot to the touch and eventually the laptop shuts down. After about 10 minutes I can turn it on again but this time the laptop will have fans full blast. Also (curiously) if I’m using the laptop on battery power and then plug in the charger the fans will immediately spin up. Since I am currently on the first boot of the day and on battery the laptop is behaving itself for the moment. Currently I’m balancing the laptop on top of a dinner plate so the underside vents of the laptop aren’t simply on hard table and have some room to circulate air. I’ve also noticed that one side of the laptop emits noticeably more hot air than the other (the cd drive side).

I am not keen on disassembling my laptop, but it is four years old now and I’ve never cleaned the fans from the inside. Its somewhat irksome that the fans are not easily accessible, and I will have to take apart the whole laptop to get at them :(. I will follow the tutorial and keep your tips in mind, once I’ve got some time. My laptop didn’t overheat in normal use on Windows, but I guess I will have to do this eventually anyway so I may as well address the problem fully. Just need to buy some thermal grease and a superfine screwdriver to get at the screws I couldn’t get at easily before :slight_smile:

Thanks for all the detailed replies, I will keep you updated :slight_smile:

Have you ever look at using a Laptop cooler pad before? They can help if you mainly use your Laptop in one location. Many computer stores carry them.

Thank You,

On 06/11/2011 09:06 PM, xenon18 wrote:
>
> My laptop didn’t overheat in normal use on Windows

my normal advice: Use what works! if windows works for you, use it…

there is no telling what magic interconnect the windows driver has with
that hardware that can never be duplicated by the Linux driver
developers because Toshiba will not tell them the secrets…

the best way to have a fully linux capable laptop is to buy one with
linux installed by the maker/seller…


dd CAVEAT: http://is.gd/bpoMD
via NNTP openSUSE 11.4 [2.6.37.6-0.5] + KDE 4.6.0 + Thunderbird 3.1.10
Acer Aspire One D255, 1.66 GHz Atom, 1 GB RAM, Intel Pineview graphics

  • When your gecko is broken you have a reptile dysfunction! *

You should be able to edit the grub menu from Yast. From memory of my days using Gnome, gedit can be a temperamental beast :wink:
Also rmember what my message in the thread I provided a link to said: it may be necessary to update the BIOS before the boot option works. I had to do it, and I think my Satellite is of more recent vintage than yours. I definitely don’t think there’s a need for hardware disassembly and all the risks involved if it works in Windows.