Toshiba Qosmio X505 + Linux = Doomed?

preface: the internet has not given me high hopes about getting Linux onto this laptop, and my first few attempts at OpenSUSE haven’t, either. I am hoping that at least one among you can help a novice Linux-user get this show on the road… I’ve used Ubuntu before, but I’m looking for something more… well, more like OpenSUSE. ;D

I have a Toshiba Qosmio X505-Q865. it was a hand-me-down from my roommate, who got a new laptop. it came with Windows 7 Home Premium 64-bit pre-installed. however, after a couple-few years, the label with the key is worn away, and so I don’t have a valid Windows key for it. I wouldn’t mind – I’ve been meaning to make the switch to Linux – but all of my research online leads me to believe that Linux is simply incompatible with this laptop. (most of what has documentation is Ubuntu, fwiw.) I tried installing it last night; I was dozing off when I glanced at it and saw that the installation had an error. as such, I can’t say that I recall terribly well what the error was. I will duplicate it momentarily and post an update to this.

until then, my main question is simple: is OpenSUSE compatible with my laptop, and/or can it be made so? if not, what is my best option?

thanks so much.

Be sure you run media check from the first install menu to test that you have a good install disk.

Installing a new OS when you are tired is probably not the best time. :sarcastic:

Without the error I doubt any can help.

That’s a 2010 vintage model with nothing too weird in the spec’s. The processor is an i5. Various models of LAN and WIFI cards used and were supplied by intel, realtek or atheros, all of which are fairly common. The video is from nvidia, and there’s certainly support for that, either with open source nouveau or drivers from nvidia. The only major component I can’t id is the sound card, however I’m betting that the fact that it’s a two year old unit will pretty much assure that it’s supported by openSUSE 12.2.

My guess is that it should be a fairly straightforward install.

If you’re having issues I too would suspect a problem with media you’re using to install from.

PS. Welcome aboard

okay, so a curious turn of events! I went to duplicate the error… and couldn’t! it installed perfectly, with a few exceptions, not the least of which is booting afterward. I took pictures with my phone, so they’re not the best, but might be enough to tell what’s going on? click to see the large versions; I didn’t want to make this thread unbearable to scroll through.](

this was what happened when I first selected to install. I waited a minute, like I did last night, and it turned into…

… a perfectly normal install?!](

so, the install goes something like this…](](

essentially off to a good start. it didn’t stick at 0%, which was promising.

(continued in new reply; can’t post more than four images in each…)

(continued from above)](](

I took tons of pictures of this, in case it glitched, but first it was halfway, and then done!

… don’t celebrate yet, guys. after the restart, I got this again…](

… followed by this bunch of fun stuff …](

(again, continued in a new reply due to image limits…)

also, I forgot to mention before, this is with openSUSE 12.2.

does that help at all? >_>;

… and ending with the Maze Screen of Death, which seems to be like a graphics card BSOD? x_x;](

I’ve seen a few ideas of “how to fix this” but mostly they’re terminal commands, and… I think the issue might be that my graphics card needs a driver that it doesn’t have? or is it something else?

all correct. Intel i5 (two cores, not four) with Realtek LAN/wifi, nVidia video, Conexant audio. a screen cap from my previous Windows install:

anyhow, given the new developments, the install media is fine… if it’s as simple as the driver, how do I get it installed without… well, being able to use my openSUSE install? >_>

sorry to be so ridiculously new at this, ahaha. I’m trying to learn. also, hopefully I provided enough pictures and information?

thanks! :smiley:

On 2012-11-25 01:36, phoenixbellamy wrote:
> sorry to be so ridiculously new at this, ahaha. I’m trying to learn.
> also, hopefully I provided enough pictures and information?

Unfortunately for you, I read the forum via nntp, so no photos. And if I
went to http to see the photos, my internet is capped to 500 MB/month,
so I will not.

Perhaps if you describe the problem I might try to help :slight_smile:

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” (Minas Tirith))

the error is always either black and white stripes with coloured speckles, or a black and white maze-looking design. that’s what’s important in those images. the stripes happened at the beginning of the install, but the screen returned to normal shortly thereafter and installed without incident. then the stripes happened again when attempting to boot into the new install of openSUSE, followed by a page-full of command-line-looking stuff… most lines begin with “Started…” and then at the end, “Re-starting syslog services / Probing connected terminal… // Initializing virtual console… // Found a Linux console terminal on /dev/console (210 columns x 59 lines)”… followed shortly thereafter by the black and white maze screen, which stayed that way for upwards of 10 minutes before I just turned it off.

does that help?

On 2012-11-25 03:06, phoenixbellamy wrote:
> does that help?

It looks like you have to switch to the proprietary nvidia vide driver.

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” (Minas Tirith))

First try to boot to rescue mode that should use another lower level driver then install the NVIDIA driver through Yast.

yes, if you read my prior posts, I had already figured out that I need the nVidia video driver. this isn’t a matter of “switching” to it… it has NEVER booted into the full operating system after installing. I have not installed ANY video drivers. I am very aware that I NEED to, but no one is telling me HOW. do you understand my dilemma?

tried it. it gives me the same black-and-white stripes. it will not boot into ANYTHING. it gives me the options, I select one, it tries to load, and then stripes. beyond that, even if I ever did get it to load, I don’t know how to use YaST, or which driver to install, etc. I am very new to this, and I’m sorry if the answers I’m getting “seem obvious” to you guys, but they don’t to me. :frowning:

We completely understand your frustration. We’ve all been there, even though we sometimes forget that someone just starting out may not yet understand the terminology that we’ve now become comfortable with. Don’t worry, you’ll get there soon.

I’m sure you’ll have an easier time getting accurate guidance, targeted to your individual situation, if you could first provide us with the answers to a few basic questions.

  1. What version of openSUSE are you trying to install?

  2. 32 bit or 64 bit?

  3. from DVD, CD or??

  4. Have you confirmed that the media is good? Did you check the MD5 sum on the download? Did you verify that the install media is good?

  5. What’s your video card? Answer: NVIDIA® GeForce® GTS 360M

  6. What’s your level of experience with Linux? With using command line?

  7. Do you know how to use YAST? answer: not yet

  8. Do you know how to use zypper?

Sorry, I had to run out and didn’t get to finish my pevious post…

I have a couple of very similar computers running here, and my gut feeling is that you may be dealing with faulty install media more than missing drivers. I’m sure you’ll want to install the nvidia drivers eventually, but my own experience indicates that that PC should work with open SUSE 12.x right out of the box. I could be wrong of course :wink: but I’d sure like to know you’d tested the media before the install.