Toshiba laptop cannot sleep

Hi,
I am new to Linux. I find OPENSUSE 11.3 is very interesting and useful to me. Unfortunately, my laptop (Toshiba A-60, 512MB ram, 40GB hard disk) cannot sleep. I have tried stickies on s2ram and the associated parameter combinations. No success. The screen is black, there is no fan turning, only the hard disk has a short start noise.

When I enter: s2ram -i, it displays:


This machine can be identified by:
sys_vendor = “TOSHIBA”
sys_product = “Satellite A60”
sys_version = “PSA60C-JL100E”
bios_version = “Version 1.40”
See http://en.opensuse.org/S2ram for details.

If you report a problem, please include the complete output above.
If you report success, please make sure you tested it from both X and
the text console and preferably without proprietary drivers.

When I enter “s2ram -n”, it displays:

Machine unknown
This machine can be identified by:
sys_vendor = “TOSHIBA”
sys_product = “Satellite A60”
sys_version = “PSA60C-JL100E”
bios_version = “Version 1.40”
See http://en.opensuse.org/S2ram for details.

I do not know whether my laptop is on the whitelist or not.

Second, I find that the resume parameter in menu.lst is different from the examples on web. It is right or not, see below please (menu.lst is from /boot/grub/:

Modified by YaST2. Last modification on Wed Oct 6 07:19:00 EDT 2010

THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader

Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

default 0
timeout 8
gfxmenu (hd0,0)/message
##YaST - activate

###Don’t change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.3 - 2.6.34-12
root (hd0,0)
kernel /vmlinuz-2.6.34-12-default root=/dev/sda2 resume=/dev/disk/by-id/ata-IC25N040ATMR04-0_MRG2DFKBCZ6JUP-part3 splash=silent quiet showopts vga=0x317
initrd /initrd-2.6.34-12-default

###Don’t change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe – openSUSE 11.3 - 2.6.34-12
root (hd0,0)
kernel /vmlinuz-2.6.34-12-default root=/dev/disk/by-id/ata-IC25N040ATMR04-0_MRG2DFKBCZ6JUP-part2 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x317
initrd /initrd-2.6.34-12-default

The display device parameters are these (from Hardware information, Yast2):
. RS250 4437
…Card Type: AGP
…Class (spec): VGA-compatible controller
…Class: Display controller
…Device: RS250 4437
…Driver: radeon
…Hwcfg Bus: pci
…Kernel Driver: drm
…Model: ATI RS240 4437
…Old Unique Key: hCZQ.DESLZPmmZ2E

,
I searched on web, which tells me that the graphics chip is an ATI 7000 series.

The boot displays: vga=0x317. I have tried vga=0, but s2ram cannot run correctly either.

Could you help me on the suspend to ram problem? Thanks.

Hi,
I want to add the following facts to my post.
. After I suspend to ram, it halts. Sometimes I can shut it down with holding the power button for several seconds (about 10s). Sometimes I have to disconnect the AC line and cold start.
. The “Restart computer” selection never works. I can only hold the power button to shut it down.

Thanks.

Many Toshiba Laptop’s with ATI graphics cannot resume from suspend to ram. my satelite l300 doesn’t come out of suspend to ram in Windows Vista or Linux. It goes into suspend fine but can’t resume and needs a hard power-off. my sister’s a60 with ATI graphics and XP does work but her linux 11.2 also doesn’t work. We both have the feature disabled as no work-arounds have worked on our machines.
Our restart works with suspend to ram disabled.