Too much idle RAM usage - KDE plasma

I have 6gb ddr3 ram and at idle around 4gb is being used

System monitor screenshots : https://susepaste.org/87183450 https://susepaste.org/53784122
System information Screenshots : https://susepaste.org/54202264 https://susepaste.org/36317352Neofetch : https://susepaste.org/12716160

This is using more ram that even WINDOWS 10 !!!

Hope this info is enough.
Thanks :slight_smile:

BTW firefox was open but i had only susepaste open so that i can post my screenshots . Even after FF is closed and no applications are running approx 3.5GB RAM is in use:(

Here is RAM usage without any applications open . I closed Firefox , discover and keepass

https://susepaste.org/45376708
https://susepaste.org/93320487>:(

For what? :wink: …and how much is “too much”? Does it impact upon your use of the system? Is the swap space constantly being used?

Have you looked to see what processes are actually using the memory? (Using “top” for example, shift+m will list by memory usage.)

My problem is , no applications are using RAM using GUI system monitor or top but total RAM usage remains high. The processes RAM usage and total RAM usage are not adding up.

So… perhaps, as the crystal ball is rather hazy, you could show us your output from top.

I’m seeing something like this:

https://paste.opensuse.org/view/raw/57a5e6a2

but we need to see, what you’re seeing :wink:

SUSE Paste (here i replaced my user processes with xxxxxxx as i wanted to keep my username private)

I actually sent it in the post already

Edit:

I realised that buff/cache is taking up all of the memory

:slight_smile:

found the solution here LMAO

https://www.linuxatemyram.com/
rotfl!

Hi
Clear the cache?


echo 3 > /proc/sys/vm/drop_caches

OK… all is good then. :slight_smile:

As an aside, it’s easy to get hung up on memory usage, personally I don’t worry how much free memory there is, provided the system isn’t using swap space; after all, memory is there to be used.

Yep.

I didnt erase the cache as there is no point of doing that . Erasing cache might actually make my PC slower as i have a spinny boi 5400rpmlol!
Anyways , linux knows how to manage RAM usage and cache as it been 30yrs to get figured out . Might as well not bother about it

thanks;)

from https://www.linuxatemyram.com/

Why is it doing this? Disk caching makes the system much faster and more responsive! There are no downsides, except for confusing newbies. It does not take memory away from applications in any way, ever!
What if I want to run more applications? If your applications want more memory, they just take back a chunk that the disk cache borrowed. Disk cache can always be given back to applications immediately! You are not low on ram!
Do I need more swap? No, disk caching only borrows the ram that applications don’t currently want. It will not use swap. If applications want more memory, they just take it back from the disk cache. They will not start swapping.
How do I stop Linux from doing this? You can’t disable disk caching. The only reason anyone ever wants to disable disk caching is because they think it takes memory away from their applications, which it doesn’t! Disk cache makes applications load faster and run smoother, but it NEVER EVER takes memory away from them! Therefore, there’s absolutely no reason to disable it!

so im not doing anything and leaving it as it is

Thanks for all the help :)lol!

Cached reads are way faster than even reads from NVMe PCIe 3.0 x4 disks:

erlangen:~ # hdparm -tT /dev/nvme0n1
/dev/nvme0n1:
 Timing cached reads:   41360 MB in  1.98 seconds = 20841.48 MB/sec
 Timing buffered disk reads: 5656 MB in  3.00 seconds = 1884.91 MB/sec
erlangen:~ # 

Host erlangen responds fast after reboot. The machine responds even faster with available RAM being used by buff/cache.

erlangen:~ # free -h
               total        used        free      shared  buff/cache   available
Mem:            31Gi       5.7Gi        20Gi       205Mi       4.5Gi        24Gi
Swap:             0B          0B          0B
erlangen:~ # 

WOW , Thats impressive!