TLP conflict with tuned

sudo zypper dup
[sudo] password for root: 
Loading repository data...
Reading installed packages...
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Computing distribution upgrade...

Problem: 1: the to be installed tlp-1.6.1-2.1.noarch conflicts with 'tuned' provided by the installed tuned-2.22.1.2+git.86ac977-3.1.noarch
 Solution 1: deinstallation of tlp-1.6.1-1.3.noarch
 Solution 2: deinstallation of tuned-2.22.1.2+git.86ac977-3.1.noarch
 Solution 3: keep obsolete tlp-1.6.1-1.3.noarch

Choose from above solutions by number or cancel [1/2/3/c/d/?] (c): 
2 Likes

Seems to be on purpose: 1224202 – [Build 20240513] upgrade issues due to tuned newly conflicting with tlp/popwer-profiles-daemon

noted, I just asked what to do.

You can use tuned, or tlp, you can’t use both, you need to pick one.

@40476 What was your decision?

remove tuned, have not restarted my computer though.

I’m running TW, Gnome, Wayland on an AMD laptop. I’m having the same issue. Should I choose tlp or tuned? Is either one fine?

Bonus question: Why choose one over the other?

I looked at 1224202 – [Build 20240513] upgrade issues due to tuned newly conflicting with tlp/popwer-profiles-daemon and it made zero sense to me. I’m a tech noob.

Why remove tuned vs removing tlp?

Based on https://bugzilla.opensuse.org/show_bug.cgi?id=1224202#c9 it looks like tlp is ok on a laptop while tuned is ok on a server, the point being battery use and suspend/resume, but I don’t have specific knowledge here and would like the opinion of members with more experience.

1 Like

Having the same issue here, how to pick one?
What is to be considered when keeping one of them and discarding the other?

The package description and documentation gives a good hint what to preserve.

Tuned is a really limited tool for really specific hardware. Tlp is more mighty and independent from the hardware.

1 Like

I was a bit clueless about what to choose, as it’s too long since I have done anything like this manually.
Running TW KDE on an Intel CPU laptop and looking at the linked bug discussion:

  • patterns-base recommends tuned
  • patterns-mobile recommends tlp
  • gnome/kde recommend power-profiles-daemon

I have chosen to remove tuned.

After a restart, tlp.service was not running, so I had to enable and start it (sudo systemctl enable --now tlp.service).

Now it is enabled and active, but has preset disabled:

sudo systemctl status tlp.service 
● tlp.service - TLP system startup/shutdown
     Loaded: loaded (/usr/lib/systemd/system/tlp.service; **enabled**; preset: **disabled**)
     Active: **active (exited)** since Fri 2024-05-24 11:41:32 EEST; 4s ago
       Docs: https://linrunner.de/tlp
    Process: 5859 ExecStart=/usr/sbin/tlp init start (code=exited, status=0/SUCCESS)
   Main PID: 5859 (code=exited, status=0/SUCCESS)
        CPU: 319ms

May 24 11:41:31 T5PT310-1 systemd[1]: Starting TLP system startup/shutdown...
May 24 11:41:32 T5PT310-1 tlp[5859]: Applying power save settings...done.
May 24 11:41:32 T5PT310-1 tlp[5859]: Setting battery charge thresholds...done.
May 24 11:41:32 T5PT310-1 systemd[1]: Finished TLP system startup/shutdown.

I am not sure if I had “Power profiles” installed previously or if these have been removed with tuned, but I don’t have these currently:
openSUSE-TW-KDE-PowerProfiles_20240524_122013

I will have to see how this behaves.

2 Likes

Hi , I did some testing , my setup is:
• XP9700 with 4k display , dual NVME
• brightness set to 20%
• wifi on and connected, BT on and connected to mouse
• OpenSuse Tumbleweed with latest updates and 6.7.5 kernel
• KDE plasma 5.27.10 on Wayland and a number of autostart apps
• I did restart before each test both for PowerProfilesDaemon (PPD) and TLP.

PPD : in power-saving mode using KDE was a pain I experienced 1-2 seconds gui freezes, plasma animation stutters and I can literately feel system was extremely slow , still power consumption/discharge rate was huge on performance mode I the experience was OK but with a lot of heat forcing the fan to go crazy or if I forced thermal mode to quiet my laptop would burn my hands.

TLP: all works smooth, no option to change modes in KDE plasma integration on power connect/disconnect events but it seams TLP is clever enough so no manual settings are required.

Measurements: See the graph where I marked PPD with yellow and TLP with green.

Conclusions : I changed to PPD some time ago when I discovered Alex’s Dell-power-manager app that supported it well, then I discovered PPD had nice integration with KDE plasma that allowed me (in gui) to set profile changes to power-saving when AC was disconnected.
Now after comparing the data and the experiences I am reverting back to TLP and I recommend the same.

3 Likes

same, had to enable it.

Same problem here. I did remove tuned and also add a lock the package to be sure it would not come back next update … (zypper al tuned).

I removed tuned and my system seems to be working normally.

My system boots to the CLI after running sudo systemctl enable --now tlp.service

I can access my system by running startplasma-wayland, but the issue re-occurs on every reboot.

Any ideas what I may be doing wrong?

When you want your problem to get the maximum of exposure, then better start a new topic and do not hang it at the end someone else’s solved one.

Thanks.

There’s already a thread here.

Then why do you post here? People will not like it when parallel discussions are going on. And if I am correct it is explicitly forbidden to multi-post.