Tint2 - I'm baffled.

Hi. I thought I would expand my knowledge a bit and build a customized DE with openbox, tint2, nitrogen and picom etc. It all seemed to work out of the box until I notice that all the icons in the tint2 launcher are screwed up but still launch their apps. No amount of tweaking the settings fixed thing.

See the two square ‘icons’ in the launcher on the left hand side in the pic https://paste.opensuse.org/47849402 .

However the same icons present ok in the task bar when the app is running. I have tried this on both 15.2 and tumbleweed (having the latest version 16.7 of tint2) in a VM as well on my PC and laptop.

If I exit tint2 but run it at the command line I get this https://paste.opensuse.org/77027211 . Don’t know why it says “Could not find icon ‘(null)’, using default” when the desktop icon is seen in the task bar.

I even tried to compile my own tint2 but opensuse repos are missing at least 1 devel file.

Anyway, this is non fatal for me as it is just playing but I’d like to know if anyone can run tint2 under 15.2 or tumbleweed or knows why the launcher icons are screwed up.


Bug report is needed.