TightVNC and Gnome

Hi,

How can I get tightvnc to use gnome?

This is my xstartup script, but it doesn’t work for gnome :frowning:

#!/bin/sh

xrdb $HOME/.Xresources
xsetroot -solid grey
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
#twm &
gnome-session &

Alternatively, if someone knows how to setup tightvnc to start at the login screen/manager?

Thanks.

I always run:
vncviewer ipaddress:1
From a terminal to start a graphic login and it always works. It defaults to the login user’s theme settings for both kde and gnome sessions.

This will do it:

#!/bin/sh
/usr/bin/gnome &

Reference: TightVNC (VNC Xvnc) on openSUSE as Client or Server (Remote Desktop Connections)

Hi whych,

Thanks for the reply. Sorry, I should of mentioned I’m trying to connect from a Windows XP laptop, so I’m using the TightVNC Viewer program to connect. I assume your referring to connecting from another Linux box.

So I can learn something new for future reference as I’m still a Linux newbie. When you say start a graphic login from a terminal, what do you mean and how do you do it?

Hi swerdna,

Thanks for the reply. Unfortunately your suggestion didn’t work. All I get is a screen with a “snowy” like background.

Here are the last lines of the log file.

Could not init font path element /usr/share/fonts/local, removing from list!
Could not init font path element /usr/share/fonts/uni, removing from list!
Could not init font path element /usr/share/fonts/CID, removing from list!
Xlib:  extension "RANDR" missing on display ":1.0".
gnome-session[6245]: WARNING: Failed to acquire org.gnome.SessionManager
gnome-session[6245]: ******************* START ********************************
gnome-session[6245]: Frame 0: /usr/bin/gnome-session [0x417217]
gnome-session[6245]: Frame 1: /usr/bin/gnome-session [0x417376]
gnome-session[6245]: Frame 2: /lib64/libpthread.so.0 [0x7f1249592a90]
gnome-session[6245]: Frame 3: /usr/bin/gnome-session [0x418ab9]
gnome-session[6245]: Frame 4: /lib64/libc.so.6(__libc_start_main+0xe6) [0x7f1249249586]
gnome-session[6245]: Frame 5: /usr/bin/gnome-session [0x40ab89]
gnome-session[6245]: ******************* END **********************************

Sorry, I should of mentioned I’m trying to connect with the TightVNC Viewer from a Windows XP laptop incase it makes a difference.

Also, TWM works so I know it’s connecting OK.

David71
In Linux, you simply open a terminal and type in the command.

If you have gnome or kde rdp installed on the linux box, you should be able to conect from windows using windows rdp. It’s not installed by default and is hidden in one of the addon setup menus for windows under the remote desktop connections (if I remember correctly from when I last installed and used it).

I understood the terminal part, I just don’t know what the “graphic login” is, you were referring to. :expressionless:
Did you mean the one when you enter the command

vncviewer

I tried RDP too. I installed the packages, rdesktop, xorg-x11-server-dmx, xorg-x11-server-rdp and xrdp, but was unable to connect. :frowning:
I kept getting “rdpx11 channel not present”

David
The vncviewer command opens a remote desktop connection to the linux/windows box and gives you your xwindow graphic desktop login prompt, etc.

For the windows>linux:
Have you set the rdp connection in windows to connect to the correct port on the linux box? Also check that the port in the linux firewall is not closed. You need to do a search to find the default port number. The windows rdp connector asks for a port number as well I think.
You should be able to get the vncviewer to connect from the linux box to windows.
Sorry, I don’t have a windows box, so I can’t check for you.

Yes, I set up and tried RDP on both computers too. I opened port 3389 in the firewalls on both and even shutdown the firewalls just to make sure that wasn’t the problem. I get the openSUSE login and it starts to connect then stops and says
“rdpx11 channel is not present”.

I’ve got it working with TightVNC and the TWM(Tab Window Manager) which is OK for occasionally using my box remotely, but I would prefer to use my regular Gnome desktop unless it proves too slow with VNC.

It’s changed since I wrote the tutorial I referred you to.

There’s been a change presumably by the developers. The command to start vncserver in Gnome in openSUSE 11.1 is now this:

dbus-launch vncserver

and also please upgrade the tightvnc RPM to this version: tightvnc-1.3.9-90.pm.1, which is in the Packman repository.

Thanks swerdna, It works now, much appreciated. :slight_smile:

I also tried getting RDP to work and can connect to Windows machines, but when I try to connect to my openSUSE box it starts to connect then the connection log says “rdpx11 channel is not present” and just hangs there. :frowning:
I’ve installed the packages as per your tutorial but no luck. Any ideas!

Thanks again.

David

I’ll try RDP again in the next few days and get back to you.

Thanks swerdna, I’ll see if I can work it out too, although I get on a plane to Australia tomorrow. Thankfully I can install and use TightVNC and OpenVPN on the Windows box I’ll have access to.

I’ve got RDP from a Windows client working now, but don’t ask me what was wrong, all I can tell you is it appears to have been a Windows thing. :open_mouth:

Basically, I followed swerdna’s excellent tutorial but it kept hanging at “rdpx11 channel is not present”.

While searching for a possible answer I came across this [Bug 455880] NOMAD gives “rdpx11 channel is not present”](http://lists.opensuse.org/opensuse-bugs/2009-01/msg13481.html) which pointed out it wasn’t an error and made me think it was maybe just a setting on the Windows machine, instead of a conflict with one of the packages.

So to cut a long story short, I disabled every option in the Remote Desktop dialog on the Windows client and set the Colours to 256. This time I still got “rdpx11 channel is not present” but it went past this and complained about the colours not being 24bit. I then set the colours to 24bit and, Bob’s your Uncle, it worked. :slight_smile:

Now I’ve tried to break it again by enabling each setting one by one, but it just keeps working, so I don’t know what was stopping it before. It works with every setting except colours less than 24bit. The sound also stays at the server even though the client has the setting to bring the sound to it.

Cheers,

David

Thanks David. I had a recommendation in my tutorial to use 24 or 32 bit, to avoid another error situation. Thanks to you I can add “your” error message.