Tigervnc viewer does not connect to realvnc server

Hello.
I have a realvnc server running on a raspberry pi 4 headless.
My computer is running leap 15.4
I have installed the realvnc viewer on my computer using this file ‘VNC-Viewer-7.1.0-Linux-x64.deb’.
This is working out-of-the-box.
The server is listenning on port 5900.

ss -an |grep LISTEN | grep “59”
u_str LISTEN 0 0 /tmp/.vnc-vncservice/vncserver-x11.CtrlComms 14595 * 0
tcp LISTEN 0 5 0.0.0.0:5900 0.0.0.0:*
tcp LISTEN 0 5 [::]:5900 [::]:*

Now I would like to use the viewer which is include in the opensuse package ( tigervnc viewer ).
I have not found any good parameter in the popup menu options

Any attempt to connect fail with either :
1°)

:~> vncviewer-tigervnc 192.168.130.90:5900

TigerVNC Viewer 64-bit v1.10.1
Copyright (C) 1999-2019 TigerVNC Team and many others (see README.rst)
See https://www.tigervnc.org for information on TigerVNC.

Wed May 17 19:00:00 2023
DecodeManager: Detected 12 CPU core(s)
DecodeManager: Creating 4 decoder thread(s)
CConn: Connected to host 192.168.130.90 port 5900
CConnection: Server supports RFB protocol version 5.0
CConnection: Using RFB protocol version 3.8
CConnection: No matching security types
CConn: No matching security types

or

2°)

~> vncviewer-tigervnc 192.168.130.90:5901

TigerVNC Viewer 64-bit v1.10.1
Copyright (C) 1999-2019 TigerVNC Team and many others (see README.rst)
See https://www.tigervnc.org for information on TigerVNC.

Wed May 17 19:37:32 2023
DecodeManager: Detected 12 CPU core(s)
DecodeManager: Creating 4 decoder thread(s)
CConn: unable connect to socket: Connection refused (111)

or

3°)
user_install@15-3-G731GV:~> vncviewer-tigervnc 192.168.130.90:5900

TigerVNC Viewer 64-bit v1.10.1
Copyright (C) 1999-2019 TigerVNC Team and many others (see README.rst)
See https://www.tigervnc.org for information on TigerVNC.

Wed May 17 19:41:20 2023
DecodeManager: Detected 12 CPU core(s)
DecodeManager: Creating 4 decoder thread(s)
CConn: Connected to host 192.168.130.90 port 5900
CConnection: Server supports RFB protocol version 3.3
CConnection: Using RFB protocol version 3.3
CConn: Connection failed: Problèmes de sécurité trop nombreux (Too many security problems)

Any help is welcome.

This topic,

is 6 years old but I think it still describes the problem and possible work-arounds.

Please let us know if you can fix the problem using these instructions.

Hello.
Thank you for your interest.
I have read many things about this problem.

I am about to install tigervnc server on the raspberry pi, and use tigervnc viewer on my computer.

I will give news as soon as possible.

1 Like

Installing tigervnc server :slight_smile:
Follow this link : https://github.com/gitbls/RPiVNCHowTo
Download the zip file
Then ON THE RASPBERRY PI
1°) Remove realvnc server on the pi

 sudo apt purge realvnc-vnc-server

2°) Remove /etc/vnc which should be still in place
3°) Install tigervnc server

 sudo apt-get install tigervnc-standalone-server xfonts-scalable xfonts-100dpi xfonts-75dpi --no-install-recommends

4°) Run the scripts

sudo edit-lightdm-config
sudo make-systemd-xvnc
sudo reboot

5°) Start the VNC service connections. For each one you’ve created

6°) Verify systemd services

sudo systemctl status xvnc*

7°) Verify that the server is listening

sudo netstat -ltpn | grep 59

ON THE CLIENT (leap 15.4)

8°) Configure vnc

/usr/bin/vncviewer-tigervnc

Fill the address of the server : 192.168.x.y::5901
Click on options button.
In the security tab
Encryption : click on none
leave TLS empty
Authentication : click on None and Standard vnc and username and password.
Click on OK button to finish
Click on connect ( that also keep the configuration you have made )

This is what works for me.

1 Like


Works for me with these settings in the Security tab.