thunderbird will not send my mails

when I try to send a mail with Thunderbird 10.0, the mail program asks for the code provided by my supplier, this i have, then i am prompted for a master software security code, that i do not have, i have not a clue how to address this issue. the log from TB gives this error code

error: [Exception… “User canceled master password entry” nsresult: “0x80004004 (NS_ERROR_ABORT)” location: “JS frame :: resource:///components/crypto-SDR.js :: <TOP_LEVEL> :: line 203” data: no]
: resource:///components/crypto-SDR.js

I have just installed opensuse 12.1 . the wireless works, so does the printer, would be nice if the mail also worked, i am using a 32bit system, perhaps this new version of Thunderbird is is not the proper mail application, it was the default version that Yest made available after a search for Thunderbird.

so my question is: is this a part of the security applied by opensuse or is it an issue i should post to mozilla? i have not been able to find any answers anywhere

jack (sleepless for days)

This is part of hour own setup for thunderbird.

Try: Edit → Preferences → Security

There should be a selection for “Use a master password” and there’s an option to change the master password.

If you have forgotten the master password, then you need to either unselect “Use a master password” or change the master password to something that you remember. Either way, you will lose any already saved passwords, though it sounds as if you might not have many (or any) of those.

thank you nrickert:
to complete the workaround, one must open Thunderbird, and in the tools menu > error log, open the console, paste the script:
open Dialog (“chrome://pippki/content/resetpassword.xul”) ,
click the evaluation button, this open a warning dialog ,if you accept, the password will be erased. Worked my mails were promptly sent
i found this solution at the Thunderbird forum -:slight_smile: