Thunderbird 12 doesn't check for mail on startup

Mozilla/5.0 (X11; Linux x86_64; rv:12.0) Gecko/20120421 Thunderbird/12.0

Installed through the openSUSE BuildService - Mozilla repository, and it doesn’t check for email, or newsgroup posts on start up.

I noticed the same behavior with Thunderbird 11.0.1, but all versions installed with tarballs work properly.

I triple checked my settings, set Thunderbird 12 as the default email client, rebooted, and the problem continues to be there.

Any ideas, other than filing a bug for openSUSE?

So I use Thunderbird everyday as it is my only mail reader and I am up to version 12.0 and it is working properly for me. I obtained my copy through YaST and not a build service, but if there is a bug report required, I would suggest that you should file one with all the info you placed here.

Thank You,

Like James, I run Thunderbird constantly.
I recently updated to 12.0 on my 12.1/KDE 4.8.2 desktop, mozilla repository.
It seems to be checking mailboxes on startup, I see the activity in lower left corner of window.

I have the ViewAbout plugin installed.

When I View-View/About-about.config and filter on “start”, I see


server is my “Local” folder, server2 and server3 are active mail accounts

It appears you are running a desktop.
I have experienced your issue on startup with a laptop, because Tbird was starting before network(wireless was up)

This is the repository I found TB 12.0 in, and installed TB 12.0 through YaST. Index of /repositories/mozilla/openSUSE_12.1

So I disabled it, and looked for TB 12.0, and this is what I found.](

Uploaded with

I reinstalled TB 11.0.1, and it displays the same behavior.

So if you could point me to where in YaST you found TB 12, I’ll give it a shot.

So I have added in the repository listed below, which may in fact come from OBS, though I have not paid any attention to that:


And then it is selected and loaded from YaST. This may be exactly the same thing you have done, though I did not understand that if true. But as said before, I have had no problem with Thunderbird 12.0 and further, if I had installed it from a Tarball and found it to work, I am not sure I would do anything else until version 13.0 (or maybe they will jump to 14 if superstitious). I am not sure which way you used first, but perhaps installing from different sources has messed up something?

Thank You,

I have my desktop on 24/7, and connected to my ISP, unless I restart for some reason.

All applications are usually closed.

If I leave TB 12.0 (or 11.0.1) running it does the checks for mail, and newsgroup posts at the set intervals, just not on start up.

Thunderbird 13 is the next version, currently in Beta.

Anythings is possible, but I run all 3 versions of Thunderbird I use with separate profiles, and the release version was a new profile that has only the Lightning extension installed.

So there are no security updates in Thunderbird 12.0 to bring it into the Update repo?

So I guess I would look at the following setting in Thunderbird called: mail.startup.enabledMailCheckOnce and see if set to True?

Thunderbird / Edit / Preferences / Advanced / General Tab / Config Editor / search on **mail.startup.enabledMailCheckOnce **and make sure it is set to true. I think if you double click on it, it toggles its value. After making a change, exit Thunderbird and start it up again. If already set to true, then it may be bug report time.

Thank You,

That pref is set to true.

I decided to delete the profile, and create a new profile.

This time I setup an email account first (bypassed that step the first time), then the news server, and all is working now.

I setup newsgroups first, then the mail account in the previous profile, but it still didn’t check for newsgroup messages on start up.

Don’t know if the other profile got corrupted, or I found a problem.


So all is well that ends well, that is what I say. A solution is good and happy to hear you found yours.

Thank You,