Thinkpad R61 funcion keys

I’ve installed OpenSuse 11 with KDE 4 successfully on my Lenovo Thinkpad R61. But i have a problem with some function keys…

At first, i had a problem with volume increase/decrease, but i solved that using kmix options. (however the Volume Mute key doesn’t wokr:)

But now i have some other problems with keys - mainly with Fn-keys… :
Fn+F2 doesn’t lock…, Fn+F3 doesn’t work too, situation with Fn+F7 | F8 | F9 is the same. So this are small problems…
Fn+Home | End should set the brightness - it doesn’t anything … :confused:

Do you know any solution for this problems? …

And finally, i have a problem with wi-fi hardware switch - when i turned off, wlan0 is down, but when i turned it on again, the wlan0 is still down until I restart Network manager or just startup wi-fi using ifconfig wlan0 up …

I tried to find help on google and thinkwiki - but with no visible result … :confused:

take a look at this:
SDB:Using the Extra Keys on the Keyboard - openSUSE
also, try using keytouch or keytouch-editor from pacman repo

I tried to set up xmodmap files - in most cases it was set right… I think, there is any problem between calling these XF86 functions and their efect…

(if i use xev all problem keys have their function set right now …) Now, i rly down know, where the problem is :confused:

What is the keytouch for? (It needs to install gnome-menu - i am not sure whatever it will work or not (I use kde 4)) …

I have no issues with my R61e
kde3 build service

Just worked!

Wireless setup in Yast and then managed from desktop with knetworkmanager. Works better than XP. And the pre-installed Vista has gone, it was a pine of brown steaming stuff.

i wasn’t aware that keytouch depends on gnome (i don’t use kde)…apologies.
you can try with hotkeys-setup, but i can’t provide any details about how to use it - hope knowledgable folks will help :slight_smile:

I have encountered the same problem on my L412 ThinkPad. I’ll describe it more accurately. I had the following symptoms:

  1. My laptop became too hot
  2. Speaker related keys are not working (Mute, Vol up, Vol down & Mic mute)
  3. Some function keys are not responding (Fn + F8(TouchPad activate), Fn + Del(iecrease screen brightness), Fn + Home(increase screen brightness))
  4. When I plug/unplug the ac power cord, my laptop doesn’t feel it correctly.

In order to try to figure out the problem and how to solve it, I used “xev” command and noted that the above keys are not responsive at all.
Moreover, the (Fn + Del(iecrease screen brightness), Fn + Home(increase screen brightness)) keys don’t work during the Grub OS choice menu. When my laptop was OK, these keys were working at that moment.

Hence I guessed it is a HW problem and not an opensuse problem. Trying to solve this problem, I tried the following and it completely solved my problem:

  1. Reset the Bios to factory setting
  2. Disconnected the ac power cord
  3. Left my laptop powered on till its battery ran out (I didn’t boot to opensuse, but left it on the Grub OS choice menu).

I think this is a HW problem and we should contact Lenovo regarding it. May be they issue a bios update that solves this problem.

Good luck