Text mode console font size

Hi all,

One of the machines I’m running SuSE on is connected to a 4K monitor, which works well, however everything is a little small :frowning: In X I can use the display settings to run the monitor at 2560x1600 which I can read without problems.

However the text mode console (ALT-CTRL-F1) still seems to be running with too higher resolution. Is there a way I can set this so that the font is bigger?

Cheers.

Phill.

@phillhs Hi Set the font in /etc/vconsole.conf I also set the resolution in grub…

cat /etc/vconsole.conf 
KEYMAP=us
FONT=ter-v32b

For the above font, install terminus-bitmap-fonts.

Then add the grub kernel options as required (I run 1080p screens), eg;

vconsole.font=ter-v32b video=1920x1080@60

My Grub linu lines mostly include just video=1440x900@60 on screens of 1680x1050 & 1920Xwhatever, and video=1920x1080@60 on 2560x1440 & 3840x2160. Dropping resolution increases font size enough that I don’t need to specify font to use. This method makes it easy to change when switching among my panoply of different size and resolution displays. With multiple displays that are different sizes, a separate video= for each is supported, e.g.: video=eDP-1:1280x720@60 video=DP-1:2048x1152@60 video=HDMI-1:1600x900@60. However, you’ll only get total rows and columns equal to the lowest resolution on the higher resolution display(s), along with big black borders right and bottom.

Why would you use 2560x1600?

erlangen:~ # inxi -zaG
Graphics:
  Device-1: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    driver: amdgpu v: kernel arch: GCN-5.1 code: Vega-2 process: TSMC n7 (7nm)
    built: 2018-21 pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s ports: active: HDMI-A-1 empty: DP-1,DP-2 bus-ID: 0a:00.0
    chip-ID: 1002:1638 class-ID: 0300 temp: 35.0 C
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
    compositor: kwin_x11 driver: X: loaded: modesetting unloaded: fbdev,vesa
    dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 192 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: HDMI-A-1 mapped: HDMI-1 model: Samsung LU28R55 serial: <filter>
    built: 2038 res: 3840x2160 hz: 60 dpi: 154 gamma: 1.2
    size: 632x360mm (24.88x14.17") diag: 727mm (28.6") ratio: 16:9 modes:
    max: 3840x2160 min: 720x400
  API: OpenGL v: 4.6 Mesa 23.0.3 renderer: AMD Radeon Graphics (renoir LLVM
    16.0.2 DRM 3.52 6.3.1-1-default) direct render: Yes
erlangen:~ # 

I use KDE > System Settings > Display and Monitor > Global Scale = 200%.

Why do you need huge font if you set resolution to 1920x1080? You really need only one of these options.

Oh, and why you set font both in /etc/vconsole.conf and on kernel command line?

@phillhs:

On this machine, with this monitor:

 > inxi --admin --filter --graphics
Graphics:
  Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
    vendor: ASUSTeK driver: amdgpu v: kernel arch: GCN-5 code: Vega
    process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
    ports: active: HDMI-A-1 empty: DP-1 bus-ID: 06:00.0 chip-ID: 1002:15d8
    class-ID: 0300 temp: 42.0 C
  Display: x11 server: X.Org v: 1.20.3 with: Xwayland v: 21.1.4
    compositor: kwin_x11 driver: X: loaded: amdgpu dri: radeonsi gpu: amdgpu
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 140 s-size: 698x393mm (27.48x15.47")
    s-diag: 801mm (31.54")
  Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: Idek Iiyama PL3288UH
    serial: <filter> built: 2020 res: 3840x2160 hz: 60 dpi: 140 gamma: 1.2
    size: 698x393mm (27.48x15.47") diag: 801mm (31.5") ratio: 16:9 modes:
    max: 3840x2160 min: 720x400
  API: OpenGL v: 4.6 Mesa 21.2.4 renderer: AMD Radeon Vega 11 Graphics
    (RAVEN DRM 3.42.0 5.14.21-150400.24.60-default LLVM 11.0.1)
    direct render: Yes
 >

I use this console font:

 > cat /etc/vconsole.conf 
KEYMAP=de-nodeadkeys
FONT=suse12x22.psfu
FONT_MAP=
FONT_UNIMAP=
 >

For exactly the reasons you describe …