Texlive installs way too many sub-packages!

It’s rare for openSUSE to do something that really annoys me or feels unjustified. But today, something I would go as far as labeling a “bad joke” happened in Tumbleweed.

I was doing my general system update earlier, when all of a sudden I’m notified that there are over 1500 new packages to install. The culprit is apparently something called Texlive: A library which has thousands of sub-packages, loads of them installed automatically by Tumbleweed. I next did a Google search to see what it was all about… and to my surprise, I discovered that Texlive is simply a typesetting (font management) library. So basically, over 1000 system packages must be installed on my system just for a new font management pipeline? Gee… rendering a few fonts on the screen has become a much bigger business since last time I checked :sarcastic:

I soon tried uninstalling Texlive and everything having to do with it, considering I don’t need it and everything worked perfectly before it. But of course this is not an option, because “zypper dup” will simply put it back. So it seems I’m stuck with this unjustified package spam… which is likely going to increase the time and network usage of package updates, not to mention how messy it is for a system I aim to keep relatively clean.

So if any openSUSE administrators are reading this: Can anything be done to reduce the package count of Texlive please? Either by merging more of its components under single packages, and / or by making fewer of them necessary to install. In my opinion this is a problem, because no one application or library should come with more than 100 obligatory sub-packages let alone 1500! Please try seeking a solution for this issue. Thank you.


Maybe you can solve this by telling YaST not to install recommended packages - I guess that zypper should be able to do this too.


I don’t have Tumbleweed, but on 13.2 and Leap 42.1 “texlive” is an optional package and is NOT installed by default.
And yes it brings in “TeX” and “LaTeX”, and many other packages. It is all related to professional typesetting setup
and page rendering for professional printed document publication… This should NOT be a required package.

Perhaps this is a new requirement for Tumbleweed -or- you’ve installed another package which requires it?

After you remove the texlive packages just add --no-recommends after up or dup. with that command it won’t drag in unneeded packages anymore, while installing them by default when you install something new.

Ah… I understand. Is there a command to find out what recommends texlive exactly, in case it’s put there by another package and not base Tumbleweed? Otherwise I might switch to --no-recommends updates in the future, which sounds like it could be a good idea too. Thanks!

Testlive is one of the packages that come with recommendations to install the whole world. Turn off recommendation in Yast-software management

I do think there is a zypper command to list recommendation but I forget it now just dig is out in the man zyyper pages

Just for the record:

I faced the same issue with the latest Tumbleweed update. An other way to ignore the updates or bypass the re-installtion of the textlive packages are **package locks:


# zypper al 'texlive*'

I found out which installed packages were recommending texlive by using:

zypper se -si --recommends texlive

The guilty package in my case was python-jupyter. I don’t need that either, so I wiped both it and texlive from my system. About 1500 packages and 1GB of disk space were freed.