Testing KDE4.5 beta2

4.4.85 (KDE 4.4.85 (KDE 4.5 Beta2)) “release 3”

Just updated. More details over time.

Updated this morning, first impression is OK, except for the network folder issues.

@Caf4926: could you try creating an ssh-based networkfolder from Dolphin/Konqueror ? I still cannot get if this is a KDE4 issue, or something in my M7/Factory install. In other words, is this the return of the kio-slave issue from the beginning of KDE4?



works for me

does not

It’s some regression. I noticed that the dropdown of protocols is gone too. Seen it before and IIRC that was all 64bit too. I check if bug report has been filed yet.

Filed a bugreport: https://bugs.kde.org/show_bug.cgi?id=241312

Discovered something weird:

I installed Gnome to see if fish:// and sftp:// would work and was presented with the new artwork for 11.3, that I already saw in GRUB and the bootsplash. Not in KDE4 though. Browsing again I saw the openSUSE113… names, but no images. So I did a ‘locate openSUSE113’ and got this as a result:


wondering how this could be, opening one in Gimp and looking at the properties learned me, that it’s a …jpg, while if fact it is a PNG !!!. Copied to desktop folder, renamed it to …png done.

The new bootsplash reminds me of SLED

I noticed the wallpaper, but never looked in to it. Did you report this?

Bug 613466 Submitted

I installed the beta last night and it mostly works fine. There is just one thing that I can’t manage to get back - not sure if the feature is gone or I just can’t find the setting.

It is the desktop bit. I quite liked the folder view - so there is a window in the top left with the desktop items shown in it. Have played with the settings but can’t seem to get it back.

Any ideas. Thanks

Anyone experiencing higher cpu usage on kwin than on beta1? Using kwin desktop effects on an nvidia GeForce 8400M GS using the nvidia driver, with the wobbly window effect, I’m getting about 20% cpu usage and it’s a bit jerky, which it wasn’t before on beta1 or 4.4. Are the suse beta2 packages compiled with the debug flag on?


No high CPU usage here, must say I recreate the desktop appearance on every new release as a habit. Tried that?

Install debuginfo and debugsource packages to have full debug info.

And …a warm welcome here.

When you say recreate the desktop appearance, are you referring to desktop effects? Or the widget style?


My guess is he means a new .kde4

Nope not the entire ~/.kde4, just the plasmafiles from ~/.kde4/share/config. To do it the most decent way:
Logout, at login screen, hit Ctrl-Alt-F1
Login with username and password, and do:

rm ~/.kde4/share/config/plasm* ; exit

Hit Ctrl-Alt-F7 to return to the login screen.
Login with username and password

You will now see the default openSUSE KDE4 desktop. Your application settings remain, just the desktopappearance is plain default.

I find that switching the window manager from kwin to compiz uses far less resources. with kwin I have very few desktop effects. With compiz I can get quite a few working and not overload my cpu.

If I remember right the same thing happened with kde 4.4 during its development

Because of issues involving Kwin crashing (and to double-check the performance difference), how would you switch the window manager with 4.5b2? With CCSM?

I tried your suggestion, with no success. I then moved .kde4 to .kde4.old to see what effect that had - minimal.

However, what seems to have made the biggest difference is upgrading the nvidia drivers to the latest. Seems strange, but there it is.


Mmmm. looks like you suffered from an update of Xorg or kernel, if the reinstall of the NVIDIA driver solved matters. Reminds me of old times: in any case of graphical problems, reinstall NVIDIA driver. Haven’t counted how many times this “repaired” things.

The switch is in system settings>default applications.