Task bar is unreliable/freezes

Whenever I choose to auto hide the task bar, and it is hidden, notifications will not display unless it is being in focus. They will also not disappear/automatically close if it’s not in focus.
The task bar also freezes frequently whenever playing a game and focusing another application, such as alt+tab into a browser. It remains frozen until the game is closed.

inxi -GSaz
$ inxi -GSaz
System:
  Kernel: 6.9.7-1-default arch: x86_64 bits: 64 compiler: gcc v: 13.3.0
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.9.7-1-default
    root=UUID=03fd253f-1f76-4d63-888a-5b3eaaa25ad1 splash=silent quiet
    security=apparmor nvidia_drm.modeset=1 fbdev=1 mitigations=auto
  Desktop: KDE Plasma v: 6.1.2 tk: Qt v: N/A info: frameworks v: 6.3.0
    wm: kwin_wayland tools: avail: xscreensaver vt: 3 dm: SDDM Distro: openSUSE
    Tumbleweed 20240705
Graphics:
  Device-1: NVIDIA GA106 [GeForce RTX 3060 Lite Hash Rate] vendor: ASUSTeK
    driver: nvidia v: 555.58 alternate: nouveau,nvidia_drm non-free: 550.xx+
    status: current (as of 2024-06; EOL~2026-12-xx) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 4 speed: 16 GT/s
    lanes: 16 ports: active: none off: DP-1 empty: DP-2,DP-3,HDMI-A-1
    bus-ID: 13:00.0 chip-ID: 10de:2504 class-ID: 0300
  Display: wayland server: X.org v: 1.21.1.12 with: Xwayland v: 24.1.0
    compositor: kwin_wayland driver: X: loaded: nvidia gpu: nvidia display-ID: 0
  Monitor-1: DP-1 res: 1920x1080 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
    drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia wayland: drv: nvidia
    x11: drv: zink inactive: device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 555.58
    glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 3060/PCIe/SSE2
    memory: 11.72 GiB display-ID: :1.0
  API: Vulkan v: 1.3.283 layers: 10 device: 0 type: discrete-gpu
    name: NVIDIA GeForce RTX 3060 driver: N/A device-ID: 10de:2504
    surfaces: xcb,xlib,wayland

I don’t know what other logs I should submit.

Isn’t this driver a Beta version? :

driver: nvidia v: 555.58

Beta drivers are not yet ready for release, as they are in the last stages of development, and can cause unexpected behaviour.

1 Like