Table crontab does not launch works.

I have the Tumbleweed version 20210330.
I have always launched applications and commands from crontab tables on opensuse and other systems.
However, now I can’t get crontab to work. I’ve tried to launch from the crontab present in the / etc / crontab folder and also in / var / spool / cron / tabs /.
The crontab service is active and running on Yast.
This is my crontab:

          • date >> / home / eragontux / testedate

I usually use this line to do the test and it has always worked. I don’t know, but it seems that the crontab tables are not being taken over by the cron system. Will be?

Any idea?



There is an important, but not easy to find feature on the forums.

Please in the future use CODE tags around copied/pasted computer text in a post. It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.

An example is here: Using CODE tags Around your paste.

Thus e.g. when you wwant to show a user’s crontab:

boven:~ # crontab -l
*/5 * * * *     /root/bin/nachtstop

*/5 * * * *     /root/bin/wij
boven:~ # 

Only so can we all see exactly what you did and saw yourself.

BTW it is not / etc / crontab, it is /etc/crontab. Please be careful and precise with all characters you type. You may create confusion before you can say JR.

BTW, I am on 15.2 and have no problem with the root’s crontab as I show above.

Thank you all.

I found out what’s going on.
I created the crontab file, but … I opened with Kate a backup i have of the crontab and copied the line (* * * * * date >> / home / servall / testedate) and pasted the line through the nano editor.
This corrupted the FILE MODE and caused the BAD FILE MODE error.
All it was necessary to do was simply create the table again and write things by hand.