systemd is consuming a LOT


my notebook is behaving strange these days. As you can see in the image, the systemd-coredum is consuming A LOT o my CPU. Why? It was not like that.

Sometimes the system freezes.

What can I do?

It looks to my rather (or very) limited knowledge you have a coredump being processed…

What does, (as root)

coredumpctl list

give you?

The problem was an mp3 file with embedded album art:

There seems to be a bug in that this also happens if coredumps are actually disabled via ulimit (as they are by default).
And systemd-coredump doesn’t even seem to respect the settings in /etc/systemd/ to limit/disable itself, in Leap at least…
(this annoyed me a lot myself already)

I found out how to disable systemd-coredump completely two days ago though, if somebody is interested:

sudo ln -s /dev/null /usr/lib/sysctl.d/50-coredump.conf

Of course, in the end it’s not systemd-coredump’s fault if applications are crashing though… :wink:
It’s just a symptom, not the real problem.

In fact, there are more bugs because the systemd-coredump returned. I don’t know exactly why. I don’t know if disable it is the best choice, but if I can’t solve I will do it, because is consuming almost 100% of my CPU.

As tannington already wrote, coredumpctl should show which applications crashed.
And it should also allow to get more informations about the crashes.

Tons of lines with this:

Qua 2017-08-30 08:48:54 -03 3787 1000 100 31 /usr/lib/tracker-extract
Qua 2017-08-30 08:48:57 -03 3857 1000 100 31 /usr/lib/tracker-extract

Also, now there is the systemd-c+ consuming

I need to use

tracker daemon -k

if I want to use my computer properly (at least for a wile)

I used this tip to disable tracker-store processes. I couldn’t find a way to solve the systemd problem.

So tracker-extract is crashing.

Might be related to, though that’s filed against Tumbleweed.

You should be able to get a backtrace via corecumpctl.

That’s just an abbreviation for systemd-coredump, and it is “consuming” because it creates a coredump for the crashed process (tracker-extract?).

It is no systemd problem, that’s just a symptom as I wrote. The problem is that tracker-extract (not tracker-store) crashes.
But I already explained how to disable systemd-coredump. Won’t fix tracker, but it should prevent your system from getting unusable.

Do you actually use tracker? If not, you could just uninstall it.

Thanks a lot. Yeap, I get it that is a symptom, but symptom of what? That’s the problem. I didn’t find a away to deal with it.

In fact I don’t use tracker, so I disable it.

That tracker-extract is crashing. Probably that’s caused by (a) certain file(s) in your home directory.
The crash should be investigated and fixed, then the systemd-coredump “problem” would be solved too.
Of course disabling or uninstalling tracker will prevent that crash anyway.

You said in post #3 that the problem “was an mp3 file with embedded album art”. Maybe you have more of those and they are what tracker is choking on, causing it to crash and coredump ??

edit: wolfi323 types faster than I, as well as being far more knowledgeable :slight_smile:

Yes, the first file was an mp3 (and I also found another ones). But the problem is there are more stuffs which I can’t understand:

Well, the file mentioned in this backtrace is /home/viniciusbr/MEGA/MEGAsync/02%20TESE_DSC/reunioes_audios/novembro_2016.3gp .

But to me it seems the actual crash is in gstreamer, when it tries to create its plugin cache.
Maybe try to delete ~/.cache/gstreamer-1.0/, and/or uninstall/move/delete the v4l2 plugin (/usr/lib64/gstreamer-1.0/, package gstreamer-plugins-good) as a test, because that’s being mentioned in the backtrace.

And yes, the crash does look similar to the one in the bug report I mentioned.

Done. I deleted the cache and Now, there is the new coredumpctl:

But seems that the problem continues :frowning:

And I also added more information in the bug report.

Yes, apparently the crashes are not restricted to gstreamer’s v4l2 plugin.

From what I can see you seem to be hitting that libmediaart crash now that’s also been mentioned in the bug report…

I see. I think that the only software using libmedia art is lollipop. I’m not using nothing more.

wolfi323 wrote:

> I found out how to disable systemd-coredump completely two days ago
> though, if somebody is interested:
> Code:
> --------------------
> sudo ln -s /dev/null /usr/lib/sysctl.d/50-coredump.conf
> --------------------

Is this a better solution than using an own 50-coredump.conf under /etc/sysctl.d
with this content:

See sysctl.d(5) for the description of the files in this directory,

and systemd-coredump(8) and core(5) for the explanation of the

setting below.


I found the hínt from here
and i use this for a longer time but i don’t know if it is only luck that i
don’t see systemd-coredump in action since this time.