System Tray seems broken in KDE Leap

Having a problem with random icons occasionally not loading in system tray.
This persists across two different clean install using two separately downloaded ISOs.

On boot, more often than not the volume icon is not loaded in systray. Around 50% - 60% of the time fcitx systray icon is not loaded.
The services themselves are running.
Sometimes logging out and back in fixes the problem - sometimes not.

It can be repaired for the session by removing systray and adding it back in. However, this raises another problem. On both my systems - after removing systray and clicking to add a new systray widget plasma crashes and then loads systray with the missing icons again. The only procedure that works successfully is to remove systray > log out and back in > add new systray.
Selecting to “always show” in systray settings has no effect.

This is going to get pretty tiring if I have to go through this procedure every time I have to boot.

Had a quick look but couldn’t find a bug report. Anybody else having systray issues. I thought perhaps it might be related to fcitx - but removing this and all config files doesn’t correct the problem.

How it should look

How it usually looks (you can see the spaces where the missing icons should be)

seems to be this . . .

and the suggested temporary workaround . . .

A quick work around to get them back is to toggle categories > miscellaneous in System Tray Settings

I’ll give this a try when I get home later

I’ve seen this in Tumbleweed, thought it was some old config glitch in my user account, but it’s gone after the latest Plasma5 updates, so I’d say a fix is on the way.

Not really.
This is still being investigated…

But it occurs quite randomly, sometimes all plasmoids are show, sometimes one is missing/blank.

Btw, another “fix” is to enable/disable one of the plasmoids in the system tray settings, or restart plasmashell.

Same here, a space where a volume icon had previously presented in the system tray. After the update here the space could be removed by enable/disable of the volume feature in systray settings, and hasn’t returned. Otherwise it just remained.

Same here, a space where a volume icon had presented in the system tray. After the update here the space could be removed by enable/disable of the volume feature in systray settings, and hasn’t returned. Otherwise it just remained, and remains a problem on Leap.

all the suggested fixes seem to work - so hopefully a permanent fix not too far away.
toggling miscellaneous gets my vol icon back and toggling services gets my IME back.

A separate - but I guess very related issue . . . .

Has anybody had any luck getting a dropbox icon to show in the taskbar / tray?
Seems to be a widespread issue across distributions using plasma 5 . . . with a lot of distributions posting temp fixes. Haven’t come across one that works for openSUSE yet.

Never used dropbox, so no idea.

But Plasma5 should show old-style system tray icons meanwhile, via xembed-sni-proxy which is installed by default.

I remember a thread about that in the KDE forums though.
Apparently Dropbox bundles its own version of Qt5 which causes problems.

See .

My experience with the same issue … so rebuilt system from an image taken just before installing Dropbox and Viber … installed DB first … straight from the repo but included the nautilus-extension dropbox, which i had not installed the first time around … and straight up the DB icon appeared in the system tray.

HOWEVER, then installed viber.rpm and configured only to find the DB icon now gone missing from the systray.

Used Yast to DE-instal viber and the DB icon comes back??!!

For what it is worth :frowning:

openSUSE Leap 42.1
KDE Plasma 5.4.3, Kernel 4.1.12-1-default

my issue with the dropbox tray icon not loading was due to FCITX (IME I use for Japanese input). For some reason it prevents old style tray icons loading. I’ve now switched to ibus as an alternative IME and dropbox tray icon (if you can call it that with its ugly black background) appears fine.


Or more accurately it is not the installation of Viber, in this instance, that removes the DropBox icon from the SysTray but the loading of it into memory!!! Consistently repeatable. Auto load Dropbox and then run Viber … you will see it immediately removes the DB icon from the systray. However simply just killing viber and reloading dropbox does not return the DB icon … but it comes back if i reboot or relog user (autoloads DB).

I have trying to solve this problem according to the many inputs in this thread.
And i must say, it is very frustrating !
Because i have no results.
Systray is very useful.
And not being able to have a quick access to battery state, wireless network toggling, or bluetooth , or other useful stuffs is a real problem !

When will there be a good fix for this problem ?

The fix is already in Tumbleweed. AFAIK it will land in Leap over the next couple of weeks.

A workaround is to go to the Systemtray’s settings: Then uncheck the “Various” item, click Apply, recheck the item, click Apply. Your systemtray has now gone back to normal. This doesn’t survive a logout/login. But, like said, the fix is on the way.

Just to be clear here: there were several independent problems.

The one originally discussed here in this thread is that fcitx does something “stupid” that caused xembedsniproxy to crash, and as a result making old-style XEmbed systray icons disappear.
Manually running “xembedsniproxy” should help in this case.

That crash is fixed in Plasma 5.5.4, but not submitted to Leap yet (I hope to add more fixes for other problems, that are not fixed yet but might be soon).
You can also install xembed-sni-proxy from KDE:Frameworks5, that does include the fixes for that crash:

sudo rpm -U

(you can of course also upgrade completely to the latest Plasma5 from KDE:Frameworks5 if you prefer…)

The problem with system tray elements disappearing randomly is caused a bug in Qt5, patches that should help have been added and submitted as an update to Leap (but that’s not released yet).
This one can be “fixed” by toggling the corresponding item in the system tray settings, as Knurpht describes.
(toggling the “Various” category only helps if that item is actually part of the “Various” category, toggling the affected item itself should help in any case)

Of course being a bit more specific about the actual problem might also help to get useful answers/hints… :wink:

Hah… well they fixed it and KDE 5.5 came to rear its ugly head, and broke it again. In fact, it’s worse this time than after the “workaround” for xembed was incorporated into Plasma.

So I have to regress to get the xembed-sni-proxy app to work… whatever they did to “incorporate” that app into plasma5.5 is broken:

| xembed-sni-proxy | Convert XEmbed system tray icons to SNI icons | package
| xembed-sni-proxy | Convert XEmbed system tray icons to SNI icons | srcpackage
user@host:~> sudo zypper in xembed-sni-proxy
Loading repository data…
Reading installed packages…
Resolving package dependencies…

Problem: installed plasma5-workspace- obsoletes xembed-sni-proxy < provided by xembed-sni-proxy-0.0.1git~20151104~ded1538-3.1.x86_64
Solution 1: Following actions will be done:
downgrade of plasma5-workspace- to plasma5-workspace-5.4.3-6.1.x86_64
downgrade of plasma5-workspace-branding-openSUSE-13.3-35.1.x86_64 to plasma5-workspace-branding-openSUSE-13.2-26.1.x86_64
downgrade of plasma5-workspace-lang- to plasma5-workspace-lang-5.4.3-6.1.noarch
downgrade of plasma5-session-5.5.5-9.1.noarch to plasma5-session-5.4.3-3.1.noarch
downgrade of plasma5-desktop-5.5.5-20.1.x86_64 to plasma5-desktop-5.4.3-6.2.x86_64
downgrade of plasma5-desktop-branding-openSUSE-13.3-35.1.x86_64 to plasma5-desktop-branding-openSUSE-13.2-26.1.x86_64
downgrade of plasma5-desktop-lang-5.5.5-20.1.noarch to plasma5-desktop-lang-5.4.3-6.2.noarch
downgrade of plasma5-workspace-libs- to plasma5-workspace-libs-5.4.3-6.1.x86_64
downgrade of powerdevil5-5.5.5-9.1.x86_64 to powerdevil5-5.4.3-3.1.x86_64
downgrade of plasma5-workspace-devel- to plasma5-workspace-devel-5.4.3-6.1.x86_64
downgrade of powerdevil5-lang-5.5.5-9.1.noarch to powerdevil5-lang-5.4.3-3.1.noarch
Solution 2: do not install xembed-sni-proxy-0.0.1git~20151104~ded1538-3.1.x86_64

Choose from above solutions by number or cancel [1/2/c] (c):

They didn’t.

And actually Plasma 5.5 was the first version to have xembedsniproxy.
That’s why you cannot install that extra package any more which we only provided so that people can have old-style system tray icons with Plasma 5.4 already.

But that has already been explained to you in your bug report anyway…