System Settings not saved in Wayland

I submitted bug #457430 about my display settings not being saved from a Wayland session back in August. I’ve been updating my nvidia drivers since then and nothing has changed. There have been no new comments on this bug since I submitted it. Is anyone else seeing this issue?

I occasionally reinstall TW after about a year and sometimes that fixes some inconsequential but annoying issues, but if this is happening to others, I won’t bother. Generally, Wayland is working pretty well, but not as reliably as Plasma X11.

To reproduce this issue with settings, I switch to a Wayland session and change the scale from 100% to 175%. Then switch back to X11 and then back to Wayland again. Scale is back to 100%. 4K display at max resolution.

I should have mentioned that I’m referring to Display settings. Other settings appear to be working normally.

I’m using KDE Plasma version 5.26.9 (with Leap 15.4), but I can’t replicate this particular issue. The scaling is preserved (separately) between X11 and Wayland sessions. Let’s see what others report/advise.

Also, when I set the scale to 175% in Wayland, my cursor size changes to 48 while the setting says 36. Is there a config file that I can delete to see if that fixes these problems?

The latest version of Plasma I have in TW is 5.26.5.

More easy probably is creating a new user to see if it has the same problem.

1 Like

Created a new user. Same problem with display settings reverting back to 100% if I switch back to X11 and then back to Wayland. As a new user, the cursor changed sizes depending where I put it. In Firefox the size was 48, if I moved it to the desktop it was 36.

Then I assume that these results tell us that searching for a config file to delete is not productive as all was fresh now.

I did a fresh install of TW a few days ago and also upgraded to plasma 5.27. Display settings changes still aren’t being saved in a Wayland session. Is there another utility I can use to change the scaling percentage?

No, not in a Wayland environment.

Can you tell us if you have KDE configured to start a new session at login?

No, it’s set to ‘restore session’

Same behavior here like the OP.
I change the scale to 125 in x11 and it stays until the next login.
In wayland it stays at 100 so I change it to 125 I logout when I login it reverted to 100.
I check the x11 and it is still at 125.

To add the display setting dialog in wayland is not similar to x11 display setting.
If have time I will post a screenshot regarding this.

Here is the screenshot of display settings in plasma x11

This is for plasma wayland. see the dialog highlighted with red square

I tried changing those two settings in the Wayland configuration and those settings were saved but the scaling wasn’t. I tried changing the resolution also. The first one I chose, my display went blank and wouldn’t come back. Next time I chose 1920x1080 and my display went blank for a second, then came back and the resolution was still at 3840x2160.