System policy prevents modification of network settings...

Everytime I want to connect to my home wifi from a non-admin user which is everytime I boot because I have “Automatically connect to this network when is available”,
NetworkManager prompts for the admin password.

I thought you only needed to check “All users may connect to this network” in Connection settings, but this does nothing:

Any idea?

This is a known issue. I’m assuming that you are using KDE/Plasma 5.

Edit the connection.
Click the WiFi security tab.

There are two distinct icons near the right side of the line where the key is entered. But they probably show as one icon or two overlapping icons. If that happens, then either maximize or unmaximize the edit window. Then you will see the two distinct icons.

One of those is for setting the location of the network key/passphrase. It it probably set to be kept in user settings. Change it to the option for the key to be saved for all users.

After that, it should work the way that you intended.

Hi there,**
Many thanks nrickert for the solution !** I was fighting with this issue for a long time and didn’t expected that it would be so simple :slight_smile:

Once again thanks !