System Keyboard Configuration not saved after reboot


I am using openSUSE 15.0. And I am really annoyed on openSUSE 15.0 at the moment.

I have a swedish keyboard and after each reboot it resets to english keyboard. So everytime I login I have to change keyboard in System Keyboard Configuration back and forth to Swedish again and save it. Then the next time i logout or reboot I have to do this again. The System Keyboard Configuration is not saved after reboot. Its really annoying and makes it unusable for me!

Hi - if you are using Gnome, in the settings app there is a section called “Region and Language”. I assume that you’ve set that properly. But on that same screen, “hidden in plain sight”, so to speak, there is a button at the top right labelled “Login Screen”. click on that - are the region and keyboard settings different?

That might be why. Needs to be more obvious IMHO.

Am I right to assume that this is done in YaST > Hardware > System Kwyboard Layout?

This to avoid confusion with the several desktop environments that can set this for individual users.

Yes you are correct! Its in yast! Wrote in search field System Keyboard Layout.

Dont really understand what setting you refer to!

But if I look in Keyboard - System Settings Module => Layouts the English (US) is default even if I have put Swedish on keyboard in Yast!

Please, say that you use this from YaST. That is not obvious to most.

And didn’t you set this at installation? It is one of the very first things you are asked for at installation.

Off course I put Swedish keyboard during installation! I have only put it in yast! But the configuration is not saved on reboot! So the keyboard get reset everytime you reboot your machine! So in other words it did not work after installation, because it was rebooted.

I should also say that after the installation Swedish is marked in yast (System Keyboard Configuration), but its not actually active! You have to open the dialog (System Keyboard Configuration) and actually press ok for it to activate. Then if you restart suse again the same thing happens again.

Hm, maybe worth a bug report.

The problem is I use English (US) as system keyborad (and also all GUI users use that)., thus I can not confirm.

Maybe first wait a bit to see if other non English (US) keyboard users come and report their experince.

Hum, cant you confirm with us keyboard? The easy check is to make the sign / that we use all the time :slight_smile:

if shift + 7 = / then keyboard is not us keyboard. if shift + 7 = & then its us keyboard.

So basically even if you have set the keyboard to for example swedish in yast and then reboot the us keyboard will still be active. And then check it with shift + 7

As most Dutch users, I have a US keyboard and have it configured as such.
Thus the / is on the lowest row at the far right (before the RightShift) and it shows /
The & is engraved above the 7 and I can type it with Shift-7.

You mean that I should reconfigure my system and then try again? Probably in a root terminal (else my KDE config should override, I assume).

Let me think over it. In any case, I can not reboot the system now as it also runs several services to other sytems in the house.

I dis as you suggested.

After chaning using YaST : Hardware : System Keyboard Layout it changed Shift-7giving /, and a lot of other changes.

After reboot, this still holds true. I do have problems now with typing ;)Ö -.,;:äåÅ"

I will change back asap. But my experience shows that your problem is not reproducable on my LEAP 15.0. What makes it probably more difficult to find out what is wrong with your system.

Lets continue this on monday. Have some ideas.

Experimented too. And setting the keyboard to Swedish IME is persistent, when done in YaST. But … what are your desktop’s settings? Mine ( US-English ) like Henk’s are persistent too, and they overrule the system’s settings, i.e. YaST’s.

To be precise:
I checked this fron with my KDE PLasma session with Konsole as well as my own user as as root. Both chaned the key interpretation.
I did NOT check from within other applications, like e.g. creating a forums post from Firefox.


I have these settings in my autoyast regarding this! Thats the only setting I used when installing!


If that info from autoyast is not enough for you I can give you a vagrant image that an autoyast with that network setting has created where you can see the problem?