System Information does not show all memory

openSUSE 11.2 installed on machine with 5GB memory but System Information in KDE desktop shows only 3GB total memory. Just added a further 4GB but no change shown in System Information.

Is there something I must do to have sysinfo report true value and does this mean that memory not shown is not being used?

POST BIOS check shows 9GB installed.

Please could somebody advise.

Did you install the 32 bit version?? 3Gig is the most that can be addressed. Install the 64 bit version and you should see all the memory.

I have the 32 bit version installed and System Monitor shows all 6 G installed. From a command prompt try this: cat /proc/meminfo

You can see my output below. The total mem is the first line.

MemTotal: 6157452 kB
MemFree: 3743408 kB
Buffers: 350176 kB
Cached: 1322340 kB
SwapCached: 0 kB
Active: 1567908 kB
Inactive: 669280 kB
HighTotal: 5310144 kB
HighFree: 3400792 kB
LowTotal: 847308 kB
LowFree: 342616 kB
SwapTotal: 3229024 kB
SwapFree: 3229024 kB
Dirty: 416 kB

Install pae kernel from YaST, and every thing should be fine.

pae does allow addressing above 3gig but it comes at a speed cost. Better to just install 64bit. 32 bit apps still run fine but of course are limited to 4 gig address space.

32 bits can only address 4 gig and then 1 gig is reserved for the OS leaving 3 gig available to process,

pae operates by a form of bank switching which costs cpu cycles

Also the desktop kernel is optimized for desktop operations which are different then what is best for servers.

I agree with the 64-bit recommendation. If you have that much RAM install the 64-bit version.

Hi and thanks to all for the responses which make sense.
I was under the impression that I had installed the 64 bit version, at least that is what I intended and it never occurred to me that the 32bit version had been installed instead.

I installed using the network install on line but the starting CD-ROM was burnt using the 64bit link.

So how can I check what I have and is there any easy route to getting the 64 bit installed or do I have to start over?

uname -a will tell you what arch is running. It show either i[56]86 or x86_64 in the output.

You have to reinstall to switch architectures.

Before you do that you might want to check that your CPU supports 64-bit, a few still don’t, mainly mobile ones.

grep -w lm /proc/cpuinfo

No output means 32-bit only CPU.

Hi and many thanks again.
When I posted my last message I was not at the machine in question. I have now run uname -a and the installed system reports:- #1 SMP … i686 i686 i386 GNU/LINUX.

However the start disk I used for the network install is definitely openSUSE-NET-x86_64-Build0349.

The machine OS is an IBM X3400 server with two Xeon Quad core procs. installed and I am very confident they are OK with 64 bit. Running your command gives me 8 indentical outputs for the flags, one for each core I presume.

I conclude that there is a fault in the startup disk so it looks as if I shall have to burn a DVD. Would it be appropriate to report this problem anywhere?

Any further advice gratefully received.

Feel free to file a bug at, but I doubt if it’s something that obvious or it would have been reported already. I’ve never experienced a mixup of the NET install CD images. Still, one never knows.

Hi Ken,
I shall leave that for now but am very depressed because the DVD download takes an age and I have never used DVD before, always network install.

Also glum because I have Virtual Box installed and a great deal of time went into building/installing the particular VM. If I take a snapshot I am not sure if that will preserve the VM including guest OS or just the state of that guest machine, in which case a new install of openSUSE to correct the 64bit problem will mean I have to start from the beginning with Virtual Box and the guest OS.

Any thoughts?

You could also download the LiveCD, which has an install option. You can then get the rest of the stuff from the online repositories.

You should be able to move the VM to a new host by copying the .xml and the .vdi files over.

If you preserve the files the VM should work fine. I always put my VM files in their own partition so that they are safe from upgrades or system changes.

Good idea which I should have done from the outset if I had thought about it. Assuming I can create a new partition by resizing to make room, exactly which files should I move to it and how do I tell the system they have moved?

If I can get this sorted and Virtual Box working from new location I will run and create snapshot before upgrading the OS but are there any other precautions I should take? (At this stage I have no working files needing backup.)
All advice and guidance gratefully received.
Many thanks,

If you did not change the default VBox settings, everything is under $HOME/.VirtualBox

When you set up VM box just tell it where the VM’s are to be stored. I think you only need th .vdi file

Hi Ken,
Things are looking up. My home directory is already on it’s own partition and .VirtualBox directory is there as you suggest with what looks like the important info. The binaries are in /usr/bin and various lib directories so I assume if I do a new installation of host OS and then install Virtual Box all will be OK. I shall work at it tonight.
Many thanks again,

I downloaded the DVD iso image and the install went like a dream and definitely 64 bit this time. Total Memory now shows as 8.8GB whereas there is 9.2 showing in the POST test. Why is this.

The VirtualBox is working after a fashion and I can see the guest machine I built. I have not yet tried to run it because there are a few glitches and errors showing in the log which were not present with 32 bit. Also I can’t find a version of linux-kernel-headers to match my kernel version, which may be cause of errors. These occur when I try to run vboxdrv setup to rebuild kernel module.
Will start a new thread after I have read up some VBox FAQs.
Thanks again,

The BIOS relocates some RAM because some of the memory addresses are used, e.g. the 640k to 1M “hole” and an area for PCI devices. So some of it ends up above 8GiB. But that’s not a problem, you have 64bit addressing.

Headers and source for your kernel should be in the repositories. Are you using Yast-Software-Software Management??

What repositories do you have active. You may need to add or activate the development repo

Differences are the reserved memory address space for the kernel I believe. Or it could be one is reporting power of 2 values and the other decimal values. There is always confusion because some things report 1K as 1000 and others 1K is 1024

Real programmers know there are only 10 states Off and On.