Synaptics touchpad not working on Fujitsu S935 (Broadwell)


I have refurbished Fujitsu S935 (Broadwell) here of which I had thought to be perfectly compatible with Linux.
Guess I was wrong.

Already at the installation dialogue the mouse courser was stuck at the center and wouldn’t move. After a bit of googling I found this:




Could someone please elaborate a bit on this? It’s a basic Synaptics touchpad for crying out load, so why on earth do I have to deal with this now?

Anyway, I tried installing Fedora 28 applying these aformentiond Kernel parameters

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.notimeout i8042.nomux"

and it didn’t work (but gave me a bunch of errors upon executing update-grub.
Then I installed Leap 15 applying the workaround and now it works.

Now, what should I do?
I can still return the notebook to the vendor (even though I like it, but better get a Lenovo instead). Reason being what will happen in the future with a Kernel update? I don’t want the touchpad to suddenly refuse to work. That’s a risk I don’t want to take, especially seeing that in the case of Fedora 28 it didn’t work at all. I mean, what guarantees me that this workaround will continue to work in the future?

Is that a Kernel bug that can - and will be? - fixed?

Thanks in advance.