Synaptics touchpad no longer working

I am running opensuse 12.3 and the touchpad is no longer working. It works at start up until the tools icon appears. I believe it is problem between the synaptics driver and evdev. If I look in / Ivar/log/Xorg.0.log I see the touchpad detected for a 2’nd time.

69.936] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event0)

69.941] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
69.941] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
69.941] (**) SynPS/2 Synaptics TouchPad: Ignoring device from InputClass "touchpad ignore duplicates"
69.941] (II) config/udev: Adding input device ST LIS3LV02DL Accelerometer (/dev/input/event7)

I also noticed that if I run startx as root The to uchpad works fine.

You failed to say which desktop you are using.

I am using KDE, and the touchpad stops working shortly after the desktop comes up. But that’s because I am running “synaptiks” and have set it to disable the touchpad if it finds another mouse.

It is a while since I last tried Gnome with a touchpad, though it was Gnome 3 (or 3.2).

My best recollection, is that if I use the function key combo to disable the touchpad, it stops working. If I logout, it starts working again. If I login to Gnome, it stops working again. Or, in other words, something in Gnome is remembering the last state of the function key touchpad control.

I’m not sure whether either of the above (KDE or Gnome) applies to you. If not, report your desktop and maybe someone will know what to do.

I am running kde. The touchpad is not set to disable if a mouse is plugged in. I have an HP2540P laptop.

Also /etc/X11/xorg.conf.d/10-evdev.conf contains

Section “InputClass”
Identifier “evdev touchpad catchall”
MatchIsTouchpad “on”
MatchDevicePath “/dev/input/event*”
Driver “evdev”
MatchDevicePath “/dev/input/event*”

and /etc/X11/xorg.conf.d/50-synaptics.conf contains

Section “InputClass”
Identifier “touchpad catchall”
Driver “synaptics”
MatchIsTouchpad “on”

This option is recommend on all Linux systems using evdev, but cannot be

enabled by default. See the following link for details:

Who-T: How to ignore configuration errors

   MatchDevicePath "/dev/input/event*"
   Option    "HorizScrollDelta"    "0"

enable tap-to-click as default (bnc#722457)

   Option "TapButton1" "1"
   Option "TapButton3" "2"
   Option "TapButton2" "3"


Section “InputClass”
Identifier “touchpad ignore duplicates”
MatchIsTouchpad “on”
MatchOS “Linux”
MatchDevicePath “/dev/input/mouse*”
Option “Ignore” “on”

If you logout from KDE, does the touchpad work on the login screen?

Yes … If I logout the touchpad works fine on the login screen.

Also as I said above it also works if I login as root

So it is very likely something in your KDE settings somewhere, or perhaps something in gtk settings that is being followed by KDE.

I had a similar problem. The touchpad stopped working after I used the hardware switch to enable/disable the touchpad. The KDE notifications went into infinite spiral crashing my session.

As a result the touchpad was non-functional despite trying:

synclient TouchpadOff=0

Also the touchpad was enabled during login but disabled after login.

My solution was to rebuild synaptics package. I guess this refreshed some of the settings. Immediately after yast finished reinstalling the package the touchpad was enabled and working.

Try the following:

[li]Start Yast Install/Remove Software tool. [/li][li]Type synaptics and the search result should show:[/li][LIST=1]



[li]Click with the right button on the selected package. Select the fourth option from the drop-down menu. Apply. [/li][li]Wait for it to remove and install again the x86 synaptics. [/li][li]After Yast has disappeared, the touchpad should work. [/li][/LIST]

I have tested this on Compaq CQ61. I hope this solution will help you.

I did not have the KDE spiral that you described but reinstalling synaptics did the trick. It now works fine. Much thanks

Sorry it works only once after the reinstall. If I log out and back in it stops as before. Something during login processing is broken. It worked fine until 12.3 + some updates.

I would create a new user called “Test” and see if it works. If it still doesn’t work, it could be a problem with udev.

Please submit a bug report with Bugzilla

It works fine for a newly created user. Now what in my home directory is the culprit.

Good to hear that you are up and running.

look if you have a file ~/.kde4/share/config/ktouchpadenablerrc

an if yes, look inside.

if it looks like this:


change the value of touchpadEnabled to true, or delete the file.

That will indeed fix it. I stumbled into the cause of the problem in another discussion thread. The HP EliteBook’s (mine is a 2540p) allows the touchpad to be disabled by typing Fn f12. It sets touchpadEnabled=false . The ksynaptics gui does not turn it back on. You have to edit ~/.kde4/share/config/ktouchpadenablerrc . Thanks for the comment.

yes, this was also the case with me.
i have an hp compaq 8710w and there it is the same story… :wink:

for a workaround look at

Found something interesting in 42.2.

I installed to a Toshiba c650 with a synaptics touchpad. Every now and again, I’d “accidentally” go off and click away from where I was typing, it was pretty frustrating. I thought maybe I was dragging my palm across the touchpad so I started looking at ways to prevent this behavior, which led me to this article.

The gnome touchpad application does not save ~all~ options or even present you with the ability to change some if you’re using a synaptics touchpad. I have found that I can fix a few by editing the xorg configuration option file, other options don’t appear to be sticky and must be set manually using synclient. Tip: execute synclient with no options to list available parameters.

I found these options to be useful in preventing the inadvertent mouse clicks on my synaptics touchpad, I placed them in the configuration file /etc/X11/xorg.conf/70-synaptics.conf:

    Option "PalmDetect" "on"
    Option "PalmMinWidth" "6"
    Option "PalmMinZ" "70"
    Option "MaxTapTime" "0"

What I found is that MaxTapTime does not appear to be “sticky” and must be set using the synclient command, so I created a small script file to set it on restart of my machine. I used alacart to create an application pointing to my script file, and tweaktool to launch it on start:

#! /bin/bash

#Script to set trackpad to not do single-click
#uncomment the next line to debug
set -xv

synclient MaxTapTime=0


I’m sure this information may be useful to others, but you’ve responded to an old thread and things have changed. In general if you have some contemporary information you’d like to share (as opposed to seeking support), consider posting to our ‘Unreviewed How To and FAQ’ forum instead.

I’ll close this old thread.