Synaptics Multi-Touch

Hey all,
I recently got a laptop with a multi-touch Synaptics touchpad. I recently got Windows 7 off of it, and installed OpenSuSE 11.2. The touchpad worked under Windows, multiple fingers were detected. However, I find that I cannot even get the touchpad to recognize that there are two fingers on it, much less support the gestures.

The X-Server does NOT recognize it as ALPS, yet synclient -m 100 never shows more than one finger.

If any of you have any ideas, or an article somewhere I should look at, please let me know!

Thanks in advance!

Install ‘gsynaptics’ when on Gnome, ‘synaptiks’ when on KDE4, and run it after install.

I’m on KDE4, and I don’t see the ‘synaptiks’ package anywhere. Which repository should I add to install the package?

Look at this thread:
How do I disable tapping function in the touchpad? - openSUSE Forums

File Name: /etc/hal/fdi/policy/20thirdparty/99-synaptics.fdi

Create this file with the following content (edit it if necessary):

<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
    <match key="info.capabilities" contains="input.touchpad">
      <merge key="input.x11_driver" type="string">synaptics</merge>
      <merge key="input.x11_options.SHMConfig" type="string">on</merge>
      <merge key="input.x11_options.Buttons" type="string">12</merge>
      <merge key="input.x11_options.VertTwoFingerScroll" type="string">1</merge>
      <merge key="input.x11_options.MaxTapTime" type="string">0</merge>
      <merge key="input.x11_options.MaxTapMove" type="string">0</merge>
      <merge key="input.x11_options.ClickFinger2" type="string">3</merge>
      <merge key="input.x11_options.ClickFinger3" type="string">2</merge>

Restart X / computer.

Thanks very much, syampillai! :slight_smile: :slight_smile:

That worked very well!

This does not work for me. All it does is disable my tap touch. What type of laptop are you using? I have an HP dv6. OpenSuSE 11.2

uname -a: Linux linux-6mk9 #1 SMP PREEMPT 2010-03-16 21:25:39 +0100 x86_64 x86_64 x86_64 GNU/Linux

The policy file I posted WILL disable “tap touch” of your touchpad. You may insert/remove/edit lines in that file as per your need. The following command can show you all the available options.

synclient -l

Have you seen thenew announcement from Synaptics:
Going Linux · Synaptics Brings Advanced MultiTouch to Linux

Thanks for bring that announcement to our attention. I’m sure that any vendor GUI config tools will be welcome.

Interesting. I see the options for what I want there but is there a reference somewhere for the values? For example:

CircularScrolling       = 0
CircScrollDelta         = 0.1
CircScrollTrigger       = 0

What thresholds am I looking at? Not clear to me. Thanks for pointing me in the right direction BTW.

synaptics(5) - Linux man page

Hi all,

I’m having similar problems with a new Asus UL20a laptop. Multi-touch/tap works in Win 7, but doesn’t in 11.2 Gnome. I tried installing gsynaptics, creating the hal file, using synclient and no muti-touch. It also seems something in Gnome is conflicting with the hal policy. synclient -m 100 only shows 1 finger.

Any reports of this working in KDE or XFCE? I’m not terribly opposed to switch DEs. Is there a newer driver/kernel I can try? I’m really hoping to get two and three finger tapping working as the mouse buttons on this laptop are horribly designed…


To others that may stumble upon this…

I didn’t get it working, however I did modify the touchpad settings so my bottom right corner is a middle click tap.

To do this, go through the control center > startup applications. Create a new application, and enter the following in the command box:

synclient RBCornerButton=2

So far, it’s been working well, just not as easy as two-finger tapping/scrolling.

Thanks for sharing! I really appreciate it!
Hey! Everyone! My sincerely recommendation! New and low price shoes of NKE、COACH、LACOSTE、BIRKENSTOCK、VISVIM、Reebok、Mizuno、Kashi Kicks、Asics、PUMA. Easy methods of payment, fast delivery, good customer service, favorable price, latest design of shoes. You must get your right ones! Take a look!
Cheap shoes, including cheap men’s shoes, cheap women’s shoes, cheap nike running shoes, are hot-sales on

I tried to look into /etc/hal but there is no directory for hal.

Where do i find the SHMConfig and set it to true ??

Some blog says it’s in xorg.conf or XF86Config but both can’t be found, can please you help me set up my sony vaio’s multitouch pad ?