Switch system packages to Packman doesn't help

Hi,
my video files doesn’t play with dragon, gwenview etc. I add Packman repo, switch system packages to Packman’s but no success.

 tom@DuoCore:~> LANG=C zypper lr -d#  | Alias                                      | Name                                       | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                      | Service
---+--------------------------------------------+--------------------------------------------+---------+-----------+---------+----------+--------+--------------------------------------------------------------------------+--------
 1 | packman.inode.at-openSUSE_Leap_$releasever | Packman Repository                         | Yes     | (r ) Yes  | Yes     |   98     | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_15.2/                         | 
 2 | repo-debug                                 | Debug Repository                           | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.2/repo/oss/      | 
 3 | repo-debug-non-oss                         | Debug Repository (Non-OSS)                 | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.2/repo/non-oss/  | 
 4 | repo-debug-update                          | Update Repository (Debug)                  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.2/oss/                 | 
 5 | repo-debug-update-non-oss                  | Update Repository (Debug, Non-OSS)         | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.2/non-oss/             | 
 6 | repo-non-oss                               | Non-OSS repozitář                          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.2/repo/non-oss/        | 
 7 | repo-oss                                   | Hlavní repozitář                           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.2/repo/oss/            | 
 8 | repo-source                                | Source Repository                          | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.2/repo/oss/     | 
 9 | repo-source-non-oss                        | Source Repository (Non-OSS)                | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.2/repo/non-oss/ | 
10 | repo-update                                | Hlavní aktualizační repozitář              | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.2/oss                        | 
11 | repo-update-non-oss                        | Aktualizační repozitář (uzavřený software) | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.2/non-oss/                   | 
12 | teamviewer                                 | TeamViewer - x86_64                        | Yes     | (r ) Yes  | No      |   99     | rpm-md | https://linux.teamviewer.com/yum/stable/main/binary-x86_64/              | 


 

At first I used graphical Yast, later I tried Konsole with command I found on forum.

 sudo zypper dup --from "Packman Repository" --allow-vendor-change

 

What did I do wrong? Can you give me some advice, please?

I do not think you did anything wrong. Did the switch install packages or not?

packman he point to is not same as mine

VM1:~ # zypper lr  -d
#  | Alias                | Name                              | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                              | Service
---+----------------------+-----------------------------------+---------+-----------+---------+----------+--------+----------------------------------------------------------------------------------+--------
 1 | Packman              | Packman 15.2 Repository           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.2                | 

Lines Delete

VM1:/etc/zypp/repos.d # cat packman.repo
[Packman]
name=Packman $releasever Repository
enabled=1
autorefresh=1
baseurl=http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_$releasever
type=rpm-md
keeppackages=0
VM1:/etc/zypp/repos.d # 

It shouldn’t matter. There are several packman mirrors. You are just using a different mirror. You should be seeing the same packages.

Yes, some. I can’t remember exactly.

IMHO, may be I caused problem with Game repos I added before. Now I both game repositories erased, but video does’t work. One more strange things exist. When I look to Yast, It looks like I didn’t switch package to packman version, no change there.

http://pepa254.sweb.cz/obrazky/index.html

http://pepa254.sweb.cz/obrazky/

Some people prefer to use “opi” to install codecs:

zypper in opi
opi codecs

Or else, install these media players in flatpak format.

You are right, I tried removed my Packman repo, make update and added new one that larryr has. Than I switch again. Problem remains :cry:

Packages which were added: http://pepa254.sweb.cz/obrazky/index.html

Well, it works! Idon’t know what I actually did, but it works. I used “opi”, 32 packages was installed. It is all.
Thank you all!

I quite wonder, why usual way of switching and using codecs from Packman repo didn’t work. What actually is “opi” and what it does another way that all codecs was installed than.

Packages installed with opi, img_3:
http://pepa254.sweb.cz/obrazky/index.html

I quite wonder, why usual way of switching and using codecs from Packman repo didn’t work. What actually is “opi” and what it does another way that all codecs was installed than.

Only installed packages will do an vendor change.

If you need a codec with licences (h264 f.e) you have to install this codec expilizt because openSUSE does not have it in their repos:

zypper se -s h264
Loading repository data...
Reading installed packages...

S  | Name                    | Type       | Version          | Arch   | Repository
---+-------------------------+------------+------------------+--------+-----------
   | h264enc                 | package    | 10.4.7-pm152.3.3 | noarch | packman
   | h264enc                 | package    | 10.4.7-pm152.3.1 | noarch | packman
   | h264enc                 | srcpackage | 10.4.7-pm152.3.3 | noarch | packman
   | h264enc                 | srcpackage | 10.4.7-pm152.3.1 | noarch | packman
i+ | libopenh264-6           | package    | 2.1.1-pm152.1.2  | x86_64 | packman
   | libopenh264-6-debuginfo | package    | 2.1.1-pm152.1.2  | x86_64 | packman
   | openh264                | srcpackage | 2.1.1-pm152.1.2  | noarch | packman
   | openh264                | srcpackage | 2.1.1-pm152.1.1  | noarch | packman
   | openh264-debugsource    | package    | 2.1.1-pm152.1.2  | x86_64 | packman
   | openh264-devel          | package    | 2.1.1-pm152.1.2  | x86_64 | packman

Aha, than why I wasn’t able to change vendor by command ?

  sudo zypper dup --from "Packman Repository" --allow-vendor-change

I thought that it should be the same result?

That will only switch installed packages.

If you need a not installed package, you must install them.

Thats what opi does, it has installed some special codecs by an script.

This is clear to me, but why isn’t that codec installed by default in the first place?

I use the switch mechanism after installation already for years. Never added something extra (either first from OSS before the switch, or after the switch direct from Packman). I never missed something with respect to multi-media. Always though that the basic installation has all (without the full functionality).

I think some of the codecs are pulled in via recommends. People who disable recommends may miss some of those codecs.

Could be an explanation.

OK guys. I don’t know anything special what could cause this. I tried allow nonfree codecs as usually, but…
Never mind, now everything is ok, thank you.

Here’s what opi does: https://github.com/openSUSE/opi/blob/master/opi#L532-L572

It does a dup, then installs a set of codecs that seem to not be pulled by a default installation, even with recommends. I took the dup route and don’t have some of these additional codecs, but don’t recall experiencing codec problems. OP must be needing a very odd codec that’s being provided by one of these additional codecs installed by opi.

Recently updates from Packman repo have been failing, and http://packman.inode.at replies with error 403 - Forbidden.
I selected a different mirror from http://packman.links2linux.org/mirrors and it works.
I don’t know why the nicely-named Austrian mirror is disabled.
I was shocked by the small number of mirrors available, with none in the Americas.

The same experience, thanks for hint.