Swap/partition not mounting after Upgrade from 12.3 -> 13.1

So, My swap partition won’t mount after my upgrade from 12.3 to 13.1. In the boot log I see this:

Expecting device dev-disk-by\x2did-scsi\x2d14d534654202020208515de2206aa374c8f52b5988a2c9d54\x2dpart1.device...
Starting Remount Root and Kernel File Systems...

Then down below that this shows up:

*     ] A start job is running for dev-disk-by\x2did-scsi\x2d14d534654202020208515de2206aa374c8f52b5988a2c9d54\x2dpart1.device
 TIME ] Timed out waiting for device dev-disk-by\x2did-scsi\x2d14d534654202020208515de2206aa374c8f52b5988a2c9d54\x2dpart1.device.
[DEPEND] Dependency failed for /dev/disk/by-id/scsi-14d534654202020208515de2206aa374c8f52b5988a2c9d54-part1.
[DEPEND] Dependency failed for Swap.

After loading up the OS. The swap file is not mounted. I run “swapon /dev/sda1” and it comes back online. But I can’t do that every time I reboot this server.

My fstab looks like this:

/dev/disk/by-id/scsi-14d534654202020208515de2206aa374c8f52b5988a2c9d54-part1 swap                 swap       defaults              0 0
/dev/disk/by-id/scsi-14d534654202020208515de2206aa374c8f52b5988a2c9d54-part2 /                    ext4       acl,user_xattr        1 1
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0

This is a Virtual Machine running within a Hyper-V system. I haven’t had any problems whatsoever with anything else before this time.

On 2014-05-05 17:26, Tomnibus wrote:

> My fstab looks like this:

I’m partial to using the “LABEL=…” syntax, except when impossible. I’m
not saying that this is your problem, though… just an idea to check.

Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

Swap partitions are never “mounted”. They are used as swap (or not).

While it seems unlikely that this is wrong (after all, the same id is used in the root partition mount and seems to work), I would nevertheless at least check if /dev/disk/by-id/scsi-14d534654202020208515de2206aa374c8f52b5988a2c9d54-part1 is indeed a symlink to /dev/sda1.

ls -l/dev/disk/by-id/scsi-14d534654202020208515de2206aa374c8f52b5988a2c9d54-part1

BTW, when this is on a virtual machine, why didn’t you post in the Virtualization forum. Do you rate the people there as incompetent?
And please do NOT double post there. When after some thought, you think it might be better to have itthere, please say so here (I am watching) or use the report button. Then it will be moved.

Assuming that Tomnibus has found an answer to her/ his problem, I would like to take the issue of ‘Problems with the Swap Area’ beyond the problem of an upgrade…

I have a Swap Area that I can’t, for the life of me, make work properly. I think that it may be working some, because, before, my browser would crash after about a half hour, now I can keep it open for hours and hours, though eventually it will begin to get LETHARGIC/ gummed up. It took me a long while to figure out that what was wrong was the lack of a swap area… there’s a prequel, which I’ll mention very briefly…

I had SUSE installed with a given configuration on a 74.5 MB twin set of HDD, where I had set up a RAID 1 “file cabinet” on the remainder, after having created the following on sda (sdb1 uses the same remainder amount, 46.5Gb, for the twin RAID array):

sda1: 24Gb [btrfs] mounted as root ("/")
sda2: 4Gb swap
sda3: 46.5 Gb [btrfs] linux.site: RaidDiar

Well, after a lot of goof-ups, I reinstalled, then reinstalled, except that the second time, even though I did a thorough DBAN erasure (DoD Short, the usual three rounds, etc.), when I reinstalled SUSE (13.1), it recognized EVERYTHING - ALL OF THE PREVIOUS HIERARCHY WAS THERE! Well, since it was my intention to simply replicate everything from the previous installations, I proceeded, except that the Swap Area is NOT working properly.

I have tried multiple times to erase and redo the swap area, and the last time, I even managed to get it to appear “active” (before, it always said “inactive”, and initially, after that second install of SUSE, it wasn’t even specified (not just not labeled), in Gparted, as “swap”, even though, every time I would try to use the SUSE Live CD to make repairs, sda2 would show up as a genuine Swap Area), but the next time I booted, it was back at “inactive”. When I try to assign the Swap Area like so:

sudo swapon /dev/sda2 {for paging}, then, to enable the Swap Area on boot,

sudo /dev/sda2 none swap defaults 0 0,

I get this reply: “Permission denied” (!)


What is wrong here??? Why will swap NOT work for me? {When I enter (under root) “cat /etc/fstab”, I get two only two UUID entries, both of which are btrfs file systems (i.e., sda1 & 3), nor do I see the UUID of the Swap Area, whose long string I have copied for future reference.}


Happily, I have SOLVED this problem, by googling its solution. My Swap Area now shows up in Terminal > sudo (log in as root user) > gparted (which opens a regular Gparted/ Yast-2-Like window) > Right-Click the relevant /dev/sdxx (linux-swap) partition and choose “Information”… which should show the Status as “Active”. How I got there, or the long story, begins right now… (this is written for NOOBS, like me, who need SPECIFIC instructions, NO ASSUMPTIONS!)…

To start with a clean slate, you might want to follow the above Terminal > etc. path to Gparted, and there delete the malfunctioning Swap Area (rendering it “Unallocated”), then create it anew, SAVING the UUID number in an ODT document (in, for example, LibreOffice) - alternatively, if you dare not monkey with your already-created Swap Area, you can query its UUID number like so [assuming you know the partition (alternatively, you can find it by going to KInformation (“Start” > “Computer” > “KInformation”) and clicking on “Device Information” > “Device Viewer” > “Storage Drives” > “Hard Disk Drives” and look for your Swap Area under the “sda” or “sdb” partitions of the relevant Hard Drive)… here, mine is listed only as an example): “sudo blkid /dev/sda2”, less the quotes, and note the spaces BEFORE and AFTER “blkid” (in caps: BLKID)] - in the following format (you’ll need this EXACT format when you edit the “/etc/fstab” file):

UUID=735b3be3-779c-4d21-a944-b033225f3ab4 none swap sw 0 0

where the alphanumeric string just to the right of the equal sign is the UUID number that was assigned when you created the Swap Area.

I went to this site (http://askubuntu.com/questions/33697/how-do-i-add-a-swap-partition-after-system-installation) for the initial instructions (the above UUID string is from that page), but it DIDN’T tell me how to edit the “/etc/fstab” file (too many Linux folk assume that NO ONE who visits a forum is a NOOB, while most NOOBS assume that ANYONE and EVERYONE who visits a forum is a NOOB!), but I found the solution here (http://www.tweakhound.com/2013/12/01/opensuse-13-1-tips-tricks-and-tweaks/), which is simply like so:

Click on “Start” and in the field at the top of the pop-up (alternatively, click on Alt+F2 and you’ll get a FREESTANDING field AT THE TOP OF THE SCREEN), type “kdesu kwrite” (less quotes), then, when the window opens, click “Open” and type in your target, which is “/etc/fstab” (less quotes, of course). This is an editor, like the ones you are used to working with in Windows (such as your “boot.ini” file), so you just place the cursor below the last entry/ line, ON THE LEFT, and plug in your UUID in the manner given above note that there are NO SPACES in the UUID number itself, while there is a space AFTER the UUID number and IN BETWEEN "none, swap, sw, 0 and 0 (those are ZEROES!) - the easiest way to do this is to simply copy and paste it from your ODT doc, and remember, in some Linux applications, hitting Ctrl+V (or Ctrl+C, for that matter) will generate a new entry line in Terminal, which is A PAIN IN THE BUTT, so get in the habit, in Linux, of Right-Clicking and choosing “Copy” or “Paste” from the menu, that way there’s no mess). Click “Save” and then “Quit”, and you’re done!

To check that all is as it should be, repeat the ‘Terminal > sudo (log in as root user) > gparted > blah-blah-blah’ sequence from above, and Right-Click and choose “Information” at the right spot, and if you have followed the procedure correctly, your Swap Area should look PRETTY, i…e., show all of the relevant stuff, like Path and UUID number and, most importantly, Status: Active!

Good luck, fellow NOOB!


ps: ALL OF THE ABOVE applies ONLY (as far as I, a NOOB, know) to KDE-!-!-!

Please, when you have a problem of your own, start a fresh thread with a good telling title. Do not hang your problem at the end of an old (or even still lively) one. The chance that it is exactly the same is minimal (which will create a mess in the thread, who answers what to which problem) and people watching for new threads to help will never see your problem.

Point well taken, Henk! Would it maybe be a good idea to delete ALL of my entries here, saving the contents, then redo it as a new thread, with a completely new title? I am quite willing to do this, for, as a NOOB, I try my best to aid fellow NOOBS who run into exasperating, hair-shedding problems like this one, so since I have done little to help those with MY problem, given that its solution is hidden inside a problem OF A DIFFERENT NATURE, I can see that it may be a good idea to fix up that separate, new thread (I could maybe even add a comment here that points to my problem, if that is deemed to be relevant/ desirable). What say (I’m flexible!), shall I proceed as I suggest here, or should I start a new thread with MY issue, then point to THIS thread for its solution?


The OP did not report the problem solved. In fact he did not answer anything on our suggestions. That means that this thread is a dead alley.

When you have something to ask or even tell about a problem you solved, start your own thread in a fitting (sub)forum with a telling title.