SVN on SUSE 10.3


I would like to install svn as a server. Using yast, I can’t find “svn” nor “subversion” nor “subversion-server”.
I tried “zypper install subversion” also and that failed.

Frustrated, I downloaded the sources and started building.
“configure” fails though on the apache dependencies. I have
apache2 up and running but svn configure does not work
with “–with-apr” pointing to the apache2 because none of
the apache2 directories contains the config files svn

helplessly confused,

Setting up a Subversion server using Apache2 - openSUSE

Worked for me (well aside from one little thing, but I edited the page so that it should be painless now)

Thanks for the pointer to the guide!

But as I indicated, I can’t get past this step:

Software Installation
“Ensure these packages are installed: apache2, apache2-doc, apache2-prefork, libapr1, libapr-util1, neon, subversion, subversion-server.”

because I can’t find subversion in my installation. I don’t understand if this is normal or not. My attempts
to build it from source have also failed.

Index of /repositories/Subversion

Add the suitable repository for your distribution version.

Thanks , this provides the packages for Yast but not
Yeast. Just have a few more dependencies to work out
(libdb) but I’m progressing…

(we need to hire an admin like ASAP)

best regards

Excuse me but… what?

So now my installation is complete (at least Yast stopped
yelling at me) but I also needed libdb (Berkely DB) and
neon (editor) for yast to be happy. This involved some
googling and clicking.

Thanks both for your time and help, you can be sure I’ll
post again when my windoze box svn client gets served by
my beautiful suse svn server.


All is up and running, tutorial is excellent.

great day