Suspend no longer than one second

When my R61 Thinkpad should do a suspend to RAM the moon-LED blinks some seconds, the display turns off, but one second later it turns on again and displays the login dialogue.

I use Suse11. Under Suse10.3 powersaving worked fine.

I found the tip to unload the USB modules. Therfore I added a file /etc/pm/config.d/modules that contains the line

SUSPEND_MODULES="button uhci_hcd ehci_hcd"

Then I did a
> rcpowersaved restart
but suspending still does not work.

A lot depends on your hardware (especially graphics and networking chipsets) and therefore the drivers used. A ThinkWiki thread with suspend info. I also found this thread, which suggested this s2ram command and options work from the command line:

s2ram -f -a 3

If this works, then try creating a text file /etc/pm/config.d/config with this string:

S2RAM_OPTS="-f -a 3"

More advice here:

Pm-utils - openSUSE

Suspend to RAM - openSUSE

Thanks, that did the trick. Everything works.

Is it normal for suspend to take as much time as hibernate (2-3min) to resume?

No, resume typically takes a few seconds to restart display. In my case (not sure how it works for others), I enter my password again, then I’m returned to my active desktop. In your case, it sounds like the system is waiting for some part of the system (network?) to reactivate.

Have a look at /var/log/pm-suspend.log for errors.

Funny thing. Today it is much faster than yesterday!

I didn’t find any errors, though.