SUSE11.1 and DVD writer

Loaded 11.1 last night and was able to get everything working with the exception of the DVD writer. 11.1 sees it as a DVD reader. 10.3 Saw it as a DVD reader/writer.

Will be reloading 10.3 tonight to make sure I can use it as a DVD reader/writer.

Has anyone else had this issue with 11.1

I was about to post a thread about problems with my burner not being recognised in K3b in a fresh openSUSE 11.1 installation.

I tried entering device path manually (in my case it was /dev/sr0, after inserting a disk and opening it with Dolphin, then running “mount” in a terminal to find the correct device name) but K3b complained.

I then opened a terminal as root and did a “chmod a+rw /dev/sr0” and then click refresh in the K3b device section, and it found the device correctly. I’ve tested it by successfully burning a disk.

Problem is that ejecting a disk and inserting another one, my permissions are lost, so I’d like to find some way of making this permanent. I suspect something dealing with udev, but I don’t have time to read up on that. Anybody?

I wish someone would make a sticky somewhere regarding this issue.

Go into Yast, security and users, add your user accounts to the disk group.

Reboot and enjoy

That works as a more permanent solution. I’m puzzled as to why users aren’t made members of this group by default? Having one’s burner recognised as such is a pretty standard thing to expect from any operating system.

I’ve only been using openSUSE 11.1 for two days now (switched from Mandriva 2009) and I have to say that more things haven’t worked out-of-the-box with openSUSE when compared with Mandriva. Don’t get me wrong, openSUSE’s better KDE4 support will keep me here for some time, but that doesn’t mean I can’t maintain a critical eye :slight_smile:

Another thing that puzzles me: the “users” group being used as the default group to secure home directories thereby giving all users on the system access to each other’s stuff. If this is the default, then locking down a DVD burner just seems so at odds with this kind of philosophy by default (one which also enables automatic login by default, too; another reason why locking down access to the burner by default is so strange).

I also can’t get my back and forward buttons to work in Dolphin (they work fine in Firefox), and this “just worked” in Mandriva with KDE4 (when I get sick of fiddling with my xorg.conf to no avail, I’ll post a separate thread).

Users do not have access to each others files or directories.

I’m sorry but I don’t see the relationship between his question/comment and your answer…
What does the CD/DVD burner has to do with file access? If I want to burn some data, normally I must be part of the disk group, but this has to be done automatically while installing openSusE. If this is not done… then we shall follow your recommendation (which I agree it should be a sticky). But normally this must be done by the OS at first time install.
It’s like not having access to a USB port or to the SD Reader. which is done automatically when we install OS the first time.
I might be wrong tho and this is the new “default” for all CD/DVD burners, but in this case… what a wrong mistake from ther OS team!!!

Just my personal opinion.

and BTW… Happy Nerw Year to everyone


PS. I don’t mean to start up a discussion, which may look like. Instead, I just wanted to enfatize the issue and the valid argument given by the original poster.