Suse 11.2 unable to connect to internet

I installed 11.2 on an older HP Laptop which was running XP without any issues.

Durring the install, the update processe failed (presumably unble to connect to respository). I am usind a wired connection and the nic is connecting to my router and is recieving an address via DHCP. I am also able to ping the workstion from the router’s Web interface. However I am unbale to connect to the internet.

I have turned off the Suse firewall via Yast and checked the settings against another computer running ver 11.1 .Everything appears to be correct but no joy.

I am new at the world beyound M$ and a bit lost.

More Information:

I am able to ping other computers inside my network using the console terminal. I am also able to ping my ISP’s name server by name " ping -c5" and the ip address is resolved. I am NOT able to brose web pages.

Seems like a firewall issue but I turned the Suse firewall off (also, no proxy).

Yes, looks like firewall issue. Most routers have own firewall. Try to disable that. Could also be an issue with some other setting of the router.

Have a look at this file: /etc/resolv.conf

You should see the IP number of your ISP’s DNS server. If not edit the file manually and enter the correct IP number.

This seems to be a Suse issue and not a firewall issue. I was able to resolve the problem by entering my ISP DNS addresses into the Yast Network configuration interface. This should not be required when using DHCP or DHCP/Auto.

It seems that Suse is accepting DHCP IP address from my router and resolving the default gateway BUT not accepting DNS relay. My Netopia router receives DNS information dynamically from my service provider and all other computers are able to resolve domain names including 2 VISTA, 1 XP, 1 Suse 11.1 computers. The only computer that is unable to resolve domain names is the Dell laptop where I installed Open Suse 11.2 (using the live install disk. Prior to the full SUSE installation, the laptop was running MS-XP and was resolving domain names through my router via DHCP.

Another oddity is that Open Suse did resolve IP addresses from domain names using the PING utility and was able to do this without the need of manually entering DNS server addresses. However, I could only browse web pages by using actual IP addresses, not domain names.

Please update NetworkManager.

right,I have the some problem ,I tried all combination ,everything seems OK but the internet dont work.uffffffff!.I used classic YASt,network manager too,but nothing,maybe the system has a real problem.I don’t know why ,really,I used all version from SUSE starting with 9.2 till 10,11,ok,ok.Now 11.2 nothing about internet.SUSE is supposed to be friendly ,but now i am sad about it.I suspected the internet connection from home that is weak,but not,the some problem at workplace.

I know,to install printer and internet in linux is difficult ,but it should not be in this way.I am not so stupid as a linux user,believe me,but this common thing,internet connection for me now is a huge problem.Has anyone some help us ?please and thank you in advance a lot to everyone.


all the_best for all linux users

Welcome to the forums, you finally got here !!!

Networking in 11.2 is no different than in 10.x or 11.x. Please tell us how you configured it, how you’re connecting (dialup, direct to modem, router etc). Does Yast see the networkcard ?

direct connection,cable,ethernet
the system recognize the device ,show the IP,gateway,subnet,active status , receiving bytes run,sending NOT sometime few bytes ,after that down and again but sending for very short time.I SUSPECT THIS IS THE REAL PROBLEM .sending bytes /packets dont work properly

and connected of course.but not acces to the internet.I thought is connected to the network but not to the internet ,is it posible no?i tried auto dhcp AFTER i tried yast manually and manny attempts.I used also network manager,the some situation ,ok but not ok in fact.Also save and restart etc…I am sure somehow i make a mistake ,the question is I dont know where…
also I saw the etc/sysconfig/network/config file and etc/resolv.conf ;for me ok.In config was firewall yes ,i put without writing mistake ,no,so …that is …

manny thanks

yast ,yes network manager yes ,both recognize the card

by the way I have laptop ASUS ,and still is posible to be a problem in sysconfig file for network could you tell how i can write ,the ip etc there talk about sintax right.of course gateway and subnet too?because from yast nothing happend after configuration from there



I would like to announce/inform a victory.internet is working ,i did it,finally,after a lot of is working on cable and broadband (vodafone),too.
My mistake of course,wrong editing in etc/sysconfig/network/config.ufff it… was remaining a wrong character.
now it is ok .thank you to all for suggestions about solving the issue.

network manager sometime is real good instead yast

all the best for all linuxusers


Another member happy. Nice.

Suse 11.3,11.4 & 12.1 - had the same problem.
To solve:

  1. Check your network is configured correctly (does not matter network manager or yast, eth or wireless) - in my case it was DHCP client at wlan0 (to check it you can use ping SOME_PUBLIC_IP_ADDRESS )
  2. sudo su - Enter root password
  3. unlink /etc/resolv.conf

  4. /etc/netconfig.d/dns-resolver - will create /etc/resolv.conf according to your present network configuration

After that everything worked well.

Hope, it helps.