SuSE 11.2 KDE not loading KDE login screen and Plasma slow

First, the xdm login screen loading instead of the KDE login screen. I have tried editting /etc/sysconfig/displaymanager both manually and using YaST, so that it currently says that 'DISPLAYMANAGER=“kdm” ', but the computer still boots to the xdm login screen, pictured here. I have also tried setting that variable to “kdm4”. Right before switching to the graphical screen when booting, the computer says “Starting service xdmdone” (copied from /var/log/boot.msg). I am not sure whether this should be happening or not. The pertinent section of /etc/X11/xdm/Xsetup is

#
# Check if kdm is running
#
  kdmpid=/var/run/kdm.pid
kde3root=/opt/kde3/bin
kde4root=/usr/bin
     kdm=no

test -x ${kde3root}/kdm && \
  /sbin/checkproc -p $kdmpid ${kde3root}/kdm &> /dev/null && kdm=yes
test -x ${kde4root}/kdm && \
  /sbin/checkproc -p $kdmpid ${kde4root}/kdm &> /dev/null && kdm=yes

When I do log in, KDE loads, but the first two things I see are that the Run Command Interface crashed and that Plasma crashed, despite that Plasma seems to be working from the presence of the bottom panel. Plasma is definitely working slowly and is using a lot of CPU: Whenever I have checked with top from Cntrl-Alt-F1, it has been using around 80% of CPU. Perhaps because of this, the the computer is running very hard (noisily) and very slowly. I have tried deleting (actually, renaming) the .kde4 file, but that did not seem to fix any of my problems, only making it so that I lost all my defaults.
Also, I cannot load the Run Command Interface, and clicking on anything on the desktop does not seem to do anything, so I have been using the terminal emulation from Cntrl-Alt-F1 for most things.
I have listed the things I have tried, and have run out of ideas. Thank you in advance for your help.

Which openSUSE version?
32/64bit?
Which KDE version?
Please post output of


zypper lr -d

Well the openSUSE version seems to be 11.2 (I read this from the title of the thread :wink: ), but I support Knurpht for the rest of the information.

I am also curious if this is from immediatly after the installation of 11.2 When not, you could elaborate a bit on what you experimented around before this happened.

These are the kde4 settings
http://dl.dropbox.com/u/10573557/Display_window_Manager/display-manager-kde4.jpg
http://dl.dropbox.com/u/10573557/Display_window_Manager/window-manager-kde4.jpg

Post your repo info too as requested.

Remember in answering these questions that I cannot open a lot of things, so I have been asking zypper

OpenSuSE version: 11.1 (sorry about that: I’m running 11.3 on my laptop and thought the desktop was one before it)
32/64 bit?: 32
KDE version: 4.3.4 (KDE 4.3.4) “release 2” or 3.5.10 “release 21.13.1”. Curiously enough, looking at zypper, neither kde3 or kde4 is marked as installed. However, from that the system seemed to be running off ~/.kde4. kde-config --version returned

Qt: 3.3.8b
KDE: 3.5.10 "release 21.13.1" 
kde-config: 1.0

and kde4-config --version returned

Qt: 4.5.3
KDE: 4.3.4 (KDE 4.3.4) "release 2"
kde4-config: 1.0

Output of zypper lr -d:


#  | Alias                     | Name                                              | Enabled | Refresh | Priority | Type   | URI                                                                                   | Service
---+---------------------------+---------------------------------------------------+---------+---------+----------+--------+---------------------------------------------------------------------------------------+--------
1  | KDE:43                    | KDE:43                                            | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/43/openSUSE_11.1/                      |        
2  | KDE:Backports             | KDE:Backports                                     | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Backports/openSUSE_11.1/               |        
3  | KDE:KDE4:Community        | KDE:KDE4:Community                                | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE4:/Community/openSUSE_11.1/         |        
4  | KDE:KDE4:UNSTABLE:Desktop | KDE:KDE4:UNSTABLE:Desktop                         | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE4:/UNSTABLE:/Desktop/openSUSE_11.1/ |        
5  | KDE:Qt                    | KDE:Qt                                            | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Qt/openSUSE_11.1/                      |        
6  | Libdvdcss repository      | Libdvdcss repository                              | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/11.1/                                                  |        
7  | Packman Repository        | Packman Repository                                | Yes     | Yes     |   99     | rpm-md | http://ftp.skynet.be/pub/packman/suse/11.1/                                           |        
8  | devel:languages:haskell   | devel:languages:haskell                           | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/haskell/openSUSE_11.1/    |        
9  | devel:tools:building      | devel:tools:building                              | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/devel:/tools:/building/openSUSE_11.1/       |        
10 | devel:tools:scm           | devel:tools:scm                                   | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/devel:/tools:/scm/openSUSE_11.1/            |        
11 | home:maw:bzr              | home:maw:bzr                                      | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/maw:/bzr/openSUSE_11.1/               |        
12 | mozilla                   | mozilla                                           | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_11.0/                      |        
13 | openoffice.org            | Stable Version of OpenOffice.org  (openSUSE_11.1) | Yes     | No      |   99     | rpm-md | http://download.opensuse.org/repositories/OpenOffice.org:/STABLE/openSUSE_11.1/       |        
14 | repo-debug                | openSUSE-11.1-Debug                               | Yes     | Yes     |  100     | yast2  | http://download.opensuse.org/debug/distribution/11.1/repo/oss/                        |        
15 | repo-non-oss              | openSUSE-11.1-Non-Oss                             | Yes     | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.1/repo/non-oss/                          |        
16 | repo-oss                  | openSUSE-11.1-Oss                                 | Yes     | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.1/repo/oss/                              |        
17 | repo-source               | openSUSE-11.1-Source                              | Yes     | Yes     |  100     | yast2  | http://download.opensuse.org/source/distribution/11.1/repo/oss/                       |        
18 | repo-update               | openSUSE-11.1-Update                              | Yes     | No      |   99     | rpm-md | http://download.opensuse.org/update/11.1/                                             |        

In answer to hcvv, this did not come right after the installation of 11.2 (sorry again). It seemed to happen right after I ran a lot of updates with YaST Online Update, including a kernel update and maybe a plasma or kde update. I do not really know how to find the log of YOU, though.

Time to install 11.3

11.1 support is ended anyway.
I don’t recommend kde4 in 11.1 either (My opinion though)

By the looks of that repo list and possible ‘has been’. I cringe at it.

In response to caf4926, I can of course change the display manager setting back to kdm4, but doing so before did not seem to do me much good. My setting of DEFAULT_WM is “kde”. I will try changing that

KDE 4 was never supported on 11.1. Like caf4962 I think you made a mess of it (but he says it more polite :wink: ).

hcvv wrote:
> KDE 4 was never supported on 11.1.

wait! wasn’t both KDE3.5 and KDE4.0 available on the 11.0 install media?

that is the way i remember it. (and the main reason i’m still on 10.3,
because i didn’t wanna switch from KDE3-stable to either KDE4-beta or
Gnome-ugly (and, most everyone and their sister here would scream
“Luddite”, if you asked a KDE3 question)…


DenverD
CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]
I feel annoyed that I can’t put my wide range of languages on stupid
Facebook. For example, I speak Sarcasm, fluently spoken and written,
and Various Forms of Geek…

s-phi-nl wrote:
> I will try changing that

my guess is the problems you are having now are the result of ‘trying’
things until you find a combination of setting that just happens to
give you what you want…but is not the combination which the
developers intended nor released…

i bet if you install 11.1 KDE and allow YaST to fully patch/update it
you will find that it will load the correct log-in screen, as
expected…and it will continue to do so until you begin “trying”
things…

and, the problem is that the folks here can’t possibly know what you
have tried that is now causing your problem…the best way forward is
to keep notes so you can find your way back to stable…or, just
restore from the system backup on the shelf labeled “Before Trying”…


DenverD
CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]
I feel annoyed that I can’t put my wide range of languages on stupid
Facebook. For example, I speak Sarcasm, fluently spoken and written,
and Various Forms of Geek…