Suse 11.2 and parallel printer HP4L

I use (open) SUSE since version 7.1 and never had any trouble using my HP Laserjet 4L. So I hardly paid any attention to the installation after installing OpenSuse 11.2. Until I tried to print something from and my printer started printing empty pages with a first page with some garbage. It looked like a wrong driver.
Nevertheless: Suse recognized the printer without any trouble and installed - what seemed the correct - driver. I tried several other drivers from the list but they all gave the same result.
Something wrong with the printer - which functions already more than ten years? I tried it on Windows Vista (dual boot on the same computer) and Vista printed without any problem a correct test page. So nothing wrong with the printer.
I tried a live CD with Ubuntu 9.10. And Ubuntu gave the same problem as OpenSuse: printing a line with garbage and empty pages.
Is something wrong with the kernel?

Have you tried the CUPS interface
Delete you current printer in Yast

Look at this
CUPS - Explained - openSUSE Forums

Further to caf4926’s suggestion, typically for HP devices one has a better chance of getting proper behaviour if one installs “hplip”. I can not recall if that is installed by default. You may wish to confirm it is installed.

Thank you for your reply.

Yes I tried Cups. But it didn’ t help.
I rebooted my computer. Deleted my printer.
Reinstalled the printer. I even reinstalled OpenSuse 11.2: but all with the same result.
I love the new version of KDE and OpenSuse 11.2, but as I cannot work without my printer I reinstalled version 11.1.: the printer was detected, the driver installed and my printer works nice and friendly as always.
I used version 11.1 since january 2009 and it never failed me, except for one thing: I couldn’t get my soundcard working; the installation from this morning doesn’t fix that. And 11.2 gives me a splendid sound. So at this moment I have a choice between sound or a printer or so it seems.

Here is the relevant info for your printer: OpenPrinting database - Printer: HP LaserJet 4L.

Maybe not.

If you do wish to try 11.1, please start a new thread and post wrt your sound card, and I’ll try to help there. Often (for example with X-Fi) it is possible to update one’s openSUSE-11.1 alsa-1.0.18 to the latest 1.0.22 alsa (via rpms provided by the openSUSE alsa packager) and there is a HIGH probability that 11.1 will be able to play audio as well as 11.2.

Hi Vodoo,

I have the same printer and the same problem with Suse11.2 It works fine with Ubuntu 9.04 HP4L driver cups+ Gutenprint v5.2.3 but I can’t get this Gutenprint version or a newer one from the link to be installed without errors.
I am stuck an extremly frustrated.

Hey andreaskwoczek, this thread is from last year. You may have better luck starting your own thread…

Still, a basic question … have you installed hplip ?

Like oldpcu says: Have you installed it using hplip?

Open a terminal and run hp-setup and follow the instructions.
My hp4L has been the most reliable of all my printers.

I had the same problem with my old HP LJ4. The yast configurator uses by default a driver that assumes that your LJ4 has a PostScript card installed, when in fact most of them don’t. Change the driver (there are at least four different driver options for the LJ4, if I remember), and then see if it works.

“hplip” is installed by default. I tried it from the command line, but the result is the same. I tried every driver YAST offers (about 8) and they all behave in the same way. The same applies to ubuntu 9.10 live and knoppix 6.3
Remebering about suse 9.3 and 10.? I think there was a similar problem, but I used I different parallel Printer from Kyocera…
What is the difference between ubuntu 9.04 und 9.10 and suse 11.2 in terms of printer drivers?? If it works with ubuntu 9.04 it is definitly no Hardware problem. I am not sure, but the printer worked without problem with suse 11.1, but I would hate to go back because of the printer!

hp4l uses pcl printer drivers. Choose one of the pcl drivers when hplip asks for the driver file to use. Do you remember which ppd file you used in 11.1?
If you are still having a problem, I’ll resurrect my hp4l and give it a try.

I am now really puzzled. Yast detects my printer correctly, but no device driver works. If I now try hp-setup or hp-toolbox both answer with “no installed HP devices found”. With device discovery the same result, refreshing hangs up the complete device manager and he does not react to any input any more. You can only kill hp-setup with all child processes. I tried it with out installed Yast printer and with: no difference. Somewhere was mentioned to switch of the postscript processing. But where should this be done?

Linux/unix printing is done via a ‘print definition file’ which tells the printer how to format the file that is sent to it. Postscipt has always been part of nix, and if you had a postscipt printer you coul just copy the file to the printer without any extra parsing/formatting.
If yast detects the printer, go to yast2>hardware>printers and set it up or install it from there.
Just check the ppd file description and choose the pcl3 file for printing (it will give you a choice of files to use).

Sorry but i just downloaded the Suse 11.1 live cd and bootet from it. opened Yast2, printer. yast did not tell me which printer, only unkown printer on lp0. I searched for laserjet and was offered "HP Laserjet Series PCL 4/5.1.3, which i choosed and printed a perfect Yast2testprint@linux page with CUPS v1.3.x. Rebooting my Suse 11.2, choosing the same printer driver just gives me the usual garbage. Where the hack is the difference in the bloody software? I tried a generic laserjet, giving the same garbage. From my point of view there is nothing wrong withj my System but there has to be a bug within Suse11.2! Where should i look?

OK, try adding it differently.
Open a browser and enter:
This will bring up cups.
Make a note of the printer’s Device URI.

Now go to Modify Printer and enter the name, etc and then continue.
Enter the device uri from above and then choose the hp4l with one of the gutenprint drivers.

If you are still having problems, I’ll dig out my hp4l and check.

I followed your steps exactly The printer URI is with both Suse 11.1 and 11.2 :
but still only in suse11.1 I am able to print. I tried different drivers, I tried different URIs for HP-devices from the cups doc. But no success.

I cecked which moduls are loaded during printerinstallation both with Suse11.1live and 11.2 the only difference are the lp modules. Here are the files from modinfo

for Suse11.1:
filename: /lib/modules/
license: GPL
alias: char-major-6-*
srcversion: 91F649757C2C0BADC6164A4
depends: parport
supported: yes
vermagic: SMP mod_unload modversions
parm: parport:array of charp
parm: reset:bool

for Suse 11.2:

filename: /lib/modules/
license: GPL
alias: char-major-6-*
srcversion: F5ACA04A12C4DC14853A3D9
depends: parport
vermagic: SMP preempt mod_unload modversions 686
parm: parport:array of charp
parm: reset:bool

I could supply the modinfo’s with or without printer too. But the only different modul is the lp.

How do I continue from here. I don’t know C so i daubt it will help to look into the source files of both modules, but I would give it a try if I knew where I would find them. If there is a mantainer for this i would even dare to mail him directly, but end of knowledge and only you or google could help.

OK, I’ll dig out my hp4l and see if I get it going on 11.2

OK, fired up my hp4l and connected it to a fresh 11.2 install.
Yast>printers doidn’t find it, but cups did.
It comes up as hp4l on /dev/lp0.
Choose the default guenprint driver suggested by cups.
(perhaps first try adding via yast so it can download the drivers and then install in cups.)
Haven’t tried it with hplip though.

HPLIP doesn’t work with the hp4l, so use cups. If you really want to use hplip, you may find out more from the hplip website.