SuSE 11.1 Worse Suse yet!!

To be clear, I’m not a novice at this, I’ve used SuSE since 6.0 and I am an embedded developer by trade with a lot of Linux experience.

Installation of SuSE 11.1
I was upgrading from 11.0 and had a 4 disk RAID 5 system configured that was completely recognized by the upgrade from 10.x to 11.0 without any problems, it just worked. From 11.0 to 11.1 the story is completely different. It completely destroyed my array. It overwrote 3 disks, changing their filesystems and essentially left it as a unbootable shambles. I ended up having to do an installation as a new machine.

In trying to layout the 4 disks as a RAID 5 array the screens are unintelligible and in the end I still don’t really know if I have the same configuration as the previous system. In fact I’m pretty sure I don’t and that one of the hard disks is not being used. Since you have changed the way sysinfo shows the disk layout I can’t seem to find an easy way to check what the configuration is.

Using the Installed System
What can I say here, things that used to work, have always worked are no longer working. The desktop (kde4) is a complete disaster. You have these widget things that are not as useful as the old dekstop panel tools. I want to (for instance) create a URL icon on the desktop. I have to bring up dolphin, use the create URL in the desktop folder and then, it doesn’t work. I can click on it until I’ve worn a hole in the mouse button and the URL never gets opened by my browser. Its just dead.

Now lets talk about the application tray!! Gawd, it’s full of things that aren’t actually running. In some case there is no icon being displayed, its just a space.

WHAT HAPPENED TO THE BASIC SET OF KDE SCREEN SAVERS? Instead I have a small selection of the old crappy stuff. It’s not complete by any measure to the previous system.

What’s up with Amarok? It crashes about twice a weak. I usually come home and there’s the email app running waiting for me to send off the latest crash report to Amarok.

Eclipse, I don’t particularly like Eclipse but I do use it for browsing large projects. I loaded it onto the system and then saw I had to add the CDT plugin. For some reason it’s not part of the SuSE packages so I go to download it using the built-in tool management in Eclipse and it says, “Eclipse has not be properly configured to be modified”. That’s bogus… WHAT HAVE YOU DONE?

I configured the mail client to use sendmail as as “direct” for the connection to the internet. It worked since in this case I don’t use the MTA configuration tool in Yast. I ran into a problem and actually brought up Yast, clicked on the MTA icon and then decided to just exit the tool (which I did correctly). Your tool then proceeded to re-write the file and it did it WRONG!! For a direct connection you leave the value for the field “relayhost” EMPTY!! DO YOU @#$%@%##@$ HEAR ME!! Anything else means that you require to configure a relay host.

This is but a short list of the problems I’ve run into. It basically fuels my growing frustration with your distribution. I don’t think I will be using your distribution much beyond this version which is disappointing since I’ve used it and gotten to know over so many years.

Good Luck!!

Name + Text = Either a troll or a bot.

Not quite sure which you are, yet but most likely both.

I have to agree on the original sentiment there, there are a lot more things that no longer work for me under 11.1 that worked under 10.3 and 11.0.

Simple things like my screen no longer being detected as 1280x800, and only 1024x768, hotkeys not functioning etc’.

But to be fair, you did an update, not an install of 11.1, (Notice I didn’t say upgrade there ;)).

Updates rarely work in my limited experience.

Plus if I had all those scary RAID drives I would be too afraid to mess with them in the first place. I run an encrypted /home partition, and that is bad enough!

You did back everything up first didn’t you?

But things are getting back on track, and I am really looking forward to the next release, I think a lot of the issues were because of the gradual switch to KDE4, and the necessity of having to mix KDE3 and KDE4 apps together.

Plus they will have more time for this release, the short dev time was in my opinion far too short.

Chrysantine, you must be right. It then gets picked up by google bot and people see stupid posts and fail to see that the person has just two posts?

I certainly understand the “gradual” switch over to the kde4 but that was already started in 11.0. It should have been finished off there.

The RAID stuff just wasn’t scary under 10.x. It was very straight forward. It appears that 11.1 has made it scary.

But then, according to someone, I’m just a troll and not to be listened too.

One thing that baffles me is the totally different kinds of installations that occur when SuSE is installed on 2 machines. Both are dual core although one is an INTEL and the other is an AMD based machine. Both are 64-bit. However, the packages and RPM repositories somehow are configured differently. The “Eclipse” installation is completely different from one to the other and the plugin installation is only a problem on one of them. The other has a CDT package available. I find this kind of peculiar since Eclipse is a Java app (one reason why I don’t like it much) and it should not suffer differences from system to system. I do realize that one issue is an installation issue and the other is a architecture issue but I still find it ironic.


Well ok but if you are not a novice how come you didn’t do a backup?
I also am not a complete novice (though in linux i probably am :slight_smile:
But i never underestimated the need to make backups, especially on RAID where anything can happenrotfl!

Regarding the DE, you can still choose KDE 3.5 in 11.1, why didn’t you do that then?

I was asked if I did a backup, I hadn’t replied as to whether or not I had.

In fact I did do a backup. Why is this relevant?

My reason for using the RAID 5 system was that if I ever lost one of the disks, I could replace it and then rebuild it from the other 3. Not an actual backup but it gives me a warm fuzzy feeling knowing that the 4 disks essentially protect themselves from failures. I have a large network storage system that critical data also gets copied to as a separate backup.


There are no different repositories for different manufacturers.

And you were “an experienced” user and yet you somehow are unable to compare the output of zypper sl -d on both machines?

RAID5 does nothing for filesystem corruption - relying on R5 to protect you in the event of catastrophic failure is inane, to say the least.

> To be clear, I’m not a novice at this, I’ve used SuSE since 6.0 and I am
> an embedded developer by trade with a lot of Linux experience.
> I was upgrading from 11.0 and had a 4 disk RAID 5 system configured
> that was completely recognized by the upgrade from 10.x to 11.0 without
> any problems, it just worked. From 11.0 to 11.1 the story is completely
> different.

yep…lots and lots of folks got caught by the 11.1 disaster…

nearly the same thing happened when 11.0 came out…i got in the habit
about 9.3 of reading the posts for two or three months prior to
‘upgrading’…and, skipped some trouble in 10.x, and currently run
10.3…i HAD intended to go to 11.1 (skipping the 10.0 junk) but now
i wait and hope for some stability in 11.2, and guess you should have

my current openSUSE upgrade plan is:

  • read and think for two or three months after 11.2 release, at least
  • participate in the 11.2 beta
  • hope 11.2 is better
  • fallback: buy SLED 11, or jump to something else

ignore those who call you bot/troll…i KNOW problems are rampant in
11.x, one only has to be able to read to know that.



Sorry to read about bout your bad 11.1 experience.

IMHO you are wasting your time with your KDE4 rant.

A LOT of us spent a LOT of effort pushing to keep kde-3.5.10 in openSUSE-11.1. KDE-3.5.10 in openSUSE-11.1 is likely the best KDE implementation yet. Why are you ranting about 4.1.3 (which is likely the best KDE4 implementation by any distribution in Dec-2008 when 11.1 was released) when there is a far superior 3.5.10 available. Why are you wasting your time on KDE4?

YOU made a mistake. You should have stuck with KDE-3.5.10. You had the choice when you installed 11.1. You still have the choice to do it now. Why do you think so many of us pushed for the retention of KDE3 in openSUSE-11.1 ?

Good luck in what ever you decide to do next, but my recommendation is don’t waste you time being upset over the KDE4 implementation. Simply install KDE-3.5.10. If you know as much about SuSE as you say, you will know its fast and VERY easy to do.

yep … and lots and lots of folks found 11.1 the best release yet. NONE of the earlier openSUSE releases would function on my new laptop. 11.1 would.

As the saying goes, YMMV (your mileage may vary).

Participating in the very last alpha and the beta releases is a good idea IMHO. But be prepared to install quick and write the bug reports quick. The turn around is fast, and in my limited experience on this, the time window for having one’s bugs / observations acted upon is brief. BUT IMHO, while brief, one can often influence things more at that stage, than at any other stage of the openSUSE release.

Is there a possibility of KDE 3.5.10 being an option as a DE (Desktop Envt.) in openSUSE 11.2 ?
If (as seems likely) KDE 3.5 will not be in openSUSE 11.2, is there a way to install it and add it later, (after Operating System install) as an option to boot into ?

I’m don’t see how the OP can say 11.1 is bad when most of his rant is about KDE4. I don’t care for KDE4, so I use Gnome. If you don’t like Gnome, try KDE 3.5.10 or LXDE. There are other choices.

This is the first version of SUSE I’ve have run. It is the best OS I’ve run to date. It’s not perfect for it is pretty darn close for my use.


I’m have a different attitude towards openSUSE 11.1 64 bit KDE4 desktop. It’s because this is the first time I have tried SUSE. Yes, I am having some problems, as in no KDE system login sound, but I do have the logout sound. I got it to work intermittently when I added user and audio to “additional groups” in user management. Seems a start up program is interferring with it, as I can hear my speaker make a snap noise when the “tune” should play.
Also, when I insert an audio cd, Dolphin doesn’t recognize it (don’t get a device notification popup like I do when I insert a data cd or a data or video dvd.) Probably a udev problem, a guess. The problem still exists after doing patch update. But it is a much much better experience with my first try of Fedora 9 KDE4 for 64 bit processor. That trial lasted a week.

Otherwise I am able to use my full 4GB of memory, use my amd athlon 64 processor, and try out the new KDE4 desktop, which is appreciated. The problems I have encountered have sent me searching for answers, and because of this, I am learning a bunch more about the linux system I never knew about. I guess I like problem solving. When I get stuck, I check for updates, and well, I can wait for future patches. It does have a much later kernel than what I am using on two other distros, so I can imagine, problems will be there. And, it nearly, almost, but not quite recognized and got my CanoScan 5600F working. :wink: In the meantime, I can go work on my crossword puzzle. Yep, I find problems challenging. The few things that are not working for me are small in comparison to what I am offered to use in the system, though I’ve only used a few of the applications. All still new and exciting to me.

I and “we” feel your pain. But it’s not painful enough to leave SuSE behind. We were planning on moving from 11.0 to 11.1 after waiting a reasonable time for the real beta testing to be completed by the community.

We saw issues with Screensavers in 3.5.10. We also had Amarok and sound problems. We didn’t do an upgrade. We don’t “upgrade” anymore from the experience we had with the openSuSE 9 series. Even that experience wasn’t “too” painful. Now we save our home partitions and do fresh installations leaving desired software and iso files in a local portable installation repository.

At one point I had OpenSuSE 11.1 working after pulling some hair out and spending more then one late night tweeking. I was almost happy.

Issues I saw included:
– No screen savers in KDE 3.5.10 (sort of fixed)
– Annoying font-aches (takes some tweeking)
– Vmware was a hassle to setup ( sigh… )
– VirtualBox stopped liking OpenSuSE 11.1 after an update. (gave up on that one)
– Setting up dual-mode and Crossfire was a pain. (Worked up until recent software update)
– Eclipse and PDT (cough probably go with netbeans in SuSE 11.2 if there is an improvement)
– We don’t use KDE 4.x for anything. (It’s still in Beta testing by the world)

– Gnome always works

I started with a fully functioning 11.0 system with only had one constant issue relating to the mounting of ntfs volumes. This was a direct result of permissions and incorrect dismounts by network users. This was a pain because we are constantly moving large files between removable external data sources which have to be on ntfs volumes that are shared with windows systems. OpenSuSE 11.1 was suppose to help correct some of the above.

For about three weeks I had my primary system working with OpenSuSE 11.1.
AMD 6000
ATI 3450 video
4 gb Ram
3 HDs
I put OpenSuSE 11.1 on a HP/Compac Turion Dual and Acer Intel single core notebook; where we had OpenSuSE 11.0 working with wifi drivers. For the most part everything seemed to work up to the last week of March 2009.

I performed what I thought would be my last OS update before moving 3 more systems to OpenSuSE 11.1. That was the end of my happy 11.1 desktop configuration and the HP/Compac notebook is having some issues staying connecting to any wifi or wired network. I’m getting use to seeing eth0 ??? with a count down on the notebook and desktop system. On a clean 11.1 install without updates I can get the network thing sorted out but once we start applying the updates things start to get chaotic.

I didn’t completely update the Acer; won’t risk it at this point. It’s working… but it’s a 32bit installation with Intel as the core. Wifi no longer works in 11.1 on the Acer but everything else does. Most everything is going back to OpenSuSE 11.0, SLED 11.0 (if it cuts mustard), or Slam64 12.2 (have to see how much beer I have in the fridge)

OpenSuSE 11.1 is the “worst” SuSE to date in my opinion. I’m not looking forward to the OpenSuSE 11.0 re-installs but that’s life. I know that OpenSuSE 11.0 works. I’m sure I really don’t have enough beer in the fridge to try out Slam64 12.2. OpenSuSE 11.0 just… works for us!

Okay, I agree with this spam boot in one thing:
Eclipse plugin integration the worst on openSUSE. I can’t finish my homework without hacking cracking some settings and browsing for solutions. :slight_smile:

I Have to agree. Here is my story, I have used Suse and KDE since 2000 and have been really happy, so when version 11.1 hit the mirrors I downloaded and executed a fresh install, BIG MISTAKE since then I can’t listen to my favourite radio program in Firebox (OK in Gnome, but don’t like Gnome) and can see but not hear flash video’s, also KDE 4’S wallpaper slide show starts at the same wallpaper every time I log on, a waist of time using it! and there’s more which I won’t go into now.
So what did I do, I installed “Mandriva One 2009” and hey every thing works out of the box! So it’s not KDE, anyway it looks like I’ll have to stay with Mandriva until Suse gets their act together and fix all the problem with this release. I still have it installed on a spare partition and will check every now and then.This really saddens me because I have always prefered Suse, but I’m a bit sick after nine years of going under the hood so to speak to fix those niggling problems, if Suse & Linux is to be considered any thing other than a toy for geeks it
needs to be a bit more complete (drivers,Libraries,configuration etc. )on install. Here’s hoping

Why does it sadden you (using Mandriva)? Linux is Linux. Whats wrong with Mandriva?

I agree with you that that partitioning during setup has gotten a lot a harder to see what’s going on… with a lot of double info and the places where you need to go reached after 2-3 clicks instead of one…
I remember reading about how they researched what would work the best and it’s what they implemented so I was reluctant to complain about it and after installing openSUSE 11.1 about 8 times I can find my way around in it. (Still, old version was better imo)

KDE4.1 is quite decent to be honest, did you try settings the desktop ‘type’ to ‘Folder view’ instead of desktop? It’s pretty much the “old” version.
Not sure if that’s actually available in 4.1, been using 4.2 for a long time and currently using 4.3.
The system tray is indeed buggy, in the 4.3 beta for the first time ALL of my icons seems to work properly, think if you’re using an nvidia card it’s important to keep your drivers up to date for this one.

As for eclipse, that’s due to a change in eclipse itself. Go to:
Window > Preferences > Capabilities (think it’s under general) and there is a “Classic update” or something like that, enable it and it works fine again.

Your right Linux is Linux a lot of us forget that fact, and there is nothing wrong with Mandriva, it’s just that for a long time now I have been comfortable with the look, feel and configure-ability of Suse and to see it sliding over the last few releases is what saddens me. but I still look forward to 11.2 or 3