Suse 11.1, installation, keyboard blocked during boot menu

Have burned Suse 11.1 on a DVD with the downloaded ISO image and checked the burning result.
Problem: The boot menu does not receive any keyboard inputs (standard type keyboard; that is the same with another keyboard, and also when the there is no mouse connected; after the default waiting period the default item is applied). That is also the same with the installed Suse 10.3; but I did not even notice this until to now.
Question: How can I access the boot menue item “boot from removable disc”? Now, in the 10.3 installation, I have moved the item “boot from removable disc” to the top. Indeed, the PC seems to boot from the DVD. But, as mentioned in the installation manual, then the 11.1 version also selects the boot menue item “boot from harddisc”, and on the harddisc there is still version 10.3. So even this did not help. What can I do to have the PC boot from the ISO-DVD or from ISO image in the home directory? Or how can I install Suse 11.1 under the given circumstances, without having to format the harddisc?

Maybe you can find the solution in this thread, 4th reply: 11.1 install dvd not responding to keyboard. - openSUSE Forums
If it doesn’t work and you have a usb keyboard, check that usb support during boot is enabled in bios.

It is a PS2 keyboard. I just noticed that I cannot enter the boot menu either (should be via key F11), although the keyboard works fine with linux and KDE (otherwise you could not read this). What could be the reason that I cannot enter the boot menu?

pardon: I meant: …just noticed that I cannot enter the BIOS either. What could be the reason that I cannot enter the BIOS?

To access bios maybe you have to press other keys, but you could also try unplugging all devices except keyboard to avoid conflicts during boot.

In fact, according to the first screen messages and according to the manual the key for BIOS is F2. I tried all F-Keys. According to the motherboard manual 775i65GV from ASRock the BIOS is an AMI legal BIOS with ACPI 1.1 compliance wake up events. In the meantime, several further ideas have been offered to me for fixing the problem. However, none of them solved it. I am really annoyed. Perhaps, it was the best I’d buy a new motherboard, preferably of a different type, and reuse the old microprocessor. However, it would be even simpler, if there would be someone explaining me how to install Suse 11.1 from Suse 10.3 without employing/passing the boot procedure.

Go to BIOS, find your USB settings and Enable Legacy support for USB devices.

Well I should be less presumptious and read that it was a PS2 keyboard - ignore this post.