SUSE 11.0 & F5D8053 N Wireless USB adapter - belkin

Hi everyone,

I’m new to Linux and looking for some basic step-by-step help in setting up my wireless usb adapter (belkin F5D8053 N wireless USB adapter). I’ve searched the forum and read many of the posts but I’m still confused and starting to get more confused as I go. I am running SUSE 11.0.

So, currently I’m successfully WIRED to my router (belkin N wireless router F5D8233-4v3) using the Network Manager and an ethernet card. I know my wireless hardware (the usb adapter and router) work because if I boot into Windows2000 I can connect without being WIRED.

Opening YaST and looking under USB in my Hardware Information I can see that the F5D8053 usb adapter is recognized. However, looking at the usb adapter I see no blinking light (usually blinks when running in Windows). After running some of the suggested commands from the sticky tread, I get the following:


/usr/bin/lsusb

Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Bus 001 Device 002: ID 050d:8053 Belkin Components

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

/usr/sbin/iwconfig

lo no wireless extensions.

eth0 no wireless extensions.

using the root account:
/usr/sbin/iwlist scan

lo Interface doesn’t support scanning.

eth0 Interface doesn’t support scanning.


eth0 is my WIRED connection. Since Linux can see the wireless USB adapter in the Hardware Info, is there a simple way to get the adapter working and have it show up in my Network Manager)??
Even though Linux can see the adapter, if a driver is needed, do I have to use Ndiswrapper with a windows driver or can I use one of the existing Linux drivers?

If it would be easier to set-up using the console, I am willing to try… but please remember that I am new to Linux and would require step-by-step directions.

I thank you in advance for your help and time.
Cheers

Found the following additional info for my USB adapter:

vendor and product code: man:050d dev:8053
chipset: ralink
driver: rt2870
driver available at:
web.ralinktech.com/ralink/Home/Support/Linux.html

Any suggestions what to do from here?? how to install the driver?? I apologize if my questions are trivial… I’m very new to linux.

Hoping someone can help… - Thanks

There is not a driver included in even the latest kernels for that device.

You need to go to the URL you listed and download the file for the
rt2870. It is a tar file compressed with bzip2, thus you should save
it in your home directory, then open a terminal and enter the command
‘tar jxvf <filename>’. Just to make it clear, substitute the actual
file name for the brackets and the stuff inside. You will also need to
install make, gcc, and the kernel headers for the kernel you are using.

After all that stuff is installed, then cd to the directory that was
created by the tar statement above, read all the files with names like
INSTALL or README. After you have done the things they say, type the
command make. Once it builds without error, you will likely need a
‘sudo make install’ command. If that works without error, then ‘sudo
modprobe -v <module_name>’.

Larry

Thanks! I will give it a shot. I’m guessing I would install: make, gcc, and the kernel headers using YaST…

The read me file is somewhat difficult to follow. I included the build section below and describe in italics what I’m having trouble with…

Build Instructions:

====================

1> $tar -xvzf DPO_RT2870_Linux_STA_x.x.x.x.tgz

go to "./DPO_RT2870_Linux_STA_x.x.x.x" directory.

*DPO_RT2870_Linux_STA_x.x.x.x.tgz does not exist??

I’m assuming that maybe this is an old name and that the new name is:
2008_0718_RT2870_Linux_STA_v1.3.1.0.tar.bz2

I think this is the driver I’m suppose to use from the manufacture’s aforementioned website - earlier in this thread? although this is a tar and not a tgz file… there is also another file on the manufacture’s website - not sure if its needed *

2> In Makefile

 set the "MODE = STA" in Makefile and chose the TARGET to Linux by set "TARGET = LINUX"

I think this is already done in makefile.

 define the linux kernel source include file path LINUX_SRC

 modify to meet your need.

Don’t know how to do this??

3> In os/linux/config.mk

define the GCC and LD of the target machine

How do I define GCC and LD??

define the compiler flags CFLAGS

modify to meet your need.

Also don’t know what to do here??

** Build for being controlled by NetworkManager

   Please set 'HAS_WPA_SUPPLICANT=y' and 'HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y'.

I managed to get this step done.

** Build for being controlled by WpaSupplicant with Ralink Custom Event

   Please set 'HAS_WPA_SUPPLICANT=y' and 'HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=n'.

   command: #./wpa_supplicant -Dralink -ira0 -c wpa_supplicant.conf -d

Skipped this since I aim to use network manager

4>$make # compile driver source code

Tried this and got the following:

make -C tools
make[1]: Entering directory /home/install/belkin_wireless_USB/2008_0718_RT2870_Linux_STA_v1.3.1.0/tools' gcc -g bin2h.c -o bin2h make[1]: Leaving directory /home/install/belkin_wireless_USB/2008_0718_RT2870_Linux_STA_v1.3.1.0/tools’
/home/install/belkin_wireless_USB/2008_0718_RT2870_Linux_STA_v1.3.1.0/tools/bin2h
cp -f os/linux/Makefile.6 /home/install/belkin_wireless_USB/2008_0718_RT2870_Linux_STA_v1.3.1.0/os/linux/Makefile
make -C /lib/modules/2.6.25.16-0.1-pae/build SUBDIRS=/home/install/belkin_wireless_USB/2008_0718_RT2870_Linux_STA_v1.3.1.0/os/linux modules
make[1]: Entering directory /usr/src/linux-2.6.25.16-0.1-obj/i386/pae' make[1]: *** No rule to make target modules’. Stop.
make[1]: Leaving directory `/usr/src/linux-2.6.25.16-0.1-obj/i386/pae’
make: *** [LINUX] Error 2

Stopped here since I received an error… any help would be GREATLY appreciated

5> $cp RT2870STA.dat /etc/Wireless/RT2870STA/RT2870STA.dat
6> load driver, go to “os/linux/” directory.

#[kernel 2.4]

#    $/sbin/insmod rt2870sta.o

#    $/sbin/ifconfig ra0 inet YOUR_IP up

#[kernel 2.6]

#    $/sbin/insmod rt2870sta.ko

#    $/sbin/ifconfig ra0 inet YOUR_IP up

7> unload driver

$/sbin/ifconfig ra0 down

$/sbin/rmmod rt2870sta

linuxstudent wrote:
> modules
> make[1]: Entering directory `/usr/src/linux-2.6.25.16-0.1-obj/i386/pae’

make[1]: *** No rule to make target modules'. Stop. &gt; make[1]: Leaving directory /usr/src/linux-2.6.25.16-0.1-obj/i386/pae’
> make: *** [LINUX] Error 2
>

Install the kernel header package for your pae kernel.

I used YaST and installed make, gcc, and the header files as you initially suggested before doing anything with the downloaded driver files. Then I followed the read-me file directions and got the error listed in my previous post.

I don’t see a separate install in YaST for pae kernel header files?? do you know what the filename is for the pae header file?? where do I find it?

Thanks

linuxstudent wrote:
> I used YaST and installed make, gcc, and the header files as you
> initially suggested before doing anything with the downloaded driver
> files. Then I followed the read-me file directions and got the error
> listed in my previous post.
>
> I don’t see a separate install in YaST for pae kernel header files?? do
> you know what the filename is for the pae header file?? where do I find
> it?

The package name is “linux-kernel-headers”. It covers all the kernels.

Larry

I have the same chipset but different USB wifi card, Asus WL-160N.

I assume these same driver instructions may work for my adapter.

What would the module name be for the modprobe command?

I installed the linux-kernel-header file using YaST before moving on to the directions in the driver read me files. So I think the error is coming from my inability to correctly follow and do all the read me file directions.

A more basic step-by-step how-to would be of great value to me and other newbies that may have this USB wireless adapter/chipset. I apologize for needing baby steps but I really do appreciate your help.
Thanks

which file did you download ? can you put a link to it & i’ll have a look

Andy

From YaST I installed make, gcc, and the linux kernel header files.

Then I went to this website:
web.ralinktech.com/ralink/Home/Support/Linux.html

and downloaded this file:
RT2870USB(RT2870/RT2770)

I’m not sure what the RT2870WebUI file is and the firmware link did not go anywhere useful for me…

Then I put the file in the following directory:
/home/install/belkin_wireless_USB

Then I ran the following command:
tar jxvf 2008_0718_RT2870_Linux_STA_v1.3.1.0.tar.bz2

Opened the read-me file and had trouble following what needs to be done from there.

Thanks for taking a look.

Are you using 32bit or 64bit SuSE ? Also, make sure you have gcc/gcc++/kernel sources & make installed & up to date. I Just followed the instructions, you don’t have to change anything,just leave defaults & it should compile.Once compiled, move RT2870STA.dat to /etc/Wireless/RT2870STA & follow the rest of the instructions

Andy

Hi and thank you for your reply.
I’m using 32bit SuSE.

I installed the additional files from YaSt (ie: gcc/gcc++ and the kernel sources). I then made the correction in the config.mk file as directed by the readme file:

** Build for being controlled by NetworkManager
Please set ‘HAS_WPA_SUPPLICANT=y’ and ‘HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y’

then I typed make and it ran fine other than the following statements:

/home/tk/install/belkin_wireless_USB/2008_0718_RT2870_Linux_STA_v1.3.1.0/os/linux/…/…/os/li.c: In function ‘rt_ioctl_giwscan’:
/home/tk/install/belkin_wireless_USB/2008_0718_RT2870_Linux_STA_v1.3.1.0/os/linux/…/…/os/li.c:1337: warning: unused variable ‘idx’

LD [M] /home/tk/install/belkin_wireless_USB/2008_0718_RT2870_Linux_STA_v1.3.1.0/os/linux/r
WARNING: /home/tk/install/belkin_wireless_USB/2008_0718_RT2870_Linux_STA_v1.3.1.0/os/linux/rtxt+0x3b20d): Section mismatch in reference from the function rtusb_probe() to the function .devinx_probe()
The function rtusb_probe() references
the function __devinit rt28xx_probe().
This is often because rtusb_probe lacks a __devinit
annotation or the annotation of rt28xx_probe is wrong.

Building modules, stage 2.
MODPOST 1 modules
WARNING: /home/tk/install/belkin_wireless_USB/2008_0718_RT2870_Linux_STA_v1.3.1.0/os/linux/rtxt+0x3b20d): Section mismatch in reference from the function rtusb_probe() to the function .devinx_probe()
The function rtusb_probe() references
the function __devinit rt28xx_probe().
This is often because rtusb_probe lacks a __devinit
annotation or the annotation of rt28xx_probe is wrong.

CC /home/tk/install/belkin_wireless_USB/2008_0718_RT2870_Linux_STA_v1.3.1.0/os/linux/ro
LD [M] /home/tk/install/belkin_wireless_USB/2008_0718_RT2870_Linux_STA_v1.3.1.0/os/linux/r
make[1]: Leaving directory `/usr/src/linux-2.6.25.16-0.1-obj/i386/pae’
cp -f /home/tk/install/belkin_wireless_USB/2008_0718_RT2870_Linux_STA_v1.3.1.0/os/linux/rt287boot

Then I created a directory:
/etc/Wireless/RT2870STA/ (was this directory suppose to exist already??)

and copied RT2870STA.dat there.

Then I did as the readme file directed and went to the /home/tk/install/belkin_wireless_USB/2008_0718_RT2870_Linux_STA_v1.3.1.0/os/linux directory and typed:

/sbin/insmod rt2870sta.ko
/sbin/ifconfig ra0 inet YOUR_IP up

and got the following message:

YOUR_IP: Unknown host
ifconfig: `–help’ gives usage information.

then I typed: /usr/sbin/iwconfig

and got the following result:
lo no wireless extensions.

eth0 no wireless extensions.

Warning: Driver for device ra0 has been compiled with an ancient version
of Wireless Extension, while this program support version 11 and later.
Some things may be broken…

ra0 RT2870 Wireless ESSID:"" Nickname:""
Mode:Auto Frequency=2.412 GHz
Link Quality:0 Signal level:0 Noise level:113
Rx invalid nwid:0 invalid crypt:0 invalid misc:0

Then I typed: /usr/sbin/iwlist scan
and got the following:

lo Interface doesn’t support scanning.

eth0 Interface doesn’t support scanning.

Warning: Driver for device ra0 has been compiled with an ancient version
of Wireless Extension, while this program support version 11 and later.
Some things may be broken…

ra0 Interface doesn’t support scanning.

Any thoughts on how to get things working?? Where did I go wrong?? was I not suppose to change the settings in the config.mk file so that it can be used with Network Manager??

Thanks.

Can anyone help?? any suggestions on what I need to do to correctly install the driver?? Error messages in the above post.

Thanks in advance.

you need to replace “YOUR_IP” with a proper ip address. See if that helps

Andy

I guess YOUR_IP should be his router IP ?

Probably 192.168.0.1 ?

i am having the same problem with mine but i am totally a newbie and would like to ask how do i “install make, gcc” this is the only part that im not getting. then i think i can figure the rest out. do i make this in yast and if so how do i go about doing it .

make,gcc/gcc++ kernelsources etc need to be installed via YaST - software management. You run make in a console etc.

Andy

so i just tell it to make the file gcc