Suse 11.0 Error loading operating system

I’m having a interesting time loading 11.0

My employer sold some surplus computers and I acquired an HP/Compaq D530 machine. The machine is 2.4ghz P4, 1g memory and 40gb Maxtor hard drive. Before releasing the machine the company used a utility called “killdisk” to clean the hard drives.

I got the machine home, did the Suse 11.0 install (from the “install” option of the live cd.) All goes just fine until time comes to remove the cd and boot from the hard drive and then the error message “error loading operating system” comes up.

After several failed attempts I decided the drive might be bad but before giving up it I re-installed Windows XP on the machine. The install went fine, the machine boots cleanly from the hard disk and I can re-boot and run XP all night with no problems. Back to try the install of Suse again. Selected the option to use the entire hard drive for Suse, install goes just fine, same error when trying to boot from the hard drive. I’ve now re-installed XP for a second time and again it works just fine so that’s what I’m using currently.

Any ideas why Suse won’t work on this crazy computer?

What happens if you have the live CD in when you start it up.

With the DVD in, it would give you options like starting from hard disk.

Can anything happen if you have the live CD in the drive, will it give you an option to start OpenSuse.

maybe for some reason Grub the bootloader didn’t get placed on your drive with OpenSuse, but that seems odd for it to occur 2 times in a row, other than if you accidentally unchecked that 2 times in a row

If I boot from the LiveCd everything works great, if I boot from the hard disk or select “Hard Disk” from the menu the LiveCD presents I get the error “error loading operating system”. I though the same as you but watched carefully and it claims grub was loaded during the install.

I’ve built a number of Suse machines starting back in the 9. series. We currently have a number of Suses machine running here on 10.3, both servers and desktops. I saw this problem once before back on a 10.1 build according to my notes. I finally gave up replaced the hard drive on that machine. The drive I removed is now in a Windows machine and runs just fine. This particular hard disk had also been cleaned using killdisk so that appears to be the common thread here.

Further notes on this problem, since my first post on this thread I’ve installed Ubuntu on the machine and it has exactly the same problem and error message.

If the “killdisk” program is the problem, what could it be doing to a hard disk that allows Windows to be installed but not linux?

Did you let you use the installer’s partition recomendation
or create your own?

Hard to say what might be wrong. But, I can say what I’d do :wink:
try to install XP and then install openSuSE next to it as a dual boot system. Make a note of what grub is doing…

Problem solved, but I’m not sure how!

After three days of alternating installs of Windows XP and several linux distros I have Suse 11.0 up and running just fine. The fix was to install XP and then install SUSE 11 as a dual boot machine. When both OS’s would load o.k. I went back and did a re-install of SUSE wiping out the XP partition. This install worked completely and I now have the machine up and running.

Further experiments with the ‘killdisk’ utility on another older machine show the same problem. I used ‘killdisk’ to wipe out a disk and then did an install of Ubuntu, got the “unable to load operating system” message. Installed Win2k on the machine, runs just file. Re-install of Ubuntu provides the same old error message. Reformatted the drive as a second drive in another computer and put it back in the old machine, Ubuntu load goes just fine. Not sure what ‘killdisk’ really does but the drives it has cleaned seem to need some special attention before loading a linux distro.

never had to deal with such a problem myself, but if there’s something wrong/unusual with disks wiped out with KillDisk, any live CD with tools for file/disk recovery (GUI or console) should be able to report it when you try to format/partition the HDD

I am still having the same problem on HP zt3000 laptop.
I am trying to install opensuse 11.0. The installation goes fine until it’s time to boot from disk and that’s when the “Error loading operating system” comes up.
I will try sheininger’s solution, except I’ll not use Windows XP but Opensolaris - which has installed on this machine perfectly in the past. I’ll post my findings.
I didn’t use “killdisk” but Partition Magic to format the disk on the zt3000.
I used the same CD to install OpenSuse on a T40 IBM laptop and didn’t have any problem. Funnily, I had used Partition Magic to reformat the T40 as well.

I installed Ubuntu 9.0.4 on the zt3000 first, and then ran the Live CD to install OpenSuSE 11.0
When I came to the part where you have to provide disk partition information, I went with the defaults - which meant my Ubuntu installation would be wiped out.
This caused a successful install of OpenSuSE on my laptop. I guess there might have been some problem in the formatting that Partition Magic did for me the first time I was installing OpenSuSE.

Could be something killdisk has done to the mbr; installing Windows writes a useable mbr which can be subsequently amended by Suse install?

I guess only of academic interest now you have it working !

(note to self - get copy of killdisk for next rainy day experimentation lol!)


I believe there is other information in mbr +/- secret partitions that opensuse uses. A BIOS disk format should give you a squeaky clean disk that is not done by “use entire disk” in YaST.

(sorry to post on 2 threads, but I thought this might be useful) I had this issue on an old Compaq computer, and was able to work around it by installing GRUB to the MBR (click “enable” in the setup summary). I also set the compatibility MBR flag (click the Boot Loader link in the install summary > Boot Loader Installation > Boot Loader Options > Write generic Boot Code to MBR).

This post is not too useful. The last post in this thread was done over a year ago !!!


I know this thread is kind of old, but it looked unresolved (installing another OS just to get your computer to boot properly is definitely overkill) so here’s my post:

I think I just had a similar problem with openSUSE 12.1 a moment ago, in that I installed it on a Compaq nc6220, and on reboot it would give me the “error loading operating system” message (just for the record, I don’t know if killdisk was ever run on the computer, though I imagine the previous owner might have). I remembered that the automated partition setup set swap to sda1 and root to sda2, and I thought it was suspicious so I tried the following (it might seem silly that I’m typing this out step by step if you already know how to use grub, but not too long ago, I would have needed this step by step also, so I list it here):

  1. turn on computer with liveCD inside.
  2. Choose the “rescue system” option. It will take you to a login. Use “root” as your login and you won’t need a password.
  3. run “grub”
  4. At the grub prompt try typing in: “root (hd0,0)”.
    If it tells you that filesystem type is unknown, and partition is of type 82 or something like that (that’s actually what it told me), then that’s grub-speak for “sda1 is a swap partition”. So it’d be silly to tell it it’s root.
    For me running “root (hd0,1)” worked. It should tell you the partition is of type 83, and that filesystem is of type ext2fs, or something similar.
  5. Once you tell grub where the correct root partition is, type in “setup (hd0)” and enter, and grub should set the changes to your harddisk.
  6. Type “quit” to quit grub.
  7. Reboot, this time into your harddisk.

Hopefully, now it works.

I am newbie to Linux, so I just follow the guide from The Perfect Server - OpenSUSE 12.1 x86 at HowtoForce. After I ran the update and restart for the first time that was when I got the error loading operating system. My harddrive was config as sda1: swap, sda2: root, sda3: server. So I reinstalled suse again and got the same error. I thought my hard drive was bad. I almost tried the earlier solution to install XP before install suse. Finally, I read the entire thread and found your post. Yes, you are right about the swap volume.

Thank you for step by step, it really helps newbie to Linux like me out there.

Please start a new thread, with a proper title (yours is not 11.0, which is a long time ago and no longer supported).