sudo problem

When using “sudo”, I get this message

sudo: could not load /usr/lib64/ /usr/lib64/ cannot open shared object file: No such file or directory
sudo: the SSS source could not be initialized. Is SSSD installed on your machine?
sudo: no valid sudoer source found; going out
sudo: policy plugin could not be initialized

How do I fix this?

I do not use sudo, but reading this a few questions come to my mind.

  1. Did you follow the advice to check for SSD to be installed? when not why? and when yes, what was the result?
  2. Because most sudo users are ral addicts to it, I assume that you used sudo earlier and that it worked to your satisfaction. What did you change between you last succesfull ud=sgae and now? Any software updates/installes/removals?

What is the content of /etc/nsswitch.conf?

How do I fix this?

Well, it is not default so you must have enabled SSSD integration. What about simply reverting this change?


I agree with “arvidjaar” – you’ve installed “SSSD”, integrated it with “sudo” and then, backed out – without properly removing the SSSD integration with “sudo”.

  • If you’ve removed SSSD then the “sssd-sudo
    ” (5) man page is probably missing – please take a look at this version on “the net”: <>. - There’s also the “Integration with sssd
    ” section in the “sudoers.ldap” man page.

There may also be some entries in the user’s cache – please check the user’s “~/.cache/” directory for anything related to SSSD, LDAP and/or “sudo” – clear the user’s cache.