suddenly connecting to specific wireless networks is impossible

I’m using Leap 42.1, after working a while at home suddenly I cannot connect to my wifi anymore, It just asks for the password over and over again. Other devices are still fine and removing the password allows a connection after deleting the entry in /etc/NetworkManager/system-connections/ and rebooting but an unsecured network is not a solution. Other secured networks are a hit and miss. Changing SSID or password of the wifi didn’t work.

I’ve googled a lot but I can’t pinpoint the problem. I’ve included as much useful output below here, I’m totally confused that it used to work but suddenly broke. Any help is greatly appreciated and if I need to post more relevant data let me know

vivo:/home/johan # lspci
03:00.0 Network controller: MEDIATEK Corp. MT7630e 802.11bgn Wireless Network Adapter

johan@vivo:~> sudo /usr/sbin/iwlist scan
Cell 05 - Address: 4C:9E:FF:09:93:2C
                    Channel:13
                    Frequency:2.472 GHz (Channel 13)
                    Quality=70/70  Signal level=-189 dBm  
                    Encryption key:on
                    ESSID:"Kokosnoot"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=0000001301a84f3f
                    Extra: Last beacon: 40ms ago
                    IE: Unknown: 00094B6F6B6F736E6F6F74
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 03010D
                    IE: Unknown: 2A0104
                    IE: Unknown: 2F0104
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 32040C121860
                    IE: Unknown: 2D1ABC181BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 3D160D080000000000000000000000000000000000000000
                    IE: Unknown: 4A0E14000A002C01C800140005001900
                    IE: Unknown: 7F080100000000000040
                    IE: Unknown: DD090010180201000C0000
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00


dmesg output of connecting:
 5709.338862] wlan0: authenticate with 4c:9e:ff:09:93:2c
 5709.354452] wlan0: send auth to 4c:9e:ff:09:93:2c (try 1/3)
 5709.355961] wlan0: authenticated
 5709.358443] wlan0: associate with 4c:9e:ff:09:93:2c (try 1/3)
 5709.361936] wlan0: RX AssocResp from 4c:9e:ff:09:93:2c (capab=0x411 status=0 aid=2)
 5709.361948] ===>rt2800_sta_add:MT7630
 5709.361966] ===>rt2800_sta_add:MT7630   wcid=33
 5709.361968] Connect to AP MAC: 4c:9e:ff:09:93:2c WCID=33
 5709.361976] BtAFHCtl: COEX AFH Start Ch = 31, AFH End Ch = 78, Channel = 13, CentralChannel = 13
 5709.361977] SendAndesAFH: -->
 5709.361979] SendAndesAFH: LinkStatus = 1, BW = 1, Channel = 13, BssHashID = 1, PktLength = 20
 5709.361981] AsicSendCmdToAndes not need  Rsp!!!
 5709.361984] PCIKickOutCmd (TxCpuIdx = 21)
 5709.361985] SendAndesAFH: <--
 5709.361986] SendAndesWLANStatus: -->
 5709.361988] SendAndesWLANStatus: CoexOperation = 4, WlanStatus = 15, PrivilegeTime = 0, BssHashID = 1, PktLength = 16
 5709.361989] AsicSendCmdToAndes not need  Rsp!!!
 5709.361991] PCIKickOutCmd (TxCpuIdx = 22)
 5709.361994] ==>INT_SOURCE_CSR_7630_HCCA_DMA_DONE
 5709.362016] ==>INT_SOURCE_CSR_7630_HCCA_DMA_DONE
 5709.362241] ieee80211 phy0: rt2x00lib_rxdone: Error - Wrong frame size 0 max 3840
 5709.367456] BtAFHCtl: COEX AFH Start Ch = 31, AFH End Ch = 78, Channel = 13, CentralChannel = 13
 5709.367459] SendAndesAFH: -->
 5709.367461] SendAndesAFH: LinkStatus = 1, BW = 1, Channel = 13, BssHashID = 1, PktLength = 20
 5709.367463] AsicSendCmdToAndes not need  Rsp!!!
 5709.367466] PCIKickOutCmd (TxCpuIdx = 23)
 5709.367467] SendAndesAFH: <--
 5709.367478] ==>INT_SOURCE_CSR_7630_HCCA_DMA_DONE
 5709.372803] wlan0: associated
 5709.394386] wlan0: deauthenticating from 4c:9e:ff:09:93:2c by local choice (Reason: 1=UNSPECIFIED)
 5709.426406] ===>rt2800_sta_remove:MT7630
 5709.426417] BtAFHCtl: COEX AFH Start Ch = 0, AFH End Ch = 0, Channel = 13, CentralChannel = 13
 5709.426418] SendAndesAFH: -->
 5709.426420] SendAndesAFH: LinkStatus = 2, BW = 1, Channel = 13, BssHashID = 1, PktLength = 20
 5709.426422] AsicSendCmdToAndes not need  Rsp!!!
 5709.426424] PCIKickOutCmd (TxCpuIdx = 24)
 5709.426425] SendAndesAFH: <--
 5709.426435] ==>INT_SOURCE_CSR_7630_HCCA_DMA_DONE
 5709.431392] ===>rt2800_sta_remove:MT7630   0x80100 = 0x0
 5709.431394] ===>rt2800_sta_remove:MT7630   0x80100 = 0x0
 5709.438431] cfg80211: Calling CRDA to update world regulatory domain
 5709.441059] cfg80211: World regulatory domain updated:
 5709.441065] cfg80211:  DFS Master region: unset
 5709.441067] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
 5709.441070] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
 5709.441073] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
 5709.441075] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
 5709.441078] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
 5709.441082] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
 5709.441084] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
 5709.441087] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
 5709.441089] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
 5722.546233] wlan0: authenticate with 4c:9e:ff:09:93:2c
 5722.561635] wlan0: send auth to 4c:9e:ff:09:93:2c (try 1/3)
 5722.563444] wlan0: authenticated
 5722.565747] wlan0: associate with 4c:9e:ff:09:93:2c (try 1/3)
 5722.568946] wlan0: RX AssocResp from 4c:9e:ff:09:93:2c (capab=0x411 status=0 aid=2)
 5722.568958] ===>rt2800_sta_add:MT7630
 5722.568976] ===>rt2800_sta_add:MT7630   wcid=33
 5722.568977] Connect to AP MAC: 4c:9e:ff:09:93:2c WCID=33
 5722.568983] BtAFHCtl: COEX AFH Start Ch = 31, AFH End Ch = 78, Channel = 13, CentralChannel = 13
 5722.568984] SendAndesAFH: -->
 5722.568986] SendAndesAFH: LinkStatus = 1, BW = 1, Channel = 13, BssHashID = 1, PktLength = 20
 5722.568988] AsicSendCmdToAndes not need  Rsp!!!
 5722.568990] PCIKickOutCmd (TxCpuIdx = 25)
 5722.568991] SendAndesAFH: <--
 5722.568993] SendAndesWLANStatus: -->
 5722.568994] SendAndesWLANStatus: CoexOperation = 4, WlanStatus = 15, PrivilegeTime = 0, BssHashID = 1, PktLength = 16
 5722.568995] AsicSendCmdToAndes not need  Rsp!!!
 5722.568997] PCIKickOutCmd (TxCpuIdx = 26)
 5722.569001] ==>INT_SOURCE_CSR_7630_HCCA_DMA_DONE
 5722.569351] ieee80211 phy0: rt2x00lib_rxdone: Error - Wrong frame size 0 max 3840
 5722.574462] BtAFHCtl: COEX AFH Start Ch = 31, AFH End Ch = 78, Channel = 13, CentralChannel = 13
 5722.574465] SendAndesAFH: -->
 5722.574466] SendAndesAFH: LinkStatus = 1, BW = 1, Channel = 13, BssHashID = 1, PktLength = 20
 5722.574468] AsicSendCmdToAndes not need  Rsp!!!
 5722.574471] PCIKickOutCmd (TxCpuIdx = 27)
 5722.574472] SendAndesAFH: <--
 5722.574482] ==>INT_SOURCE_CSR_7630_HCCA_DMA_DONE
 5722.579555] wlan0: associated
 5722.597665] wlan0: deauthenticating from 4c:9e:ff:09:93:2c by local choice (Reason: 1=UNSPECIFIED)
 5722.629580] ===>rt2800_sta_remove:MT7630
 5722.629591] BtAFHCtl: COEX AFH Start Ch = 0, AFH End Ch = 0, Channel = 13, CentralChannel = 13
 5722.629593] SendAndesAFH: -->
 5722.629595] SendAndesAFH: LinkStatus = 2, BW = 1, Channel = 13, BssHashID = 1, PktLength = 20
 5722.629596] AsicSendCmdToAndes not need  Rsp!!!
 5722.629599] PCIKickOutCmd (TxCpuIdx = 28)
 5722.629600] SendAndesAFH: <--
 5722.629609] ==>INT_SOURCE_CSR_7630_HCCA_DMA_DONE
 5722.634566] ===>rt2800_sta_remove:MT7630   0x80100 = 0x0
 5722.634569] ===>rt2800_sta_remove:MT7630   0x80100 = 0x0
 5722.641649] cfg80211: Calling CRDA to update world regulatory domain
 5722.644213] cfg80211: World regulatory domain updated:
 5722.644217] cfg80211:  DFS Master region: unset
 5722.644218] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
 5722.644221] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
 5722.644223] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
 5722.644224] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
 5722.644226] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
 5722.644228] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
 5722.644230] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
 5722.644231] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
 5722.644233] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)



johan@vivo:~> tail -n 80 /var/log/wpa_supplicant.log 
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: SME: Trying to authenticate with 4c:9e:ff:09:93:2c (SSID='Kokosnoot' freq=2472 MHz)
wlan0: Trying to associate with 4c:9e:ff:09:93:2c (SSID='Kokosnoot' freq=2472 MHz)
wlan0: Associated with 4c:9e:ff:09:93:2c
wlan0: WPA: Failed to set GTK to the driver (alg=2 keylen=32 keyidx=2)
wlan0: RSN: Failed to configure GTK
wlan0: CTRL-EVENT-DISCONNECTED bssid=4c:9e:ff:09:93:2c reason=1 locally_generated=1
wlan0: CTRL-EVENT-REGDOM-CHANGE init=DRIVER type=WORLD
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-REGDOM-CHANGE init=CORE type=UNKNOWN
wlan0: SME: Trying to authenticate with 4c:9e:ff:09:93:2c (SSID='Kokosnoot' freq=2472 MHz)
wlan0: Trying to associate with 4c:9e:ff:09:93:2c (SSID='Kokosnoot' freq=2472 MHz)
wlan0: Associated with 4c:9e:ff:09:93:2c
wlan0: WPA: Failed to set GTK to the driver (alg=2 keylen=32 keyidx=2)
wlan0: RSN: Failed to configure GTK
wlan0: CTRL-EVENT-DISCONNECTED bssid=4c:9e:ff:09:93:2c reason=1 locally_generated=1
wlan0: CTRL-EVENT-REGDOM-CHANGE init=DRIVER type=WORLD
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-REGDOM-CHANGE init=CORE type=UNKNOWN
wlan0: SME: Trying to authenticate with 4c:9e:ff:09:93:2c (SSID='Kokosnoot' freq=2472 MHz)
wlan0: Trying to associate with 4c:9e:ff:09:93:2c (SSID='Kokosnoot' freq=2472 MHz)
wlan0: Associated with 4c:9e:ff:09:93:2c
wlan0: WPA: Failed to set GTK to the driver (alg=2 keylen=32 keyidx=2)
wlan0: RSN: Failed to configure GTK
wlan0: CTRL-EVENT-DISCONNECTED bssid=4c:9e:ff:09:93:2c reason=1 locally_generated=1
wlan0: CTRL-EVENT-REGDOM-CHANGE init=DRIVER type=WORLD
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-REGDOM-CHANGE init=CORE type=UNKNOWN
wlan0: SME: Trying to authenticate with 4c:9e:ff:09:93:2c (SSID='Kokosnoot' freq=2472 MHz)
wlan0: Trying to associate with 4c:9e:ff:09:93:2c (SSID='Kokosnoot' freq=2472 MHz)
wlan0: Associated with 4c:9e:ff:09:93:2c
wlan0: WPA: Failed to set GTK to the driver (alg=2 keylen=32 keyidx=2)
wlan0: RSN: Failed to configure GTK
wlan0: CTRL-EVENT-DISCONNECTED bssid=4c:9e:ff:09:93:2c reason=1 locally_generated=1
wlan0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="Kokosnoot" auth_failures=1 duration=10 reason=CONN_FAILED
wlan0: CTRL-EVENT-REGDOM-CHANGE init=DRIVER type=WORLD
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-REGDOM-CHANGE init=CORE type=UNKNOWN
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SSID-REENABLED id=0 ssid="Kokosnoot"
wlan0: SME: Trying to authenticate with 4c:9e:ff:09:93:2c (SSID='Kokosnoot' freq=2472 MHz)
wlan0: Trying to associate with 4c:9e:ff:09:93:2c (SSID='Kokosnoot' freq=2472 MHz)
wlan0: Associated with 4c:9e:ff:09:93:2c
wlan0: WPA: Failed to set GTK to the driver (alg=2 keylen=32 keyidx=2)
wlan0: RSN: Failed to configure GTK
wlan0: CTRL-EVENT-DISCONNECTED bssid=4c:9e:ff:09:93:2c reason=1 locally_generated=1
wlan0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="Kokosnoot" auth_failures=2 duration=20 reason=CONN_FAILED
wlan0: CTRL-EVENT-REGDOM-CHANGE init=DRIVER type=WORLD
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-REGDOM-CHANGE init=CORE type=UNKNOWN
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SCAN-STARTED 
wlan0: CTRL-EVENT-SCAN-STARTED 

wlan0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid=“Kokosnoot” auth_failures=2 duration=20 reason=CONN_FAILED

Has the WLAN Router been changed to “accept only known devices”?
And, if so, is the MAC Address of your machine in the list of “known devices”?
[HR][/HR]Check the contents of the “Password Wallet” on your machine – being a KDE user, for me it’s “KWallet” – but, GNOME has something similar.

I checked the MAC filter, it is disabled. I didn’t touch the router in any way and I have the same problem with the wifi at my parent’s place but not with other networks I visited so far, so I think it has got to do with some configuration getting stuck wrong, also considering the reboot that was needed after deleting the networkmanager config file, otherwise the network manager still reported the wifi to be secured when I changed the network to no security at all.

I may have found something specific that could reveal where the problem is. If I configure the router to use only AES encryption instead of TKIP + AES I can succesfully connect, I never changed these settings and in any case the TKIP +AES default settings should work, but at least this hopefully can pinpoint the problem. Does anyone know what to do with this?

I have run into this with some routers, sometimes when the router’s firmware is updated, and sometimes when the router’s firmware is not updated.

… and, in some routers, nothing will work except the solution you found.

BTW: Not a Linux problem, as the same issue sometimes pops up with Windows and Mac machines. It is the router’s firmware.

Your best bet is to stay with the settings you are now using, but if you want, you can check your router for the latest firmware. If it has the latest, then get the previous version and test that. If it does not have the latest version, then test with the latest.

IMHO, though, I would just keep it the way you now have it working.:wink:

The router was to blame. My laptop suddenly stopped having wifi connection again, but other several other devices failed as well, only my tablet kept working. I didn’t change anything in the router but evidently it changed on it’s own. Resetting it fixed it. Having only problem with my laptop made me think that the laptop was the source of problem. I do have to check why the connection failed identically at the other network I was at, might be the same router problem, it made me doubt my laptop as well but that may nog be correct either. Thanks everybody for the help and suggestions!