Sublime Text crashes

I’ve installed clean Sublime Text 3 from stable repo (without any settings, plugins and so on). Open quite a big file (for example 5000 lines). Press ctrl+shift+end (to select full file), next when I release keys - sublime text crashes. At this moment journalctl show the message like this:

Oct 18 13:11:09 kwin_x11[1731]: **QXcbConnection: XCB error: 3 (BadWindow), sequence: 38906, resource id: 67109439, major code: 15 (QueryTree), minor code: 0**

It seems, that Sublime itself is ok - as it works properly with different PCs (however kate, for example, in this case, works ok).

On the internet I’ve found some related topics, like the following:

Noticed, that often people just prevent such logs, but in my case - it crashes the important tool.

Is it possible to fix that problem?

$ kf5-config --version
Qt: 5.9.4
KDE Frameworks: 5.45.0
kf5-config: 1.0

Linux 4.12.14-lp150.11-default

Sublime Text is a commercial product of Sublime HQ Pty Ltd (“Proprietary Limited” – and, therefore, an Australian company … ): <>.
The only openSUSE packages available are those from “community packages” – private user builds …

  • You’re on your own.

I suggest that, you contact the company producing this code editor.
[HR][/HR]Looking at what it’s doing, may I suggest that, you take a look at KDevelop; despite it being a project-orientated (CMake) IDE, the editor does most things that the Sublime Text product seems to be doing …

I know that this doesn’t answer your question, but maybe you can give a try at Atom, it is pretty much the same kind of software but it is open source.

It is not present on the repos but you can download a RPM package from the official site

It’s important that Sublime Text run on openSUSE, Sublime is one of the most recommended advanced text editors around, particularly for coding.

You can’t just say you installed from the “stable repo,” for anyone to understand your problem and possibly attempt to replicate,
You have to provide details that anyone else can use… ie the exact URL of the repo, and every exact step you did.

So, for instance…
Did you update your system fully before installing Sublime?
Have you installed any other related repos, particularly any coding language repos?
Perhaps, what is the exact name of your Sublime package… If it was installed from an rpm, the following can display all package info (name , author, etc)

zypper info sublime

And, of course if you’re following any documentation or guide describing your install process, pls post the link.


I’ve installed OpenSuse Leap 15 only yesterday from USB stick (before I’ve used TW, where this bug presents too). Yes, the system is fully updated.

I’ve followed this steps to install Sublime Text (by stable repo):

$ zypper info sublime-text
Loading repository data...
Reading installed packages...

Information for package sublime-text:
Repository     : Sublime Text - x86_64 - Stable
Name           : sublime-text
Version        : 3176-1
Arch           : x86_64
Vendor         : Sublime HQ Pty Ltd
Installed Size : 23.9 MiB
Installed      : Yes
Status         : up-to-date
Source package : sublime-text-3176-1.src
Summary        : Sublime Text is a sophisticated text editor for code, markup and prose
Description    :

$ zypper lr
Repository priorities are without effect. All enabled repositories share the same priority.

#  | Alias                     | Name                                    | Enabled | GPG Check | Refresh
 1 | NVIDIA                    | NVIDIA                                  | Yes     | (r ) Yes  | Yes
 2 | VLC                       | VLC                                     | Yes     | (r ) Yes  | Yes
 3 | google-chrome             | google-chrome                           | Yes     | ( p) Yes  | Yes
 4 | repo-debug                | openSUSE-Leap-15.0-Debug                | No      | ----      | ----
 5 | repo-debug-non-oss        | openSUSE-Leap-15.0-Debug-Non-Oss        | No      | ----      | ----
 6 | repo-debug-update         | openSUSE-Leap-15.0-Update-Debug         | No      | ----      | ----
 7 | repo-debug-update-non-oss | openSUSE-Leap-15.0-Update-Debug-Non-Oss | No      | ----      | ----
 8 | repo-non-oss              | openSUSE-Leap-15.0-Non-Oss              | Yes     | (r ) Yes  | Yes
 9 | repo-oss                  | openSUSE-Leap-15.0-Oss                  | Yes     | (r ) Yes  | Yes
10 | repo-source               | openSUSE-Leap-15.0-Source               | No      | ----      | ----
11 | repo-source-non-oss       | openSUSE-Leap-15.0-Source-Non-Oss       | No      | ----      | ----
12 | repo-update               | openSUSE-Leap-15.0-Update               | Yes     | (r ) Yes  | Yes
13 | repo-update-non-oss       | openSUSE-Leap-15.0-Update-Non-Oss       | Yes     | (r ) Yes  | Yes
14 | sublime-text              | Sublime Text - x86_64 - Stable          | Yes     | (r ) Yes  | Yes

Because your error is related to the display,
Looks like your Desktop is KDE/Plasma, but will also need to know whether your display is Wayland your Xorg.


Just installed Sublime-text successfully in a LEAP 15 LXQt (fully updated) running as a VMware VM.
I did not test for full functionality, thine sublime-text install complained about not finding a libpng >= 1.6.
By default LEAP 15 already instlls a libpng 16 which I assume should provide what is required, likely to render PNG image files.

So, installed sublime-text select Option 2 (ignore some dependencies)

Result is that I can launch sublime-text from the app menu item.
I’d also expect that the app should be fully functional except possibly when rendering a PNG file.

I’m not sure why you are throwing your specified error,
It suggests some kind of general problem related to your Disply, ie the GPU, its driver and how it’s rendered.
I’m also not sure why a text editor should be sensitive to GPU support issues, it’s not likely that anyone would do any advanced graphics, the needs should be pretty basic.

If you are familiar with Virtualbox or some other virtualization, I’d recommend you do your development in a virtual machine anyway.
It avoids possibly causing serious problems in your bare metal install, if your development environment develops a problem you can simply discard and recreate with minimal pain compared to if the same happened on bare metal.


Yes, a have KDE/Plasma. I consider display is Xorg (I have not changed here default settings during installation). Video card - Nvidia Geforce 210. Nvidia driver - 340.106 (x11-video-nvidiaG03 installed as specified here - SDB:NVIDIA drivers - openSUSE Wiki)
I confirm the complaints about libpng during sublime-text installation, but OpenSuse has package libpng16 - seems, just diff names of the same package.

Have you tried to reproduce the problem by way, I specified in the first post:

Open quite a big file (for example 5000 lines).Press ctrl+shift+end (to select full file), next when I release keys - sublime text crashes.

If I do the same by ctrl+a - no problem.

I tried TWM and IceWM - there is no problem with Sublime Text. Plasma by Wayland does not work. (together 4 variants in SDDM).

Have you considered running your Development in a virtual machine?
Unless you have a special reason to do your coding in your bare metal install, it’s my opinion chances are significant that you’ll need to re-install eventually and not by your choice…
And, development packages can theoretically increase your attack surface, make you more vulnerable to hacking.

I also suspect that in a KDE/Plasma VM, you may not see your described crash.

Even your described crash if proven to be a problem which can be replicated could be categorized as a potential attack vector.

If you’re like to submit a bug to, gather what information you can,
Since you know how to invoke the problem, you can collect additional system logs (journalctl) both before and after the error you posted.
Because Sublime Text is proprietary, a decision may be made not to look into this, so you may also want to report directly to the Sublime people.

Good Luck,

Maybe I’ll try to reproduce the problem in VM (but I don’t gather doing development there). Also, I consider trying GNOME desktop.

I just tried another PC with OpenSuse TW and KDE/Plasma (with a built-in video card, without Nvidia drivers). The problem is reproduced simply. Consider the bug is not bound to a hardware.