Stumped by samba

For about 2 years, I have been using “sneakernet” to network the computers in my house. I have never been able to get either nfs or samba to work.

Yesterday, I tried Swerdna’s excellent sscw and for the first time, I have a real live home network! Well, almost. I first tried setting it up on a laptop and my main desktop. I followed instructions to the letter and it worked as promised. Tonight, I tried adding another pc and it failed.

I followed all the steps in the instructions and, at some level, it must be working. I was able to connect from my main desktop and transfer a file over. When I try to go the other way, I get an error message that it

*Could not connect to host for smb://smb-network/
*
If I try to force it by typing smb:/<netbios-name> both Dolphin and Konqueror crashed. At least until I typed smbclient -L <netbios-name> in the konsole. That returned correct info about my main pc. Still, clicking on Network in Dolphin gives the error.

Any ideas?

BTW, without Swerdna’s script, I wouldn’t have gotten samba working in 10,000 years! … or at least until opensuse 37.2

On Wed October 29 2008 11:56 pm, Prexy wrote:

>
> For about 2 years, I have been using “sneakernet” to network the
> computers in my house. I have never been able to get either nfs or
> samba to work.
>
> Yesterday, I tried -Swerdna’s- excellent sscw and for the first time,
> I have a real live home network! Well, almost. I first tried setting it
> up on a laptop and my main desktop. I followed instructions to the
> letter and it worked as promised. Tonight, I tried adding another pc
> and it failed.
>
> I followed all the steps in the instructions and, at some level, it
> must be working. I was able to connect from my main desktop and
> transfer a file over. When I try to go the other way, I get an error
> message that it
>
> -Could not connect to host for smb://smb-network/
> -
> If I try to force it by typing smb:/<netbios-name> both Dolphin and
> Konqueror crashed. At least until I typed -smbclient -L <netbios-name>-
> in the konsole. That returned correct info about my main pc. Still,
> clicking on Network in Dolphin gives the error.
>
> Any ideas?
>
> BTW, without Swerdna’s script, I wouldn’t have gotten samba working in
> 10,000 years! … or at least until opensuse 37.2
>
>

If you are using KDE4 there is a known bug; try with KDE3.5.x.


P. V.
Cogito cogito ergo cogito sum.

PV is right. OpenSUSE 11.0 is a bit sad for Samba: KDE4’s GUIs are just plain bad with Samba and Gnome has a bug in Nautilus that stops the drill-down to shares from showing the contentes of shares. Samba works fine underneath but the GUIs don’t. KDE3.5 is as PV said, fine. One hopes for improvements in openSUSE 11.1.

PS thanks for the compliments

@swerdna - I really can’t praise you enough for this script. There is stuff in there I never would have guessed at and it solved this network issue for me. Too bad you can’t automate it :wink:

Also, it would go faster if all changes to be made in one place were grouped together, i.e. “make the following changes at yast–>security–>firewall–>etc”. This is an observation, not a complaint. The script works splendidly, even for a novice like me.

Back to the main point: all of these machines are running opensuse 11.0 and kde4. Which is why I don’t understand the different performance. I suppose I could ignore the problem and do a “push and pull” using the machines where the gui works and not using the non-gui one to do either. But, I have a remote machine on another floor of the house where it would be more convenient to have the gui work. Maybe I am crying wolf, because I have not tried it on this last machine yet. Still, if it works 2 out of 3 times, why not every time?

Could easily be someting I overlooked. The script is quite new and consequently not debugged extensively yet. Can you post the report.txt and the Samba config file (smb.conf at /etc/samba/smb.conf) for the machine that doesn’t work properly.

In the meantime, I did a zypper up and things are a bit better. Dolphin and Konqueror still give the error, but if I manually enter “smb:/netbios-name” I can connect to main pc. That no longer causes Dolphin and Konqueror to crash. Here is the report.txt but there’s not much to see since I fixed everything.

Analysis of Samba setup for a Workgroup in Version openSUSE 11.0 (i586)
Do NOT use this script if you have a Domain Controller on the LAN or if
workstation is a Domain Member. This script is only for SOHO workgroups.

Checking the following RPMs:
samba, samba-client, yast2-samba-server, yast2-samba-client, kdebase3-samba
All in the list are installed.
Status: Pass

===============================================================================

Calculatinging the IP range for your Workgroup/LAN

Device name: eth0 IP address: 192.168.10.5 MAC address:xx:xx:xx:xx:xx

Your “Trusted Network” is 192.168.10.0/24
Status: Pass

===============================================================================

Report on Samba daemons

The Samba smb daemon is running
The Samba nmb daemon is running
Status: Pass

Check for active firewall

SuSEfirewall2 is running
Status: Pass

===============================================================================

Check devices carrying Samba comms are in the “External Zone” of SuSEfirewall2

Device eth0 [IP=192.168.10.5] is in the “External Zone” in firewall settings
Status: Pass

===============================================================================

Check SuSEfirewall2 TCP, UDP and outward Broadcast ports for a Workgroup

These TCP ports are open: 139 (netbios-ssn) 445 (microsoft-ds)
These UDP ports are open: 137 (netbios-ns) 138 (netbios-dgm)
These Broadcast ports are open: 137 (netbios-ns) 138 (netbios-dgm)

SuSEfirewall2 TCP, UDP and outward Broadcast ports are open for a Workgroup.
Status: Pass

===============================================================================

Check SuSEfirewall2 for passage of netbios-ns broadcast replies

Firewall allows netbios-ns broadcast replies on trusted network 192.168.10.0/24
Status: Pass

===============================================================================

Each workstation takes a common workgroup/domain name but a unique nebios name.

Samba has been configured for workgroup/domain ==> HOMENET
Samba has been configured with netbios name ==> LABRAT
Status: Pass

[Footnote: If you want to modify either name you can do that in Yast:
Go to Yast → Network Services → Samba Server → Identity. Edit only the
Workgroup and/or Netbios (Host)name. Do not activate for DC or Wins Server]

===============================================================================

Recommended name resolve order = bcast host lmhosts wins (leading two mandatory)
You have name resolve order = bcast host lmhosts wins
Status: Pass

===============================================================================

Checking configuration of Local Master Browser

Your workstation is configured as a Local Master Browser with “os level = 33”.
Status: Pass

===============================================================================

Checking status as a Preferred Master Browser for the LAN

Your Local Master Browser is not configured as the “Preferred Master Browser”.
Status: Pass

–Footnote–For Experts: About Preferred Master Browser------------------------
A Preferred Master generally shares community resources; e.g. file/print server.
Do not have more that one Preferred Master on your LAN. This function is mainly
for experts. If in any doubt, just leave it off. That works fine for SOHO LANs.
You can add/delete Preferred Master and/or alter the os level in Yast →
Network Services → Samba Server → Identity → Advanced → Expert Global
Use the Add/Edit/Delete buttons to modify the settings

===============================================================================

Checking the Samba user database

One user, named prexy, exists in the Samba user database.

Status: Pass

===============================================================================

Incidental (precautionary) checks:
Not a “Wins Server”
Not a “Wins Client”
Not a “Domain Controller”
Not a “Windows Domain Member”

===============================================================================

I don’t see any obvious errors in smb.conf

smb.conf is the main Samba configuration file. You find a full commented

version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the

samba-doc package is installed.

Date: 2008-06-06

[global]
workgroup = HOMENET
printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
map to guest = Bad User
include = /etc/samba/dhcp.conf
logon path = \%L\profiles.msprofile
logon home = \%L%U.9xprofile
logon drive = P:
usershare allow guests = Yes
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
domain logons = No
domain master = No
passdb backend = smbpasswd
security = user
wins support = No
netbios name = labrat
name resolve order = bcast host lmhosts wins
os level = 33
wins server =
[homes]
comment = Home Directories
valid users = %S, %D%w%S
browseable = No
read only = No
inherit acls = Yes
[profiles]
comment = Network Profiles Service
path = %H
read only = No
store dos attributes = Yes
create mask = 0600
directory mask = 0700
[users]
comment = All users
path = /home
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares/
[groups]
comment = All groups
path = /home/groups
read only = No
inherit acls = Yes
[printers]
comment = All Printers
path = /var/tmp
printable = Yes
create mask = 0600
browseable = No
[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin root
force group = ntadmin
create mask = 0664
directory mask = 0775

Share disabled by YaST

[netlogon]

I’m now inclined to believe this has nothing to do with samba. I didn’t have a chance to try this on the remaining pc.

That looks very good to me from the Samba config point of view. There’s some residual crud in [global] but it’s harmless. There are two valid shares there, [homes] and [users] which are accessed a bit differently from windows style shares. They are discussed here:
The Suse/openSUSE Default Shares

If you want a windows style share that should be visible from the get go, use this:
make a directory at /home/prexy/music (or whatever)
add this definition into the bottom of smb.conf

[prexys_music]
path = /home/prexy/music
read only = no
force user = prexy
guest ok = yes

On Thu October 30 2008 11:46 pm, Prexy wrote:

>
> In the meantime, I did a zypper up and things are a bit better. Dolphin
> and Konqueror still give the error, but if I manually enter
> “smb:/netbios-name” I can connect to main pc. That no longer causes
> Dolphin and Konqueror to crash. Here is the report.txt but there’s not
> much to see since I fixed everything.
<snip by PV>
>> I’m now inclined to believe this has nothing to do with samba. I didn’t
> have a chance to try this on the remaining pc.
>
>
Prexy;
I agree, the tip off is that smbclient works properly, this makes it almost
certain to be a GUI problem. Just out of curiosity, had you updated the
machine that seemed to work properly?

P. V.
Cogito cogito ergo cogito sum.

What’s windows style? :confused:

I try to update daily. So, all machines are now in the same state, or at least they should be. Checking just now, I find that I must have two different repos for kde4. The pc that “works” is at 4.1.2 and the problem machine is at 4.0.4 and that pretty much convinces me that is where the problem is.

I admit, the naming of the repos confuses me a bit. :shame:

Very visible and accessible, with little or no security

On Fri October 31 2008 09:56 am, Prexy wrote:

>
> What’s windows style? :confused:
>
> I try to update daily. So, all machines are now in the same state, or
> at least they should be. Checking just now, I find that I must have two
> different repos for kde4. The pc that “works” is at 4.1.2 and the
> problem machine is at 4.0.4 and that pretty much convinces me that is
> where the problem is.
>
> I admit, the naming of the repos confuses me a bit. :shame:
>
>
Prexy;
Thank you for the information. It looks like the Samba problem is fixed with
KDE 4.1.

P. V.
Cogito cogito ergo cogito sum.