Stuck with wrong resolution after fresh install

Hello Everyone,

after having done a fresh install of Leap 15.5 with xfce, my desktop resolution is wrong and stuck at “1024x768*” in the graphical options (no other options are shown). The normal resolution of my screen is 2560x1440, the H. Freq. as shown by my monitor is 88Hz and the V. Frequency is 60Hz.

When running “xrandr --query” I get:

Authorization required, but no authorization protocol specified
xrandr: failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 867, maximum 1024 x 768
default connected 1024 x768+0+0 0mm x 0mm
1024x768 76.00*

I tried editing /.config/xfce4/xfconf/xfce-perchannel-xml/displays.xml

But after a reboot, nothing changes…

Has anyone any idea how I could fix this?

Good to know if you can provide your GPU

This typically means a required driver didn’t load. It’s a common result of trying to install on hardware that is too new for support by the selected OS. The release date of the GPU is typically needed to make such a determination. What CPU/GPU do you have? Is this a laptop that has hybrid graphics (2 GPUs)? Input/output from the command inxi -SGCxxz pasted here will show that information.

Another reason this may happen is that the installation program utilized a boot option “nomodeset” that it imposed upon the installed system and needs to be removed. To see if this is the problem, run the command cat /proc/cmdline. If nomodeset is included in that output, you can test booting without it by striking the E key at the Grub boot menu and removing it before proceeding to boot with F10 or Ctrl-X. If this solves the problem without creating other graphics trouble, then it needs to be removed from /etc/default/grub, and then /boot/grub2/grub.cfg regenerated with command grub2-mkconfig -o /boot/grub2/grub.cfg. For more information about nomodeset and its effect on display modes, open the pinned graphics primer topic at the top of the hardware forum here.

Yes, it’s an NVIDIA GeForce RTX 2070 Super.

I did fire a sudo zypper update to check if everything was installed correctly too.

My CPU is an AMD Ryzen 5, 3600 hand has 6 cores.

It is not a laptop, but a desktop.

This message was wrong.
I tyed the command wrong, see my answer below.

No sorry, I typed the cmd wrong, nomodset isn’t included.

If /etc/X11/xorg.conf exists, try booting with it temporarily renamed or moved.

Yes, it is not included. I misread the cmd above, sorry!

You can install the Nvidia drivers…

I can try it, but on Tumbleweed it made my screen flicker and I had to uninstall them right after the install, so I am not sure, that this is gonna help (even tho Leap might react differently than TW).
Aren’t they installed by default if I do a sudo zypper update and accept the Nvidia repo? I think I did include it in the install and I accepted the keyring during the prompt!

No. See linked SDB.

Don’t be sorry. Web pages often make space between characters seem to disappear. It is helpful to copy and paste instead of retyping it all when a command is presented to try.

If you haven’t already tried installing the proprietary drivers, it could be helpful to the whole community, including you, to try to get the default drivers to behave well. If there is a software bug that can be identified, it needs to be reported and fixed. Once you’ve installed proprietary drivers, it’s usually a frustrating lot of work to purge them.

1 Like

Yes, that’s why I wasn’t really up to it. Especially not with Leap - since I already had some problems with Tumbleweed, but I should probably have reported the problems I had with tumbleweed. I still have to get used to report things :blush: , I am always scared to annoy people :no_mouth: !

So I am still kinda stuck :confused: .

From a customary/normal boot, show us the file Xorg.0.log found in /var/log/ or ~/.local/share/xorg/ if it exists. You can upload it directly from an X terminal, e.g.:

susepaste /var/log/Xorg.0.log


cat /var/log/Xorg.0.log | susepaste

Then if it succeeds, paste here the second/longer of the two resulting URLs.

There you go!

It’s better to install the nvidia driver to unleash the power of the nvidia rtx.
Don’t be scared of installing the driver.

1 Like

The backbreaker is this:

(EE) open /dev/dri/card0: No such file or directory

One possible cause of this is that kernel-default-extra was not installed. That should be an easy fix. Just install it. In Leap, contrary to TW, it supplies the nouveau kernel module NVidia cards have traditionally required when NVidia’s proprietary drivers are not installed. The required drivers for AMD and Intel are provided by kernel-default in Leap, and for all three in TW. I think in newer NVidia cards something else may have replaced the need for nouveau. Whether that’s actually true, and if so, which newer models are new enough, I don’t know anything about.

Command line tells me: the latest version is already installed :thinking: :face_with_peeking_eye: