strange window behavior recently

I believe the last round of updates did something to my window behavior(s)

All I know is when I click Tbird from notification area, it opens behind my open Firefox window.
Skype - same thing.
Hotkey opening for gnome-terminal does it also.

Everything opens behind my whatever program is on the screen (and has focus) atm. Strange.
I don’t believe it acted this way yesterday, before the latest updates.

There’s an 'rpm -q <something> command I can use to view ‘–last’ but I’ve forgotten what it is.

“rpm -qa --last | grep “Aug 2011” | sort -k3” gives me this (partial) output:

glibc-i18ndata-2.11.3-12.17.1                 Thu 18 Aug 2011 09:45:24 AM EDT
glibc-2.11.3-12.17.1                          Thu 18 Aug 2011 09:45:26 AM EDT
glibc-devel-2.11.3-12.17.1                    Thu 18 Aug 2011 09:45:28 AM EDT
libxcrypt-3.0.3-9.10.1                        Thu 18 Aug 2011 09:45:30 AM EDT
glibc-locale-2.11.3-12.17.1                   Thu 18 Aug 2011 09:45:34 AM EDT
libpng14-14-1.4.4-3.4.1                       Thu 18 Aug 2011 09:45:36 AM EDT
libpng12-0-1.2.46-7.3.1                       Thu 18 Aug 2011 09:45:37 AM EDT
pam-modules-11.4-3.4.1                        Thu 18 Aug 2011 09:45:37 AM EDT
pwdutils-3.2.14-4.5.1                         Thu 18 Aug 2011 09:45:38 AM EDT

Desktop Effects are disabled.
Any ideas what to do or try next to restore this functionality?

Thank you for your time.


Created a new user to see if it was system-wide or profile-specific.
The anomaly was not present in new user’s profiles.

Logged out as new user and back in a normal user.
Symptoms are gone.
I had rebooted after the latest updates.

Creating the new user asked me if I wanted to disable auto-magic login and I replied yes.

Deleted “new” user and re-enabled auto-login.
Everything’s good to go.

Go figure.