Strange US(?) keyboard on Tumbleweed!


I’ve used Linux, predominantly SuSE, since the late '90s; I still have my original boxed sets of 6.3, 7.1, 7.2 & 8.0 (all with 6 CD’s + manual) and have run SuSE on a number of strange machines - some desktops built by me and, since entering the laptop age, on others almost wilder & woollier - however, I’ve now hit a problem I’ve never met before.

I have 2 SuSE’s running on my system at the moment:

  1. Leap15
  2. Tumbleweed.
    Leap15 is (more or less) fine but, in Tumbleweed, I can’t lose the American keyboard which is infuriating since, although I can track down all the other symbols, (eg: while, on my UK keyboard: @=", |=<, =>, #=, etc) - which is a ********** nuisance but which I COULD learn to overcome - BUT the American keyboard can produce neither the tilde (~) nor the pound sign (£) - and, dammit, I’m British!

I’ve checked the language on both SuSE’s & they both return:
Bash - 4.4.23 : echo $LANG

I could (but I don’t want to) reinstall both systems. I have upgraded Tumbleweed twice, both times using “zypper dup” and on both occasions I’ve saved the output. I can let you have that if you want it. There may be one or two other things about the system which may be relevant but I’m hoping someone will pop up & say “Do this & everything’ll be OK!”

Thanks in advance for any help


PS. I chose the UK keyboard when I installed T-weed (it worked fine) & since then I’ve done all the usual things in YaST!

This used to be a fault with kde/plasma but I haven’t seen the problem for some time.

To resolve it I used to:

system settings

input devices


put a tick in the ‘configure layouts’ box

add ‘gb’ keyboard

remove the ‘us’ keyboard

That somehow depends on the desktop you use.

Plasma should use the default system keyboard layout as configured with YaST/during the installation (unless you override it in Plasma’s settings, i.e. systemsettings5).
GNOME doesn’t, you need to configure it explicitly per user there AFAIK.

No idea about other desktops, most probably behave like Plasma in that regard though, I think.

Although, if you install some IME like ibus, that might override the system settings in any case.

Check YaST - System - System Keyboard layout. Change it to English(UK). The YaST module has a test area.
Furthermore: both on KDE and GNOME check the keyboard layouts.

OK! - I got it and thanks to you all for your help.

When I worked out how to do it in the “new” all-GUI system, I have to confess that it’s pretty straightforward, BUT always, in the past, the setting your keyboard at set-up always worked and, if it hadn’t, you would have opened YaST, fossicked around amongst the the files you found there until you found what you wanted, changed it and got on with the job. It was easy.

As have said, I can see the “new” way has its advantages but you’re dealing here with someone here who’s first OS was CPM. I can deal with the “old” way but I do have trouble with the “new”.

Thanks, as I’ve already said, to you all - I’m very grateful for your help - and I now have the ~] and the £] where they should be on my keyboard.


ps: The word “fossick” is not recognised by the spelling dictionary here. It’s Australian. It means “search for gold or precious stones in abandoned workings, rivers, etc; or to rummage or search for something” (maybe I’m a bit of a fossicker).

Right-click, then choose “Add to Dictionary” :stuck_out_tongue: