strange, root has permission denied

Hi Guys

just when I thought I had everything built and running as I wanted, Sods law struck.

You that horrible noise you hear as the hard drive fails.
So new 500GB HD, nearly everything restored, Managed to build the app that wanted qmake-qt4 with qmake :slight_smile:

Then went to build its companion app

ran ./bootstrap and got permission denied, chmod to 777 and got the same.
installed the missing autoconf and still got the same.
so I ran each line in bootstrap manually and the configure file was built.

Now I’m getting the same with configure, bootstrap still gives permission denied.

linux-txzs:/home/richard/Hamapps/SDR-svn/dttsp-svn/sdr-core-r570/base/src # ./bootstrap
bash: ./bootstrap: Permission denied
linux-txzs:/home/richard/Hamapps/SDR-svn/dttsp-svn/sdr-core-r570/base/src # ls -ls
total 1128
36 -rw-r–r-- 1 root root 34611 2010-11-11 22:29 aclocal.m4
8 -rw-r–r-- 1 root root 5833 2010-11-11 22:21 am_demod.c
4 -rw-r–r-- 1 root root 1995 2010-11-11 22:21 am_demod.h
0 -rw-r–r-- 1 root root 0 2010-11-11 22:29 AUTHORS
4 drwxr-xr-x 2 root root 4096 2010-11-11 22:29 autom4te.cache
12 -rw-r–r-- 1 root root 9462 2010-11-11 22:21 banal.c
4 -rw-r–r-- 1 root root 879 2010-11-11 22:21 banal.erl
4 -rw-r–r-- 1 root root 3003 2010-11-11 22:21 banal.h
4 -rwxrwxrwx 1 root root 76 2010-11-11 22:21 bootstrap
12 -rw-r–r-- 1 root root 10752 2010-11-11 22:21 bufvec.c
4 -rw-r–r-- 1 root root 3435 2010-11-11 22:21 bufvec.h
0 -rw-r–r-- 1 root root 0 2010-11-11 22:29 ChangeLog
4 -rw-r–r-- 1 root root 1885 2010-11-11 22:21 common.h
4 -rw-r–r-- 1 root root 1199 2010-11-11 22:21 complex.h
0 lrwxrwxrwx 1 root root 37 2010-11-11 22:29 config.guess → /usr/share/automake-1.11/config.guess
0 lrwxrwxrwx 1 root root 35 2010-11-11 22:29 config.sub → /usr/share/automake-1.11/config.sub
180 -rwxr-xr-x 1 root root 182817 2010-11-11 22:29 configure

What did I screw up this time ?

thanks
Richard

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

How is your volume mounted? Get the output of ‘mount’ and post it here.

Good luck.

On 11/11/2010 04:06 PM, rb004a0345 wrote:
>
> Hi Guys
>
> just when I thought I had everything built and running as I wanted,
> Sods law struck.
>
> You that horrible noise you hear as the hard drive fails.
> So new 500GB HD, nearly everything restored, Managed to build the app
> that wanted qmake-qt4 with qmake :slight_smile:
>
> Then went to build its companion app
>
> ran ./bootstrap and got permission denied, chmod to 777 and got the
> same.
> installed the missing autoconf and still got the same.
> so I ran each line in bootstrap manually and the configure file was
> built.
>
> Now I’m getting the same with configure, bootstrap still gives
> permission denied.
>
> linux-txzs:/home/richard/Hamapps/SDR-svn/dttsp-svn/sdr-core-r570/base/src
> # ./bootstrap
> bash: ./bootstrap: Permission denied
> linux-txzs:/home/richard/Hamapps/SDR-svn/dttsp-svn/sdr-core-r570/base/src
> # ls -ls
> total 1128
> 36 -rw-r–r-- 1 root root 34611 2010-11-11 22:29 aclocal.m4
> 8 -rw-r–r-- 1 root root 5833 2010-11-11 22:21 am_demod.c
> 4 -rw-r–r-- 1 root root 1995 2010-11-11 22:21 am_demod.h
> 0 -rw-r–r-- 1 root root 0 2010-11-11 22:29 AUTHORS
> 4 drwxr-xr-x 2 root root 4096 2010-11-11 22:29 autom4te.cache
> 12 -rw-r–r-- 1 root root 9462 2010-11-11 22:21 banal.c
> 4 -rw-r–r-- 1 root root 879 2010-11-11 22:21 banal.erl
> 4 -rw-r–r-- 1 root root 3003 2010-11-11 22:21 banal.h
> 4 -rwxrwxrwx 1 root root 76 2010-11-11 22:21 bootstrap
> 12 -rw-r–r-- 1 root root 10752 2010-11-11 22:21 bufvec.c
> 4 -rw-r–r-- 1 root root 3435 2010-11-11 22:21 bufvec.h
> 0 -rw-r–r-- 1 root root 0 2010-11-11 22:29 ChangeLog
> 4 -rw-r–r-- 1 root root 1885 2010-11-11 22:21 common.h
> 4 -rw-r–r-- 1 root root 1199 2010-11-11 22:21 complex.h
> 0 lrwxrwxrwx 1 root root 37 2010-11-11 22:29 config.guess →
> /usr/share/automake-1.11/config.guess
> 0 lrwxrwxrwx 1 root root 35 2010-11-11 22:29 config.sub →
> /usr/share/automake-1.11/config.sub
> 180 -rwxr-xr-x 1 root root 182817 2010-11-11 22:29 configure
>
>
> What did I screw up this time ?
>
>
> thanks
> Richard
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.15 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJM3HooAAoJEF+XTK08PnB5SN0P+gJNyjY2Gh6Q+yj/f1dR2xZ4
XV3QYccEEF+ci9eU36llNUM7SVW6bm9665C/W85QaikZPucYT8v3So/9L4SmxusJ
YmMHP847ksnCDGxGY4FkWp7gbtvpY4+yf/0vs1nDilbNPpM0C3fQKEbxETwXsHDd
EC0jEnSk1IenwC/0a6VUWB1DdYoShzQSTz1B4Dmz4lC/Mn9D/kiwHbeFlk6kD0U4
pUKT3qqsl3sOktEnSVjQphL9/0AunZattuQtemNaO/1fWzz5KFN7nLsetUYxpdUU
l1TT+VaPo74wmAKZkUsNYK3YZhmsBGdwUcR+6Ak0OHCbzH3cWNlh5EohEdNWJCf/
1gUhB7+9eXp2jfpxSaNmX3jUDTktZiv5j7L0YaheXnkxdPKPgj+8kyRHNY1orcPb
lKl66oOdEwQGNGPWaGVWsCflGfkchHePPWjqO4bs++QDYpNQX1hCAb5qSDsghW8Q
upWfeES+NcjBPrrell5spcAbL3O0diBEpZKV/74lqyNXza38KCF9teLDntz3J1ih
TK6UnIT5yf3PaDkNhRX+amB6b4o9Nz1C9w1EBixjHwoQ1nX96zDtY3x2M7yO5edH
QQw3URFzo7Ii7C1YAoyUjs2GDlKVyECWkGC9g6x3JWFz0Z4cchAmZLrV8rTto6t4
Nru3Gw40KzbP73rYUNHf
=lj7L
-----END PGP SIGNATURE-----

mount:-
/dev/sda2 on / type ext4 (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
devtmpfs on /dev type devtmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,mode=1777)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/sda3 on /home type ext4 (rw,noexec,nosuid,nodev,acl,user_xattr)
/dev/sda4 on /multimedia type ext4 (rw,noexec,nosuid,nodev,acl,user_xattr)
securityfs on /sys/kernel/security type securityfs (rw)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
gvfs-fuse-daemon on /home/richard/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=richard)

HTH

Richard

If I’m not mistaken you are doing something in richard’s home directory under account of linux-txzs?

/home is mounted noexec. This means you can’t run programs in that partition.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Exactly… ‘noexec’ is what I was after. As ken yap mentions it’s
trumping permissions on files. Move your directory structure somewhere
else like /tmp and then it should run, or else remove the noexec flag
(modify /etc/fstab and either remount or reboot). remount would be
something like sudo mount -o remount /home IIRC.

Good luck.

On 11/11/2010 06:06 PM, ken yap wrote:
>
> /home is mounted noexec. This means you can’t run programs in that
> partition.
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.15 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJM3Jy3AAoJEF+XTK08PnB5X3IP/iGgNFFLy79kf5IWgjv1my3W
nVXIwO1/Cmuf5WPgnJzqVk1k4NS69jCn3ocSXmccnIcfUhREPk3bB1O/Leof31jo
juMVr2B7HAaX+csVDfY3mCABTnrZZALN8OcKQ2yM22C7gG7Dzj1/5KeCTHsIbuKq
vihXLVvvyZS4COCcLCQFv2zmEhydwdofBMJBNKFTcYgHqVsorq5+DQ/tFVfWgrgk
1bMBxT+brqNV9pxW1uoetkdcRx+dfzdhPDj+5XoZP32yesePlB6cKx+DT0sAHYoV
LShqhko2AeXR4ax4hETi0K4T0ZWHwuW5GL4xy0va679kwzD7BZM0uMrRNA8kpRfr
yE1BH64wtPfyKTHOf9zgeGyQhA7I2mYJBW3JoLrr/SYIq1+J3PnygXdXntoG3UXd
luU1F2GtA6GePfEc0EF8bTCdMX/87q0Q+FFZ8lyliognbIkLF/cSrvA0GKyLq+hV
pk3420AlGOD7q52iLVRrdA+ZFgSNWhJcTDHCQrsuv0daVKb764YfsWCb/CuvR012
iyyUnbG4iswJfZj3B0e4TUQa6gWJUP5Djbj8sbFPGDdfxVHhsznvp2/fiPAaHqMm
YNlKutiUzPkMnJ3wQOwGZfZbtVXZEvmti0cuZSng4wqwNDRfIGtCBX0FqeRrzp5m
HhC+tu+ccezUSohY/xeL
=LUr9
-----END PGP SIGNATURE-----

Thanks guys

is that normal on an install of suse to add the noexec flag to /home ?.
I haven’t come across that on other distros I’ve used.
I know Suse has a reputation for having its own peculiarities, as long as I know what they its not a problem.
I should have spotted that, bit tired after a complete reinstall and rebuild, 5 hours from new hard drive instal and recover 90% of the old HD contents.

thanks
Richard

Sorry mailed a reply too soon
Just went edit fstab , and cant see the noexec flag to remove ??
contents of fstab:
/dev/disk/by-id/ata-Hitachi_HDS721050CLA362_JPB540HA111KXB-part2 / ext4 acl,user_xattr 1 1
/dev/sda3 /home ext4 user,acl,user_xattr 1 2
/dev/sda4 /multimedia ext4 user,acl,user_xattr 1 2
/dev/disk/by-id/ata-Hitachi_HDS721050CLA362_JPB540HA111KXB-part1 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0

I’ll change the name of this computer before the next reboot, to avoid any confusion.
I’ve looked through sysconfig to see if there is any security setting to change the mounting of /home, but can’t see any thing

but I did find it in mtab, so removed the flag.
now to reboot :frowning: ?

Richard

Noexec and nosuid are implied by user. There’s no reason to specify user for non-removable filesystems. It’s not normal, you must have turned on user when installing the system. Ditto for sda4.

No good just removing in mtab. Mtab is regenerated every boot from fstab.

rb004a0345 wrote:
> is that normal on an install of suse to add the noexec flag to /home

nope, i’ve never ever seen it before…
did you do this http://tinyurl.com/25ydj4a before install?

did you have any errors during install?


DenverD
CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

Thanks Ken
I’ve remove user from the two partitions and back to normal.

Richard