Strange lines with ATI Radeon x300

I think Fedora uses newer xorg/mesa/radeon with KMS and DRI2.

I just looked around in the openSUSE software search for new Mesa packages and found this repository:

linux@linux:~> zypper sl -u | grep xorg
4 | xorg         | xorg                  | Yes     | Yes     | rpm-md |

I updated all packages to versions from this repository, init 3, rmmod radeon, rmmod drm, modprobe radeon, init 5 - and what can I say?
I got Kernel modesetting, DRI2, new radeon driver without any artifacts and reasonable performance using EXA Acceleration.
Window moving and resizing is reaaaalllllly smooth - haven’t seen this before on that X600 Mobility chip.

Well, seems that we radeon users will have to wait for 11.3 or even 12.0 to get reasonable acceleration - and I wonder how long my old notebook will survive :wink:

Important Warning:
I’ve done this by booting the KDE Live CD via USB and installing the packages on the fly. Don’t try this at home :wink:
Another point: glxgears performance went down by about 50% :-/

Yes, I’ll say they are new.

I note

  • xorg updated from 7.4-6 (11.2 oss) to 7.4-155 (jobermayr repos)
  • drm updated from 2.4.14-2 (11.2 oss) to 2.4.99_20091123 (jobermayr repos) - That is an update from yesterday ! speaking of cutting edge !
  • Mesa updated from 7.6-3.1 (11.2 oss) to 7.7.99_20091123 (jobermayr repos) - That also is an update from yesterday ! speaking of cutting edge !

I wonder what version the Fedora has ?

First, a warning:
Don’t use these drivers on your main production system.

  • Firefox scrolling was awfully slow (where konqueror was very fast)
  • Screen garbage after suspend to ram (could not get it working again without a reboot)

Well, I don’t know which version Fedora use… but I know that they love being bleeding edge with KMS support etc.

IIRC, openSUSE disabled KMS and modesetting (and afaik DRI2) in some Milestone release because there were performance problems.
That might be the slow scrolling and slower glxgears what I’ve seen.

I wonder what Fedora has done to fix those issues…

Iam sorry by “new Fedora release” i ment Fedora12, i just assumed people follow what happend around in the linux world.

I don’t think KDE is the issue, Fedora has 4.3.2 while my openSUSE 11.2 has 4.3.3 and i had the same issues from milestone7-8-rc1-rc2 with KDE 4.3.1 on a ATI x1400 mobility radeon.

I don’t have Fedora installed so i can’t answer all the questions you asked but from the release notes it seems Fedora12 uses the same kernel version as openSUSE11.2, on the other hand as others have said they use bleeding edge stuff.

There is a clear difference in performance between them when it comes to the opensource ati drivers. While i stopped caring and just switched off desktop effects on my openSUSE box, new users might not.

I go through phases where I look at other distributions. There are many distributions and right now I’m in a phase where I don’t bother looking at the most current distribution other than openSUSE.

I used to have a dual Fedora / openSUSE dual boot on a sandbox PC (over a year ago) but have no longer. But surely there must be an openSUSE user somewhere who has both distributions installed, who can check the versions.

My Sandbox PC has a nVidia FX5200 graphic card, so re-installing the latest Fedora (12) on that PC would not possibly add much to this thread.

Can someone else provide this detail ?

I note distrowatch has Fedora-12 as having 1.7.1 xorg-server while openSUSE-11.2 is listed as having 1.6.5 xorg-server. Both have the same kernel, and similar KDE versions (KDE-4.3.1 vs 4.3.2).

Indeed the ATI driver situation with 11.2 is unsatisfactory wrt new users. This is especially true where for some graphics hardware, it appears that the new autoprobe of graphics (to setup the opensource (openGL) ati, radeon, or radeonhd) driver does not work (or if it works, the driver does not work), and some new users are left with a black screen upon install. This did NOT happen to me with my wife’s PC (with an ATI RV280 (ie a 9200). I’m hoping Novell/SuSE-GmbH update the appropriate xorg-X11 driver file (or what ever file might be relevevant ) to stop this black screen on install from happening, possibly by having that file available as an immediate download during installation.

This sounds like the same problem I have found with my Radeon X600. If possible could you add additional system information to the bug?

I just ran the Fedora 12 KDE LiveCD. X -version reports this:

X.Org X Server 1.7.1
Release Date: 2009-10-23
X Protocol Version 11, Revision 0
Build Operating System:  2.6.18-164.2.1.el5
Current Operating System: Linux localhost.localdomain #1 SMP Sat Nov 7 21:41:45 EST 2009 i686
Kernel command line: initrd=initrd0.img root=live:CDLABEL=Fedora-12-i686-Live-KDE rootfstype=auto ro liveimg quiet  rhgb rd_NO_LUKS rd_NO_MD noiswmd vga=0x342 BOOT_IMAGE=vmlinuz0
Build Date: 05 November 2009  07:43:20PM
Build ID: xorg-x11-server 1.7.1-7.fc12
Current version of pixman: 0.16.2

Mesa appears to be 7.6.

I also installed mesa from the above mentioned repository in OpenSUSE, and it seems KMS is working and DRI2 gets loaded. However, when I turn desktop effects on, I get a white screen with a mouse cursor. Then it reverts back to no desktop effects. I did notice in the dmesg output that the microcode (R100) for my card (which is ATI Mobility U1) fails to load, and that GPU acceleration is disabled. My knowledge is quite limited so I don’t know if I could fix any of that.

On the other hand, on Fedora’s LiveCD, the microcode gets loaded ok (R100_cp.bin), and I see no GPU-related errors in dmesg. KWin’s desktop effects are lightning fast, no distortions on the screen, no problems with scrolling.

kubuntu 9.10 is also problem free. From the #549226 bug report:

I also have this problem. Using 11.2 64bit release with an ATI X700 mobile. I briefly tested a Fedora12(kde) and kubuntu livecd, and neither presents these problems.

All three use Mesa 7.6. But while opensuse uses ati driver 6.12.4, fedora uses ati driver 6.13 (20091006git) and kubuntu uses 6.12.99 (29092009git)

Is there an easy way i can revert to the default packages if i fell like trying the files on that “jobermayr” repo and things go wrong?


i couldn’t edit my previous post… so anyway, i’ve using the files from jobermay and so far so good :slight_smile:


I have this graphics card…
ATI Technologies Inc RV370 [Radeon X300SE] [1002:5b70]

Is there proprietary drivers for this yet. I am new to openSuse 11.2. When i tried using the desktop effects i got those same lines he was talking about and i got freezing.

Compiz fusion effects worked fine for me with the same graphics card with Linux Mint, so i am sure it should work with openSuse. Right?..

There will never be proprietary drivers for that card for any Linux distribution released after Feburary 2009. Specifically, any Linux distro with a kernel version greater than 2.6.27 (I think) and X.Org version greater than 7.3. You may thank AMD for this.

The good news is that there is a pretty decent open source driver that supports your card, and it’s getting better every day. You’re probably using it right now. You can read about it here on the wiki. However, the open source driver doesn’t have as good 3D performance as the proprietary one yet. If you really need the proprietary driver, you may want to consider using an earlier version of openSUSE (i.e. 11.1) or another distro that uses kernel and X.Org versions supported by the driver.

Updating to Mesa 7.7 should fix this… there’s a link to a one click install for that on the bottom of the wiki page.