Static IP set, but it gets a dynamic IP ???

I had a computer with oepnsuse 15.1, I have just upgraded to 15.2 with a DVD image.
It was set to use static IP … and I think already is, but after booting some times it gets the static IP and sometimes it gets a dynamic ip



Klick in the 2. picture on modify and set the IP.

Or post:

cat /etc/sysconfig/network/ifcfg-eth0

@OP, I’m assuming your system that dishes out DHCP addresses does not issue them for the range of static ip’s in use?

tutatis:/home/fperal # cat /etc/sysconfig/network/ifcfg-eth0
NAME='RTL8153 Gigabit Ethernet Adapter'
tutatis:/home/fperal # 

no, the static IP configured is the dynamic IPs are above, when it gets the dhcp address it get it from the pool.

Looks to me you’re set up properly.

  1. Inspect your DHCP active and reserved leases for any entries using your client machine’s MAC address. If you see any, remove entries. This might especially be an issue if you’re running network security that integrates DHCP, DNS and Directory Services like Active Directory.

  2. Verify no other machines on your network are configured with the same machine name (should be unique on your network) or using the same MAC address.

Again referring to integrated network security services, I wonder if somehow your pre-upgrade machine data might be stored somewhere and is confused when you login with your upgraded machine info. But, if you’re not running advanced network security and your network services are all separate and simple, this is unlikely.


It happened with the same computer in two different places. I brought the server to my home to work on it and it happened twice or three times, then I switched it off, took it to my office, booted it there and it got again a DHCP address (a different one because is a different range in my office that in my home) that it has got in my home. Then I deleted the interface and create it again with the static IP (but exactly the same configuration as previously), switched it off, switched it on again, fine, static IP ok… but I don’t know if it will last, in fact now I can access the computer from my home but I don’t even think on rebooting it remotely because if it changes the IP then it will be no longer accessible.

Except in very rare configurations, the IPv6 address must use the same prefix as the gateway router you connect to.
So, if your machine is moving from network to network,

  • You should know your IPv6 address <must> change
  • You cannot configure incoming network connections to use the IPv6 address if your machine changes locations
  • You can use a type of dynamic DNS to support using FQDN to access a resource with multiple or changing IP addresses.

So, if IPv6 won’t work for your purposes,
Avoid using it.
Either ignore the IPv6 error or disable it if you aren’t able to set it up to support what you’re doing.

IPV6 is disabled (in yast)

I chaged the network card because of errors (it went down several times) and since I did it it aparently stopped loosing the static IP, but today I have done a ip addr and I found this

tutatis:~ # ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
2: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 50:3e:aa:12:6b:4a brd ff:ff:ff:ff:ff:ff
    inet brd scope global dynamic noprefixroute eth1
       valid_lft 2578sec preferred_lft 2578sec
    inet brd scope global secondary noprefixroute eth1
       valid_lft forever preferred_lft forever
    inet6 fe80::c411:607b:5cad:49e2/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

I am almost sure I had disabled IPV6.

And it has two IPs in the same interface eth1, the static IP I have set and another IP wich is getting through dhcp.

Maybe the solution to this strange behaviour is to remove th dhcp-client package